添加中文输入法 failed

为当前最终发行版之前的所有版本提供支持
回复
cybersome
帖子: 9
注册时间: 2006-04-24 1:53
送出感谢: 0
接收感谢: 0
联系:

添加中文输入法 failed

#1

帖子 cybersome » 2006-08-07 17:21

cybersome@cybersome-desktop:~$ $sudo apt-get install fcitx
E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
cybersome@cybersome-desktop:~$
My Blog:图片
XNA:图片
cybersome
帖子: 9
注册时间: 2006-04-24 1:53
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 cybersome » 2006-08-07 19:27

help~~~~
My Blog:图片
XNA:图片
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#3

帖子 oneleaf » 2006-08-07 19:34

E: Could not open lock file /var/lib/dpkg/lock - open (13 Permission denied)
不要运行命令时打开新立得。
cybersome
帖子: 9
注册时间: 2006-04-24 1:53
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 cybersome » 2006-08-08 11:22

a 大概是那时候刚装完ubuntu在下载/安装一大堆更新的原因

改成中文系统了,好像输入法自动有了?! :P

按照“快速设置指南/DapperDrake - UbuntuChina Wiki”
cybersome@cybersome-desktop:~$ sudo gedit /etc/apt/sources.list
Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Loading socket FrontEnd module ...
Starting SCIM as daemon ...
GTK Panel of SCIM 1.4.4

cybersome@cybersome-desktop:~$ sudo apt-get update
E: 无法获得锁 /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: 无法对状态列表目录加锁
cybersome@cybersome-desktop:~$ sudo apt-get update
E: 无法获得锁 /var/lib/apt/lists/lock - open (11 Resource temporarily unavailable)
E: 无法对状态列表目录加锁
cybersome@cybersome-desktop:~$ sudo apt-get dist-upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在筹划升级... 完成
下列的软件包将被升级:
vim vim-common vim-runtime
共升级了 3 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 7299kB 的软件包。
解压缩后会消耗掉 7532kB 的额外空间。
您希望继续执行吗?[Y/n]y
【警告】:下列的软件包不能通过验证!
vim vim-common vim-runtime
不经验证就安装这些软件包么?[y/N] y
获取:1 http://mirror.lupaworld.com dapper/main vim 1:7.0-010+1ubuntu1 [710kB]
获取:2 http://mirror.lupaworld.com dapper/main vim-common 1:7.0-010+1ubuntu1 [208kB]
获取:3 http://mirror.lupaworld.com dapper/main vim-runtime 1:7.0-010+1ubuntu1 [6381kB]
下载 7299kB,耗时 9m19s (13.1kB/s)
(正在读取数据库 ... 系统当前总共安装有 75090 个文件和目录。)
正预备替换 vim 1:6.4-006+2ubuntu6 (使用 .../vim_1%3a7.0-010+1ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 vim ...
正预备替换 vim-common 1:6.4-006+2ubuntu6 (使用 .../vim-common_1%3a7.0-010+1ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 vim-common ...
正预备替换 vim-runtime 1:6.4-006+2ubuntu6 (使用 .../vim-runtime_1%3a7.0-010+1ubuntu1_all.deb) ...
正在解压缩将用于更替的包文件 vim-runtime ...
正在设置 vim-common (7.0-010+1ubuntu1) ...
正在安装新版本的配置文件 /etc/vim/vimrc ...

正在设置 vim-runtime (7.0-010+1ubuntu1) ...
正在设置 vim (7.0-010+1ubuntu1) ...

cybersome@cybersome-desktop:~$
cybersome@cybersome-desktop:~$ sudo fontconfig-voodoo -f -s zh_CN
cybersome@cybersome-desktop:~$ sudo apt-get install xfonts-wqy
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 xfonts-wqy
cybersome@cybersome-desktop:~$ sudo apt-get install xfonts-wqy
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 xfonts-wqy
cybersome@cybersome-desktop:~$ sudo gedit /etc/fonts/conf.d/50-xfonts-wqy.conf
cybersome@cybersome-desktop:~$ sudo apt-get install sun-java5-jre
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 sun-java5-jre
cybersome@cybersome-desktop:~$ sudo apt-get install sun-java5-jdk
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法找到软件包 sun-java5-jdk
cybersome@cybersome-desktop:~$ sudo update-alternatives --config java

There are 2 alternatives which provide `java'.

Selection Alternative
-----------------------------------------------
1 /usr/bin/gij-wrapper-4.1
*+ 2 /usr/lib/jvm/java-gcj/jre/bin/java

Press enter to keep the default[*], or type selection number:
cybersome@cybersome-desktop:~$
好像遇到了些问题....
My Blog:图片
XNA:图片
头像
zhan
帖子: 1880
注册时间: 2005-08-15 0:04
来自: 南7技校
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 zhan » 2006-08-08 12:16

去wiki上面看看,把sources.list改一下。找不到软家是源的问题。
飞得高,飞得低,学习再学习,多少大秘密!
http://zhan.blog.ubuntu.org.cn
回复

回到 “老旧版本支持”