[教学]Ubuntu中安装perl/Tk

为当前最终发行版之前的所有版本提供支持
回复
bestdz
帖子: 4
注册时间: 2006-08-02 22:26
送出感谢: 0
接收感谢: 0

[教学]Ubuntu中安装perl/Tk

#1

帖子 bestdz » 2006-08-09 10:58

这两天安装perl/Tk
弄得焦头烂额
现在终于眼看可以正常编译了... 哇哈哈

tar -xzvf PerlTk-804.027.tar.gz
cd PerlTk-804.027

(gedit INSTALL查看帮助文档,确实很有用)

perl Makefile.PL
一开始我就是老在这一步出错,提示找不到X include files,开始以为是Ubuntu中的路径跟它的默认路径不一样,于是根据帮助文档和网上查找的资料更改X11参数(注意如果lib文件和include文件不在同一个文件夹下,则要分别设置X11INC参数和X11LIB参数),但是结果还是不行。
后来我发现Ubuntu的/usr/include/X11文件夹下只有一个bitmap文件夹,并没有其他的.h文件,怀疑是默认安装的Ubuntu中并不包括所需的X11 include文件!
在新立得软件包管理器中,选择 “全部”,在右边单击选择任一个文件,在键盘上按下X11,选择所有X11开头的那些软件包(也不知道到底哪些是需要的,只好全选啦),安装。
这回终于可以编译了,/usr/include/X11文件夹下果然多了一个所需的Xlib.h文件!

make
make test
make install
(注意,有时候有错误出现,应该尝试 sudo make, sudo make test, sudo make install)

搞惦!


接触Linux才几天,深深喜欢上了Ubuntu,第一次发技术类的贴,跟大家分享一下,呵呵,见笑了 :)-
回复

回到 “老旧版本支持”