在XGL下看电影很卡。。。

为当前最终发行版之前的所有版本提供支持
回复
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

在XGL下看电影很卡。。。

#1

帖子 天蝎网子 » 2006-08-12 20:54

XGL效果是很炫,可是在它下面看电影很卡。。。

用普通的gnome下看电影都没这问题~~

不知道有没有什么好的解决方案。。。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-08-12 23:55

我的一点不卡,不知楼主如何设置的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

#3

帖子 天蝎网子 » 2006-08-13 0:50

zhuqin_83 写了:我的一点不卡,不知楼主如何设置的。
窗口播放下不卡,全屏以后就卡了。。。声音和画面都不同步了,哎。

我是参考这个帖子安装的
viewtopic.php?t=16777
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-08-13 1:53

http://wiki.ubuntu.org.cn/Xgl_compiz_HowTo
我是用这个方法(第二个howto)安装的,没有任何问题。以前也用lz看的帖子安装,结果失败。
我放1280*1024的avi格式全屏一点不卡的。
好像论坛里有一篇关于xgl下影片播放卡的解决方法,lz可以搜一下。
对了,lz用什么播放器的?如果是mplayer,则要设置一下视频驱动(video driver)。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

#5

帖子 天蝎网子 » 2006-08-13 2:26

zhuqin_83 写了:http://wiki.ubuntu.org.cn/Xgl_compiz_HowTo
我是用这个方法(第二个howto)安装的,没有任何问题。以前也用lz看的帖子安装,结果失败。
我放1280*1024的avi格式全屏一点不卡的。
好像论坛里有一篇关于xgl下影片播放卡的解决方法,lz可以搜一下。
对了,lz用什么播放器的?如果是mplayer,则要设置一下视频驱动(video driver)。
我用的是mplayer, 你说是选择视频驱动是指mplayer参数设置里边的吗? 我video选的是X11...
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2006-08-13 2:33

个人感觉mplayer设置之后还是没有totem流畅。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
IdeaLee
帖子: 90
注册时间: 2006-01-29 9:29
送出感谢: 0
接收感谢: 0

#7

帖子 IdeaLee » 2006-08-13 10:54

我的在 xgl 也没什么问题,设置了 gl2 的 vo 非常流畅的播放,快进什么的都比 Windows 下的快……
在现实面前,当然是理想错了……
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

#8

帖子 天蝎网子 » 2006-08-13 16:27

IdeaLee 写了:我的在 xgl 也没什么问题,设置了 gl2 的 vo 非常流畅的播放,快进什么的都比 Windows 下的快……
选了gl2还是不行,声音和画面都不同步了。CPU占用高。而且画面长宽比失调。。。。 :(
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

#9

帖子 天蝎网子 » 2006-08-15 18:51

顶~~~
lvscar
帖子: 59
注册时间: 2005-08-21 0:41
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 lvscar » 2006-08-16 13:58

我这里 是 ati的卡 xgl下 mplayer 看电影用 vo=xv 很好。
头像
天蝎网子
帖子: 162
注册时间: 2005-09-30 1:22
送出感谢: 0
接收感谢: 0

#11

帖子 天蝎网子 » 2006-08-16 17:01

lvscar 写了:我这里 是 ati的卡 xgl下 mplayer 看电影用 vo=xv 很好。
全屏也OK吗?

我窗口下播放也不卡,就是全屏的时候,CPU占用就100%了。
lvscar
帖子: 59
注册时间: 2005-08-21 0:41
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

#12

帖子 lvscar » 2006-08-22 18:16

天蝎网子 写了:
lvscar 写了:我这里 是 ati的卡 xgl下 mplayer 看电影用 vo=xv 很好。
全屏也OK吗?

我窗口下播放也不卡,就是全屏的时候,CPU占用就100%了。
十分ok。

小提示
1. 配置你的compiz,使其不重渲染全屏(unredirect fullscreen windows) 你可以在gset-compiz里设置

2. 确定你的 xgl 启动脚本 里有 -accel xv:

下面的是我的
#!/bin/bash
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 2 && DISPLAY=:1 gnome-session

3. 升级xgl/compiz 目前 我这里运行 quake3 , google earth 均没问题。
回复

回到 “老旧版本支持”