reiserfs格式与fstab设置

为当前最终发行版之前的所有版本提供支持
回复
头像
xxdaystar
帖子: 225
注册时间: 2006-07-28 14:58
来自: 廣州
送出感谢: 0
接收感谢: 0

reiserfs格式与fstab设置

#1

帖子 xxdaystar » 2006-08-14 22:08

我有一个reiserfs格式的分区,想让他自动挂载,且一般用户有写入的权力。修改fstab如下:
/dev/hdb9 /mnt/store reiserfs user,rw,utf8,umask=002 0 0
挂载时发现reiserfs下认不出参数umask等,信息如下:

xxdaystar@myubuntu:~$ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hdb9,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so
xxdaystar@myubuntu:~$ dmesg | tail
[17179966.108000] ReiserFS: hdb9: using ordered data mode
[17179966.120000] ReiserFS: hdb9: journal params: device hdb9, size 8192, journal first block 18, max trans len 1024, max batch 900, max commit age 30, max trans age 30
[17179966.120000] ReiserFS: hdb9: checking transaction log (hdb9)
[17179966.124000] ReiserFS: hdb9: Using r5 hash to sort names
[17180072.572000] NTFS volume version 3.1.
[17180072.700000] NTFS volume version 3.1.
[17180073.100000] ReiserFS: hdb9: warning: unknown mount option "utf8"
[17180136.952000] NTFS volume version 3.1.
[17180137.076000] NTFS volume version 3.1.
[17180137.416000] ReiserFS: hdb9: warning: unknown mount option "umask=002"

请问应该如何挂载才能让普通用户有写入的权力呢?我把"utf8,umask=002"去掉,su能挂载但是写入权限并不是自己想要的那样,普通用户也挂不了。
又或者reiserfs有特殊的限制?希望大家给个答案。Thanks!
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#2

帖子 gnix_oag » 2006-08-14 22:29

/dev/hdb9 /mnt/store reiserfs umask=000 0 0
头像
xxdaystar
帖子: 225
注册时间: 2006-07-28 14:58
来自: 廣州
送出感谢: 0
接收感谢: 0

#3

帖子 xxdaystar » 2006-08-14 22:35

谢谢回复(错别字,改),照办。结果如下:

xxdaystar@myubuntu:~$ sudo mount -a
mount: wrong fs type, bad option, bad superblock on /dev/hdb9,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

xxdaystar@myubuntu:~$ dmesg | tail
[17182283.136000] NTFS volume version 3.1.
[17182283.536000] NTFS volume version 3.1.
[17182284.008000] ReiserFS: hdb9: warning: unknown mount option "umask=000"

它是认不出umask参数啊~~
huanlin
帖子: 5
注册时间: 2006-02-19 17:32
送出感谢: 0
接收感谢: 0

#4

帖子 huanlin » 2006-08-22 20:52

楼上的兄弟,reiserfs文件系统不支持umask=xxx选项,节哀顺变吧!解决的方法是mount之后,对于创建的文件和目录改变其权限:
sudo mkdir -pv /mnt/foo/bar
sudo chmod xxx /mnt/foo/bar
头像
xxdaystar
帖子: 225
注册时间: 2006-07-28 14:58
来自: 廣州
送出感谢: 0
接收感谢: 0

#5

帖子 xxdaystar » 2006-08-23 19:31

谢谢楼上兄弟的回复,今天才看到。其实我猜也是这样的。
只是一直不很明白reiserfs与另外一个文件格式的区别/
头像
ghostry
帖子: 1532
注册时间: 2008-07-23 20:08
来自: http://www.ghostry.cn
送出感谢: 0
接收感谢: 1 次
联系:

Re: reiserfs格式与fstab设置

#6

帖子 ghostry » 2010-08-26 11:56

UUID=23abb3d7-f121-4e91-aee7-88098d8071ee /home/momo/workspace reiserfs defaults 0 2
我这样写的由于momo是我有权限的文件夹。挂载过来之后,直接所有者就是我。
不过有个缺点。 :em04 桌面上会显示一个图标。就像挂载的移动硬盘那样。。。
http://www.ghostry.cn狂网技术工作室,组网建站,平面设计,java项目,空间域名.
好心人点这里进去注册并且用一次,给我增加点流量http://tinyurl.com/272ncjl
电脑配置:
公司:880G/II250/1TB/2G1333/
家:785G+/II245+/1TB/2G677/
回复

回到 “老旧版本支持”