当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 6 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [问题]启动后eth0没有通过dhcp分配IP的问题
帖子发表于 : 2006-08-16 22:01 

注册: 2005-08-20 18:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
环境:ubuntu 6.06

配置:
一切正常。
/etc/network/interfaces 的是:
auto eth0
iface eth0 inet dhcp

症状描述:
启动好了以后,eth0没有dhcp到IP。但是ifdown eth0 & ifup eth0就拿到IP了
检查启动文件,发现在/etc/init.d/networking里面ifup -a的时候,eth0已经起来了(但是没有拿到IP),所以什么也没有做。
然后发现是/etc/init.d/udev里面执行udevplug的时候,把eth0起来了。

请问这个应该怎么解决?难道是ubuntu的bug么?


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-08-17 16:14 
头像

注册: 2006-04-29 21:45
帖子: 269
地址: Shanghai
送出感谢: 0 次
接收感谢: 0 次
关注


_________________
ubuntu edgy
blog:http://renexu.blogspot.com/


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2006-08-17 22:43 
头像

注册: 2005-08-14 21:55
帖子: 58428
地址: 长沙
送出感谢: 4
接收感谢: 272
/etc/resolv.conf 有吗。


_________________
● 鸣学


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2006-08-18 22:36 

注册: 2005-08-20 18:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
eexpress 写道:
/etc/resolv.conf 有吗。


有的,而且我实验了一下,是这样:
如果我手动把/etc/resolv.conf删除,重启以后是没有这个文件的。
而我手动ifdown eth0 & ifup eth0,/etc/resolv.conf又重新出现了

而且我发现,启动的时候,在执行完/etc/rcS.d/S10udev 以后,进程里面会出现下面两个,而且会一直存在
root 2322 1 0 22:24 ? 00:00:00 /sbin/ifup --allow auto eth0
dhcp 2382 2322 0 22:24 ? 00:00:00 dhclient3 -pf /var/run/dhclient.eth0.pid -lf /var/lib/dhcp3/dhclient.eth0.leases eth0


页首
 用户资料  
 
5 楼 
 文章标题 : 呵呵
帖子发表于 : 2006-08-19 14:25 

注册: 2006-08-19 14:04
帖子: 23
送出感谢: 0 次
接收感谢: 0 次
那就不要动态分配,自己设置静态ip


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 呵呵
帖子发表于 : 2006-08-19 22:35 

注册: 2005-08-20 18:50
帖子: 37
送出感谢: 0 次
接收感谢: 0 次
ghqxx 写道:
那就不要动态分配,自己设置静态ip


这样的确就没有问题了
但是不能dhcp,我很不爽啊

谁能告诉我出现这个问题是为什么么?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 6 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译