当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 4 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 关于Canon几款打印机的安装
帖子发表于 : 2006-08-17 5:32 
头像

注册: 2006-08-17 1:13
帖子: 101
送出感谢: 0 次
接收感谢: 2
  我的打印机是Canon Pixma iP1000,ubuntu不能正确识别,以下是解决方案,本帖还适用于以下几种打印机的安装:

* Canon Pixus iP3100
* Canon Pixus iP4100
* Canon Pixus iP8600
* Canon Pixma iP1000
* Canon Pixma iP1500
* Canon BJ S700 (with iP3100 driver, 2006-01-08)
* Canon Pixma 3000 (with iP3100 driver, 2006-01-11)
* Canon PIXMA MP750, MP780 (with iP4100 driver, 2006-03-11)

  第一步,增加源并更新升级:

在终端执行以下命令(第一条是备份现有服务器列表,第二条是使用Gedit编辑,您也可以使用自己喜爱的编辑器编辑。)
代码:
sudo cp /etc/apt/sources.list /etc/apt/sources.list_backup
sudo gedit /etc/apt/sources.list

加入以下行:
  
代码:
deb http://mambo.kuhp.kyoto-u.ac.jp/~takushi/debian ./

  运行命令:
  
代码:
# apt-get update

  
  第二步,安装驱动软件包:

  
代码:
# apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj


  第三步,按照普通方法配置打印机:

  系统->系统管理->正在打印
  这时,会出现你的打印机驱动。例如我的是PIXMA iP1000 Ver.2.50


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2007-03-29 9:11 

注册: 2006-12-19 10:14
帖子: 107
送出感谢: 0 次
接收感谢: 0 次
我已经这样做了,为什么还是没有呢?


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2007-05-29 19:57 

注册: 2007-05-27 17:44
帖子: 17
送出感谢: 0 次
接收感谢: 0 次
我的 打印机也是canon iP1000,就是装不上去。我照别人介绍的方法下载了iP1000的3个rpm包照如下方法装了:
gamts@gamts-desktop:~$ ls
Desktop Examples prindrv 共享文档
gamts@gamts-desktop:~$ cd prindrv
gamts@gamts-desktop:~/prindrv$ ls
bjfilter-common-2.50-2.i386.rpm
bjfilter-pixmaip1000-2.50-2.i386.rpm
bjfilter-pixmaip1000-lprng-2.50-2.i386.rpm
gamts@gamts-desktop:~/prindrv$ sudo apt-get install rpm alien
Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
将会安装下列额外的软件包:
debhelper dpkg-dev gettext html2text intltool-debian libbeecrypt6 librpm4
po-debconf
建议安装的软件包:
lsb-rpm lintian dh-make debian-keyring cvs gettext-doc
推荐安装的软件包:
libmail-sendmail-perl libcompress-zlib-perl
下列【新】软件包将被安装:
alien debhelper dpkg-dev gettext html2text intltool-debian libbeecrypt6
librpm4 po-debconf rpm
共升级了 0 个软件包,新安装了 10 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 147kB/4255kB 的软件包。
解压缩后会消耗掉 15.6MB 的额外空间。
您希望继续执行吗?[Y/n]y
获取:1 http://cn.archive.ubuntu.com feisty/main dpkg-dev 1.13.24ubuntu6 [147kB]
下载 66.8kB,耗时 4s (16.0kB/s)
选中了曾被取消选择的软件包 dpkg-dev。
(正在读取数据库 ... 系统当前总共安装有 108190 个文件和目录。)
正在解压缩 dpkg-dev (从 .../dpkg-dev_1.13.24ubuntu6_all.deb) ...
选中了曾被取消选择的软件包 html2text。
正在解压缩 html2text (从 .../html2text_1.3.2a-3_i386.deb) ...
选中了曾被取消选择的软件包 gettext。
正在解压缩 gettext (从 .../gettext_0.16.1-1ubuntu2_i386.deb) ...
选中了曾被取消选择的软件包 intltool-debian。
正在解压缩 intltool-debian (从 .../intltool-debian_0.35.0+20060710.1_all.deb) ...
选中了曾被取消选择的软件包 po-debconf。
正在解压缩 po-debconf (从 .../po-debconf_1.0.8_all.deb) ...
选中了曾被取消选择的软件包 debhelper。
正在解压缩 debhelper (从 .../debhelper_5.0.42ubuntu1_all.deb) ...
选中了曾被取消选择的软件包 libbeecrypt6。
正在解压缩 libbeecrypt6 (从 .../libbeecrypt6_4.1.2-6build1_i386.deb) ...
选中了曾被取消选择的软件包 librpm4。
正在解压缩 librpm4 (从 .../librpm4_4.4.1-14build1_i386.deb) ...
选中了曾被取消选择的软件包 rpm。
正在解压缩 rpm (从 .../rpm_4.4.1-14build1_i386.deb) ...
选中了曾被取消选择的软件包 alien。
正在解压缩 alien (从 .../archives/alien_8.65_all.deb) ...
正在设置 dpkg-dev (1.13.24ubuntu6) ...
正在设置 html2text (1.3.2a-3) ...

正在设置 gettext (0.16.1-1ubuntu2) ...

正在设置 intltool-debian (0.35.0+20060710.1) ...
正在设置 po-debconf (1.0.8) ...
正在设置 debhelper (5.0.42ubuntu1) ...
正在设置 libbeecrypt6 (4.1.2-6build1) ...

正在设置 librpm4 (4.4.1-14build1) ...

正在设置 rpm (4.4.1-14build1) ...

正在设置 alien (8.65) ...
gamts@gamts-desktop:~/prindrv$ ls
bjfilter-common-2.50-2.i386.rpm
bjfilter-pixmaip1000-2.50-2.i386.rpm
bjfilter-pixmaip1000-lprng-2.50-2.i386.rpm
gamts@gamts-desktop:~/prindrv$ alien -d bjfilter*rpm
Must run as root to convert to deb format (or you may use fakeroot).
gamts@gamts-desktop:~/prindrv$ fakeroot alien bjfilter*.rpm
The program 'fakeroot' is currently not installed. You can install it by typing:
sudo apt-get install fakeroot
bash: fakeroot:找不到命令
gamts@gamts-desktop:~/prindrv$ sudo apt-get install fakeroot
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
Reading state information... 完成
下列【新】软件包将被安装:
fakeroot
共升级了 0 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
需要下载 0B/99.4kB 的软件包。
解压缩后会消耗掉 397kB 的额外空间。
选中了曾被取消选择的软件包 fakeroot。
(正在读取数据库 ... 系统当前总共安装有 108999 个文件和目录。)
正在解压缩 fakeroot (从 .../fakeroot_1.5.10ubuntu2_i386.deb) ...
正在设置 fakeroot (1.5.10ubuntu2) ...

gamts@gamts-desktop:~/prindrv$ fakeroot alien bjfiter*rpm
File "bjfiter*rpm" not found.
gamts@gamts-desktop:~/prindrv$ ls
bjfilter-common-2.50-2.i386.rpm
bjfilter-pixmaip1000-2.50-2.i386.rpm
bjfilter-pixmaip1000-lprng-2.50-2.i386.rpm
gamts@gamts-desktop:~/prindrv$ fakeroot alien bjfilter*.rpm
bjfilter-common_2.50-3_i386.deb generated
Warning: Skipping conversion of scripts in package bjfilter-pixmaip1000: postinst postrm
Warning: Use the --scripts parameter to include the scripts.
bjfilter-pixmaip1000_2.50-3_i386.deb generated
Warning: Skipping conversion of scripts in package bjfilter-pixmaip1000-lprng: postrm
Warning: Use the --scripts parameter to include the scripts.
bjfilter-pixmaip1000-lprng_2.50-3_i386.deb generated
gamts@gamts-desktop:~/prindrv$ ls
bjfilter-common-2.50-2.i386.rpm
bjfilter-common_2.50-3_i386.deb
bjfilter-pixmaip1000-2.50-2.i386.rpm
bjfilter-pixmaip1000_2.50-3_i386.deb
bjfilter-pixmaip1000-lprng-2.50-2.i386.rpm
bjfilter-pixmaip1000-lprng_2.50-3_i386.deb
gamts@gamts-desktop:~/prindrv$ sudo dpkg -i bjfilter*.deb
选中了曾被取消选择的软件包 bjfilter-common。
(正在读取数据库 ... 系统当前总共安装有 109034 个文件和目录。)
正在解压缩 bjfilter-common (从 bjfilter-common_2.50-3_i386.deb) ...
选中了曾被取消选择的软件包 bjfilter-pixmaip1000。
正在解压缩 bjfilter-pixmaip1000 (从 bjfilter-pixmaip1000_2.50-3_i386.deb) ...
选中了曾被取消选择的软件包 bjfilter-pixmaip1000-lprng。
正在解压缩 bjfilter-pixmaip1000-lprng (从 bjfilter-pixmaip1000-lprng_2.50-3_i386.deb) ...
正在设置 bjfilter-common (2.50-3) ...
正在设置 bjfilter-pixmaip1000 (2.50-3) ...
正在设置 bjfilter-pixmaip1000-lprng (2.50-3) ...
gamts@gamts-desktop:~/prindrv$

还是没有找到iP1000的驱动。

于是照你的方法又做了:
 第一步,增加源并更新升级:

在终端执行以下命令(第一条是备份现有服务器列表,第二条是使用Gedit编辑,您也可以使用自己喜爱的编辑器编辑。)
代码:
sudo cp /etc/apt/sources.list /etc/apt/sources.list_backup
sudo gedit /etc/apt/sources.list

加入以下行:
  
代码:
deb http://mambo.kuhp.kyoto-u.ac.jp/~takushi/debian ./

  运行命令:
"  
代码:
# apt-get update

  
  第二步,安装驱动软件包:

  
代码:
# apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj


  第三步,按照普通方法配置打印机:

  系统->系统管理->正在打印
  这时,会出现你的打印机驱动。例如我的是PIXMA iP1000 Ver.2.50"

结果还是找不到iP1000的驱动,请指教,看看以上的做法对不对。谢谢!


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2007-11-27 16:17 

注册: 2006-11-07 9:40
帖子: 33
送出感谢: 0 次
接收感谢: 0 次
第二步 : # apt-get install libcnbj-2.5 bjfilter-2.5 pstocanonbj 出错。。信息如下

The following packages have unmet dependencies:
pstocanonbj: Depends: libcupsys2-gnutls10 (>= 1.1.23-1) but it is not installable
E: Broken packages


请教如何解决啊


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 4 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译