[问题]新立得无法运行,高手请进

为当前最终发行版之前的所有版本提供支持
回复
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

[问题]新立得无法运行,高手请进

#1

帖子 zhuqin_83 » 2006-08-19 2:00

出现如下错误:
zhuqin@ubuntu:~$ synaptic
synaptic: error while loading shared libraries: libvte.so.4: cannot open shared object file: No such file or directory
该怎么办?
上次由 zhuqin_83 在 2006-08-19 9:29,总共编辑 2 次。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
bcliu
帖子: 19
注册时间: 2006-02-27 17:10
送出感谢: 0
接收感谢: 0

#2

帖子 bcliu » 2006-08-19 8:04

出现如下错误:
zhuqin@ubuntu:~$ synaptic
synaptic: error while loading shared libraries: libvte.so.4: cannot open shared object file: No such file or directory
我的也是这种情况,不知包含这个libvte.so.4的软件包叫什么名字,如果知道就重装一下试试。
flyinwind
帖子: 69
注册时间: 2006-06-06 16:55
送出感谢: 0
接收感谢: 0

#3

帖子 flyinwind » 2006-08-19 8:19

哈哈,是不是刚刚作了系统升级啊,
我也是这样,今天早上开始还好好的,一看提示有升级就立马update了,结果再运行synaptic就提示楼上所说的这个错误鸟
flyinwind
帖子: 69
注册时间: 2006-06-06 16:55
送出感谢: 0
接收感谢: 0

#4

帖子 flyinwind » 2006-08-19 8:23

回想一下,升级的时候好像确实把这个libvte.so.4给更新成新版本了
flyinwind
帖子: 69
注册时间: 2006-06-06 16:55
送出感谢: 0
接收感谢: 0

#5

帖子 flyinwind » 2006-08-19 8:41

http://packages.ubuntu.com/cgi-bin/sear ... &arch=i386

解决了,点上面的链接进去后,选择“usr/lib/libvte.so.4”的package,然后在页面下方down下它来安装,是个deb包
我是因为早上升级过,所以在重新安装libvte.so.4时发现它的一个依赖包libvte-common也升的不行了,所以在安装usr/lib/libvte.so.4之前先在那个网页里的“Other Packages Related to libvte4”下载libvte-common安装后,再安装libvte.so.4就OK了

上面的做过之后,还会有刚升级引出的一点小遗留,升级的那个小notify又来了,这时点击它会弹出一个问题框;如果进入synaptic会提示你两个什么东东安装broken,好说,甭理它,在synaptic里找到并"synaptic"并右击它选择“make reinstall”(就是在synaptic里重装一遍"synaptic"),确定后等它完成,一切解决
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2006-08-19 9:08

多谢,试试看。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#7

帖子 zhuqin_83 » 2006-08-19 9:19

更新过后,好像升级成了libvte9,所以才无法载入的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 zhuqin_83 » 2006-08-19 9:26

不过这样不是降级安装吗?还是等synaptic升级以后再说吧。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
IdeaLee
帖子: 90
注册时间: 2006-01-29 9:29
送出感谢: 0
接收感谢: 0

#9

帖子 IdeaLee » 2006-08-21 10:52

我也碰到这个问题了,已经解决了,见下面的帖子……
viewtopic.php?t=22380&highlight=libvte.so.4
符号链接时记得要 sudo 权限……

不知道这算不算 bug ,总之挺有意思的……
在现实面前,当然是理想错了……
回复

回到 “老旧版本支持”