[问题]I can't install the gcc/g++,why?

为当前最终发行版之前的所有版本提供支持
回复
lcy3125891
帖子: 4
注册时间: 2006-07-16 10:41
送出感谢: 0
接收感谢: 0

[问题]I can't install the gcc/g++,why?

#1

帖子 lcy3125891 » 2006-08-19 10:03

lcy3125891@lcy3125891:~$ sudo apt-get install gcc
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gcc: 依赖: cpp (>= 4:4.0.1-3) 但是它将不会被安装
依赖: gcc-4.0 (>= 4.0.1-2) 但是它将不会被安装
E: 无法安装的软件包
头像
cho
帖子: 70
注册时间: 2006-08-12 7:46
送出感谢: 0
接收感谢: 0

#2

帖子 cho » 2006-08-19 13:06

先运行
sudo apt-cache depends gcc
查看gcc依赖的软件,然后安装他们再安装gcc看能不能解决你的问题
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 karron » 2006-08-19 13:24

sudo apt-get install build-essential
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
回复

回到 “老旧版本支持”