[问题]在ubuntu 6.06 TLS下安装不了一些软件,请问是什么原因?

为当前最终发行版之前的所有版本提供支持
回复
虫虫2003
帖子: 51
注册时间: 2006-03-27 19:28
送出感谢: 0
接收感谢: 0

[问题]在ubuntu 6.06 TLS下安装不了一些软件,请问是什么原因?

#1

帖子 虫虫2003 » 2006-08-19 16:13

我 apt-get install gcc,不能正常安装,显示如下信息:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
gcc: 依赖: cpp (>= 4:4.0.1-3) 但是它将不会被安装
依赖: gcc-4.0 (>= 4.0.1-2) 但是它将不会被安装
E: 无法安装的软件包

我 apt-get install libncurses5-dev 也有类似的问题。

请问是什么原因,如何解决?
谢谢!
头像
Jungherr
帖子: 269
注册时间: 2006-07-08 9:00
来自: Deutschland
送出感谢: 0
接收感谢: 0

#2

帖子 Jungherr » 2006-08-19 16:21

sudo apt-get build-essential
回复

回到 “老旧版本支持”