ubuntu播放mp3并且解决乱码的方法

为当前最终发行版之前的所有版本提供支持
回复
casm
帖子: 33
注册时间: 2006-07-11 11:47
来自: Dalian, China
送出感谢: 0
接收感谢: 0
联系:

ubuntu播放mp3并且解决乱码的方法

#1

帖子 casm » 2006-08-19 22:58

小弟也是新手,刚刚用ubuntu,为了能让ubuntu能够播放mp3并且字体显示正常,这两天在IRC里面没少麻烦大牛们,在

此对他们表示衷心的感谢:boraCN, Huahua, freeflying。我把我的经历写出来,让和我一样的新手少走一点弯路,

好了,言归正传。

为了能够播放mp3甚至其余的媒体文件,自然需要安装软件解码器,我按照 Karron Qiu 的方法安装的。如下:

sudo apt-get install gstreamer0.10-*

sudo apt-get install libxine-extracodecs totem-xine mplayer-686 ffmpeg lame faad sox mjpegtools libxine-main1

wget -c ftp://ftp.nerim.net/debian-marillat/poo ... 0_i386.deb

sudo dpkg -i w32codecs_20050412-0.0_i386.deb

注:因为w32codecs现在也包含在源里面了,所以可以直接这样安装

sudo apt-get install w32codecs

这样做以后,mp3就能够正常播放了,但还有少数在播放列表中显示的是乱码。下面继续完善:

升级rhythmbox,系统默认安装的版本是0.9.3.1的,我们将它升级到0.9.4.1

wget -c http://mighmos.org/packages/dapper/rhyt ... 0_i386.deb

sudo dpkg -i rhythmbox_0.9.4.1-0unofficial0_i386.deb

如果播放的时候有些mp3还是显示乱码,你就可以用rhythmbox将它标签的内容编辑一下,就能正常显示中文了。

注:在升级rhythmbox的时候,有可能会遇到这样的错误提示:

dpkg:依赖关系问题使得 rhythmbox 的配置工作不能继续:
rhythmbox 依赖于 libgnutls11 (>= 1.0.16);然而:
软件包 libgnutls11还没有被安装。

只需要

sudo apt-get install libgnutls11

就可以了。
头像
bitnew
帖子: 111
注册时间: 2006-07-29 2:04
来自: Southwest JiaoTong University
送出感谢: 0
接收感谢: 0

#2

帖子 bitnew » 2006-08-20 1:17

最好还是安装easytag.
头像
haige
帖子: 315
注册时间: 2006-03-16 16:29
送出感谢: 0
接收感谢: 0

是英文啊

#3

帖子 haige » 2006-08-30 18:57

不会用
muxaul
帖子: 5
注册时间: 2006-09-15 23:14
送出感谢: 0
接收感谢: 0

#4

帖子 muxaul » 2006-09-16 16:14

照着一步步来
sudo apt-get install gstreamer0.10-* OK

sudo apt-get install libxine-extracodecs totem-xine mplayer-686 ffmpeg lame faad sox mjpegtools libxine-main1 所有源里都找不到

sudo apt-get install libgnutls11 E: 无法找到软件包 libgnutlsll

新版rhythmbox安了,w32codecs也装了, 还是不能放mp3。
请问乍回事?
头像
这个唐勇
帖子: 49
注册时间: 2008-01-13 10:10
送出感谢: 0
接收感谢: 0
联系:

Re:

#5

帖子 这个唐勇 » 2011-10-19 22:41

bitnew 写了:最好还是安装easytag.
先试试 你的这个方法。
回复

回到 “老旧版本支持”