安装JDK时遇见的 问题

为当前最终发行版之前的所有版本提供支持
回复
datoaaa
帖子: 5
注册时间: 2006-08-21 7:53
送出感谢: 0
接收感谢: 0

安装JDK时遇见的 问题

#1

帖子 datoaaa » 2006-08-21 8:02

我在装JDK1.5时现是说没有RPM命令,用新立得装上RPM后又报
root@cao-linux:/home/cao# rpm -ivh jdk-1_5_0_08-linux-i586.rpm
error: 依赖性检测失败:
glibc >= 2.1.2-11 被 jdk-1.5.0_08-fcs.i586 所需要
sh-utils >= 2.0-1 被 jdk-1.5.0_08-fcs.i586 所需要
fileutils >= 4.0-8 被 jdk-1.5.0_08-fcs.i586 所需要
gawk >= 3.0.4-1 被 jdk-1.5.0_08-fcs.i586 所需要
textutils >= 2.0-2 被 jdk-1.5.0_08-fcs.i586 所需要
/bin/sh 被 jdk-1.5.0_08-fcs.i586 所需要

请问应该怎么办,我是新手,希望能写的 详细点,谢谢
头像
xiaosilent
帖子: 513
注册时间: 2006-05-09 9:59
来自: 四川成都
送出感谢: 1 次
接收感谢: 0
联系:

#2

帖子 xiaosilent » 2006-08-21 9:10

安装JDK sudo apt-get install sun-java5-jdk

然后选择默认Java解释器 sudo update-alternatives --config java
选择带有 java-1.5.0-sun 的一项就可以了。

rpm是RH的包管理方式,Debian包的后缀是.deb
datoaaa
帖子: 5
注册时间: 2006-08-21 7:53
送出感谢: 0
接收感谢: 0

#3

帖子 datoaaa » 2006-08-21 17:35

谢谢,LINUX下东西太乱了 头晕呀!!!
回复

回到 “老旧版本支持”