[问题]紧急问题,急求解决方法

为当前最终发行版之前的所有版本提供支持
回复
头像
烟雨平生
帖子: 103
注册时间: 2006-07-06 16:35
送出感谢: 0
接收感谢: 0
联系:

[问题]紧急问题,急求解决方法

#1

帖子 烟雨平生 » 2006-08-21 19:40

root@allin-desktop:~# sudo apt-get install mplayer-386
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
root@allin-desktop:~#


我在ununtu 网站上看到的如何安装Mplayer 但是总是出现这个提示,你说是怎么搞的啊!!!
还有,在执行 sudo apt-get install 时,总是这个提示。




root@allin-desktop:~# sudo apt-get install mplayer-386
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
root@allin-desktop:~#


我在ununtu 网站上看到的如何安装Mplayer 但是总是出现这个提示,你说是怎么搞的啊!!!
还有,在执行 sudo apt-get install 时,总是这个提示。


请高手赐教!!!!
谢过!!!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-08-21 19:44

1。新利得里面找broken包,先卸载。
2。执行sudo dpkg --configure -a
3。sudo rm -r /var/cache/apt/,再卸载apt-get,再重装
● 鸣学
头像
烟雨平生
帖子: 103
注册时间: 2006-07-06 16:35
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 烟雨平生 » 2006-08-21 20:17

root@allin-desktop:~# sudo dpkg --configure -a
dpkg:依赖关系问题使得 libtool 的配置工作不能继续:
libtool 依赖于 libc6-dev | libc-dev;然而:
软件包 libc6-dev还没有被安装。
软件包 libc-dev还没有被安装。
dpkg:处理 libtool (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 adept (2.0ubuntu2) ...

dpkg:依赖关系问题使得 language-selector-qt 的配置工作不能继续:
language-selector-qt 依赖于 python2.4-qt3;然而:
软件包 python2.4-qt3还没有被安装。
dpkg:处理 language-selector-qt (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-common 的配置工作不能继续:
gnome-common 依赖于 libtool (>= 1.5);然而:
软件包 libtool还没有被配置。
dpkg:处理 gnome-common (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 amarok (1.3.9-0ubuntu4) ...

dpkg:依赖关系问题使得 glade-gnome 的配置工作不能继续:
glade-gnome 依赖于 gnome-common (>= 2.8.0);然而:
软件包 gnome-common还没有被配置。
dpkg:处理 glade-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libtool
language-selector-qt
gnome-common
glade-gnome
root@allin-desktop:~#



我用sudo rm -r /var/cache/apt/ 删除了,但是怎么安装???? 急呀,原来用 sudo apt-get update 可以更新,现在不能用了,惨!!!!!
急盼赐教!!!!
头像
5451vs5451
帖子: 345
注册时间: 2006-07-14 18:56
来自: Apple Valley, Planet Tux, Linux System
送出感谢: 0
接收感谢: 0

#4

帖子 5451vs5451 » 2006-08-21 21:31

烟雨平生 写了:root@allin-desktop:~# sudo dpkg --configure -a
dpkg:依赖关系问题使得 libtool 的配置工作不能继续:
libtool 依赖于 libc6-dev | libc-dev;然而:
软件包 libc6-dev还没有被安装。
软件包 libc-dev还没有被安装。
dpkg:处理 libtool (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 adept (2.0ubuntu2) ...

dpkg:依赖关系问题使得 language-selector-qt 的配置工作不能继续:
language-selector-qt 依赖于 python2.4-qt3;然而:
软件包 python2.4-qt3还没有被安装。
dpkg:处理 language-selector-qt (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 gnome-common 的配置工作不能继续:
gnome-common 依赖于 libtool (>= 1.5);然而:
软件包 libtool还没有被配置。
dpkg:处理 gnome-common (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 amarok (1.3.9-0ubuntu4) ...

dpkg:依赖关系问题使得 glade-gnome 的配置工作不能继续:
glade-gnome 依赖于 gnome-common (>= 2.8.0);然而:
软件包 gnome-common还没有被配置。
dpkg:处理 glade-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
libtool
language-selector-qt
gnome-common
glade-gnome
root@allin-desktop:~#



我用sudo rm -r /var/cache/apt/ 删除了,但是怎么安装???? 急呀,原来用 sudo apt-get update 可以更新,现在不能用了,惨!!!!!
急盼赐教!!!!
dpkg --configure -a --ignore-depends=libtool, language-selector-qt,gnome-common, glade-gnome
dpkg-reconfigure apt
dpkg -r libtool language-selector-qt gnome-common glade-gnome
dpkg -i libtool language-selector-qt gnome-common glade-gnome
头像
烟雨平生
帖子: 103
注册时间: 2006-07-06 16:35
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 烟雨平生 » 2006-08-22 12:17

oot@allin-desktop:/usr/lib/apt# dpkg --configure -a --ignore-depends=libtool,language-selector-qt,gnome-common,glade-gnome
dpkg: --ignore-depends 需要一个有效的软件包名。而“libtool,language-selector-qt,gnome-common,glade-gnome”却不是;不允许有字符“,” - 只能用字符、数字和 -+._: No such file or directory
root@allin-desktop:/usr/lib/apt# dpkg-reconfigure apt
debconf: 无法初始化前端界面:Kde
debconf: (Unable to load Qt -- is libqt-perl installed?)
debconf: 返回前端界面:Dialog

root@allin-desktop:/usr/lib/apt#
root@allin-desktop:/usr/lib/apt


还是不行啊????!!!!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#6

帖子 eexpress » 2006-08-22 12:20

package.ubuntu.org下载deb包。dpkg -i安装回来apt-get
● 鸣学
回复

回到 “老旧版本支持”