当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 9 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-07 12:06 

注册: 2008-08-14 14:01
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
每次启动 提示GRUB LOADING。。。 都要等上十几秒 才LOAD出来 LINUX 和XP选项 ,感觉这个比9.04的差好多啊 不知道大家有没有这个现象?


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-07 16:26 
头像

注册: 2007-03-18 16:17
帖子: 639
地址: 汕尾
送出感谢: 0 次
接收感谢: 1
我没这个现象,估计是你的引导文件有问题,检查一下。


_________________
感受Ubuntu!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-07 20:28 

注册: 2008-08-14 14:01
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
2楼看一下我的grub.cfg有啥问题 也贴一下你的吧
这是我的
代码:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
load_env
set default=0
if [ ${prev_saved_entry} ]; then
  saved_entry=${prev_saved_entry}
  save_env saved_entry
  prev_saved_entry=
  save_env prev_saved_entry
fi
insmod ext2
set root=(hd1,2)

if loadfont /usr/share/grub/unicode.pf2 ; then
  set gfxmode=640x480
  insmod gfxterm
  insmod vbe
  if terminal_output gfxterm ; then true ; else
    # For backward compatibility with versions of terminal.mod that don't
    # understand terminal_output
    terminal gfxterm
  fi
fi
set timeout=10
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/05_debian_theme ###
set menu_color_normal=white/black
set menu_color_highlight=black/white
### END /etc/grub.d/05_debian_theme ###

### BEGIN /etc/grub.d/10_linux ###
menuentry "Ubuntu, Linux 2.6.31-9-generic" {
   set quiet=1
   insmod ext2
   set root=(hd1,2)
   
   linux   /boot/vmlinuz-2.6.31-9-generic root=UUID=ddfcbf7d-22b5-46b7-9eb3-b4baa6e2659d ro   quiet splash
   initrd   /boot/initrd.img-2.6.31-9-generic
}
menuentry "Ubuntu, Linux 2.6.31-9-generic (recovery mode)" {
   insmod ext2
   set root=(hd1,2)
   
   linux   /boot/vmlinuz-2.6.31-9-generic root=UUID=ddfcbf7d-22b5-46b7-9eb3-b4baa6e2659d ro single
   initrd   /boot/initrd.img-2.6.31-9-generic
}
### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_memtest86+ ###
menuentry "Memory test (memtest86+)" {
   linux16   /boot/memtest86+.bin
}
menuentry "Memory test (memtest86+, serial console 115200)" {
   linux16   /boot/memtest86+.bin console=ttyS0,115200n8
}
### END /etc/grub.d/20_memtest86+ ###

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sda1)" {
   insmod fat
   set root=(hd0,1)
   
   drivemap -s (hd0) ${root}
   chainloader +1
}
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file is an example on how to add custom entries
### END /etc/grub.d/40_custom ###


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-07 20:33 
头像

注册: 2008-12-13 19:39
帖子: 13284
地址: 物华天宝人杰地灵
送出感谢: 1
接收感谢: 6
楼主难道是两块硬盘,哥伦布2代某也不熟,请教下smallapple,看他有什么办法可以优化下。本人哥伦布启动需要几秒钟。 :em06


_________________
行到水穷处,坐看云起时。
海内生明月,天涯共此夕。
--------------------吾本独!


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-07 21:02 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
grub.cfg看不出什么问题。
可以把这一段删掉
if [ ${prev_saved_entry} ]; then
saved_entry=${prev_saved_entry}
save_env saved_entry
prev_saved_entry=
save_env prev_saved_entry
fi

然后重装下grub2
sudo grub-install /dev/sda
试试


再不然在出现grub loading之后按下Tab键看看。


_________________
Grub2 基础教程


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-08 18:33 

注册: 2008-08-14 14:01
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
我的正是两块硬盘 :em05 一块是XP,一块是LINUX。
谢谢SMALLAPPLE的帮助,不过问题仍然存在。。难道是我的硬盘某个地方坏掉?对于9.10就这点遗憾了。。


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-08 19:35 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
引用:
难道是我的硬盘某个地方坏掉?对于9.10就这点遗憾了

不排除这种可能。
等grub2 1.97正式版出来后看能不能改观。今天才升级到Beta2。
可以等的话凑和。
不行就改回用grub。

刚测试下,双硬盘设定启动顺序有点影响。
可以把grub装到linux盘的mbr上,改linux盘为启动盘试试。


_________________
Grub2 基础教程


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-09-09 21:17 

注册: 2008-08-14 14:01
帖子: 55
送出感谢: 0 次
接收感谢: 0 次
改来改去,把一硬盘改没了。。。还好 里面没啥东西 后来又找了回来
我决心等待了 又回到了9.04。 :em06 :em06


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 我的9.10 GRUB LOADING特别慢
帖子发表于 : 2009-11-29 20:58 
头像

注册: 2009-11-29 20:56
帖子: 34
送出感谢: 0 次
接收感谢: 0 次
我也遇到了这个问题,不过好像也没有什么特别的影响,就是开机有点慢。
第一次用ubuntu就到了9.10了,呵呵。


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 9 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译