ubuntu启动太慢了!

为当前最终发行版之前的所有版本提供支持
tartss
帖子: 57
注册时间: 2006-05-03 17:29
送出感谢: 0
接收感谢: 0

ubuntu启动太慢了!

#1

帖子 tartss » 2006-08-24 9:09

我装了系统之后,期间有个分区映射,当时没搞懂她要干嘛,后来就装上了,刚开始觉得挺好的,启动之后分区全部已经挂上了,而且不存在中文显示问题,当时挺高兴的,可是之后发现重启的时间竟然要2-3分钟!我的xp启动只要30秒!好像主要的时间都花在了Mount分区上了,超级慢阿,大牛们有没有好办法解决这个?
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-08-24 9:51

每次都这样?都是mount时候慢?那就是磁盘有问题。在检查磁盘。比如每次不正常关机。
● 鸣学
tartss
帖子: 57
注册时间: 2006-05-03 17:29
送出感谢: 0
接收感谢: 0

#3

帖子 tartss » 2006-08-24 14:06

就是这样的,我reboot和上电开机是一样的,每次都是等一段时间之后就跳出来.........sda6而且有sda6的详细信息,接着是sda7……。我一共mount7个分区……,哪个慢阿。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-08-24 15:21

什么格式的分区?我十几个分区都不要那么多的时间。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#5

帖子 eexpress » 2006-08-24 18:39

dmesg|grep mount
比较下挂载时间看看有多长。也可以自己看,是不是有什么错误提示
● 鸣学
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#6

帖子 glade » 2006-08-25 2:00

应该不是什么问题,我的也是这样,挂了C D E三个盘 默认都要检测,哪怕正常关机也是如此
checking all file systems这一步花的时间最长,可以设置禁用的吧
不过也没什么所谓,一天开一次机,从没彻底死过
头像
Jungherr
帖子: 269
注册时间: 2006-07-08 9:00
来自: Deutschland
送出感谢: 0
接收感谢: 0

#7

帖子 Jungherr » 2006-08-25 2:15

glade 写了:应该不是什么问题,我的也是这样,挂了C D E三个盘 默认都要检测,哪怕正常关机也是如此
checking all file systems这一步花的时间最长,可以设置禁用的吧
不过也没什么所谓,一天开一次机,从没彻底死过
ubuntu开机应该不会这么慢,50sec比较正常,我的硬盘有130G也就用了不到10secchecking all file systems
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#8

帖子 glade » 2006-08-25 2:34

我已经关掉很多不必要的服务了,还要1min+
tartss
帖子: 57
注册时间: 2006-05-03 17:29
送出感谢: 0
接收感谢: 0

#9

帖子 tartss » 2006-08-25 8:34

glade 写了:应该不是什么问题,我的也是这样,挂了C D E三个盘 默认都要检测,哪怕正常关机也是如此
checking all file systems这一步花的时间最长,可以设置禁用的吧
不过也没什么所谓,一天开一次机,从没彻底死过
就是在checking all file systems花时间,怎么搞得比win还夸张!因为我的用途不再应用上,所以经常要reboot,搞得很心烦阿,整个启动的时间大概3M,花在检测上的时间有1-2M!我的磁盘都是fat32格式的,不应该这样的阿。
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#10

帖子 glade » 2006-08-25 15:31

cd /etc/init.d
sudo mv checkfs.sh checkfs.sh.bak
非常有效
LittleLing
帖子: 20
注册时间: 2006-08-24 14:53
送出感谢: 0
接收感谢: 0

#11

帖子 LittleLing » 2006-08-25 16:00

樓主可以不預設掛載所有的盤。

本人用P-ATA100 大約一分鐘就進系統了
besteffort
帖子: 18
注册时间: 2006-08-25 15:06
送出感谢: 0
接收感谢: 0

#12

帖子 besteffort » 2006-08-25 20:56

在/etc/fstab里把对应分区的最后一个参数设为0,就不会检查分区了
tartss
帖子: 57
注册时间: 2006-05-03 17:29
送出感谢: 0
接收感谢: 0

#13

帖子 tartss » 2006-08-29 17:29

besteffort 写了:在/etc/fstab里把对应分区的最后一个参数设为0,就不会检查分区了
94这样的,很有效!我是查wiki看到的解决办法,不过还是谢谢besteffort了!
networker
帖子: 419
注册时间: 2006-02-06 21:06
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 networker » 2006-08-29 18:34

glade 写了:cd /etc/init.d
sudo mv checkfs.sh checkfs.sh.bak
非常有效
networker
帖子: 419
注册时间: 2006-02-06 21:06
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

#15

帖子 networker » 2006-08-29 20:30

这里有问题吖~
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda10 / ext3 defaults,errors=remount-ro 0 1
/dev/hda7 /boot ext3 defaults 0 2
/dev/hda9 /home ext3 defaults 0 2
/dev/hda1 /c vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda5 /d vfat defaults,utf8,umask=022 0 1
/dev/hda6 /e vfat defaults,utf8,umask=007,gid=46 0 1
/dev/sda1 /games vfat defaults,utf8,umask=007,gid=46 0 1
/dev/sda2 /others vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda11 /usr/local ext3 defaults 0 2
/dev/hda8 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
none /selinux selinuxfs noauto 0 0
我把C,D,E,Games,Others全改成0之后。移动硬盘也就是games,others2个盘不能自动挂载。
不知道该怎么改。
回复

回到 “老旧版本支持”