求救Ubuntu启动不了了

为当前最终发行版之前的所有版本提供支持
回复
头像
deng
帖子: 130
注册时间: 2006-04-09 14:09
来自: 北京
送出感谢: 0
接收感谢: 0
联系:

求救Ubuntu启动不了了

#1

帖子 deng » 2006-08-25 12:14

我昨天装完Dapper后重启突然启动不了了,首先说找不到/etc/X11/X。。。只能在字符界面工作,后来我手动建了这个目录 出现
X: cannot read /etc/X11/X symbolic link (Invalid argument),aborting.
错误 怎么解决啊? 还是不能进图行界面。郁闷,玩了不到10分钟坏了
Programming is fun
==========================
http://oteam.cn
图片
头像
davix
帖子: 274
注册时间: 2005-10-04 16:16
来自: Beijing
送出感谢: 0
接收感谢: 2 次

#2

帖子 davix » 2006-08-25 13:03

之前有过升级吗?

听说最近有一个xorg的升级会导致不能进入X window。

如果是这个问题,可以试试
sudo apt-get update
sudo apt-get dist-upgrade
头像
zweitian
帖子: 5
注册时间: 2006-08-23 13:41
来自: 广州
送出感谢: 0
接收感谢: 0
联系:

升级问题

#3

帖子 zweitian » 2006-08-25 15:56

升级最新的xserver-xorg-core(版本为1:1.0.2-0ubuntu10.3)会造成X崩溃。这一现象并非仅仅影响Xgl+compiz的用户。 若你不幸升级了,需要:

wget -c http://people.ubuntu.com/~rodarvus/packages/dapper /xorg-server/xserver-xorg-core_1.0.2-0ubuntu10.4_i 386.deb
wget -c http://people.ubuntu.com/~rodarvus/packages/dapper /xorg-server/xserver-xorg-dev_1.0.2-0ubuntu10.4_i3 86.deb
sudo dpkg -i xserver-xorg-core*.deb

或者先行降级:

sudo apt-get install xserver-xorg-core=1:1.0.2-0ubuntu10

安装了商用显卡驱动(ATI/nVidia)的系统还要重装驱动。"
回复

回到 “老旧版本支持”