如何让apt-get install 自动安装所有必需的包

为当前最终发行版之前的所有版本提供支持
回复
shileiofchina
帖子: 12
注册时间: 2006-08-21 23:27
送出感谢: 0
接收感谢: 0

如何让apt-get install 自动安装所有必需的包

#1

帖子 shileiofchina » 2006-08-25 21:30

我要安装 x-window-system.core ,然后他告诉我依赖了很多包,所以没有办法安装,有没有参数设置可以自动安装
所有必需的包?
谢谢。

经三楼指摘后,现改正如下:
我下载的是,alternate,安装的时候,选择了server模式,现在想安装desktop,
所以使用命令 sudo apt-get install x-window-system.core desktop
来安装,但是呢,报错了,说依赖与 什么什么包(很多,如果是一个两个,我就自己安装了),
请求各位,这是什么问题.
上次由 shileiofchina 在 2006-08-25 23:08,总共编辑 1 次。
头像
davix
帖子: 274
注册时间: 2005-10-04 16:16
来自: Beijing
送出感谢: 0
接收感谢: 2 次

#2

帖子 davix » 2006-08-25 22:09

我一般使用新立得来安装,在有依赖包的时候,都会自动全部下载的

记得apt-get也是啊
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#3

帖子 aBiNg » 2006-08-25 22:52

我觉得这个更适合您:
viewtopic.php?t=11511
shileiofchina
帖子: 12
注册时间: 2006-08-21 23:27
送出感谢: 0
接收感谢: 0

#4

帖子 shileiofchina » 2006-08-25 23:07

我下载的是,alternate,安装的时候,选择了server模式,现在想安装desktop,
所以使用命令 sudo apt-get install x-window-system.core desktop
来安装,但是呢,报错了,说依赖与 什么什么包(很多,如果是一个两个,我就自己安装了),
请求各位,这是什么问题.

btw:多谢楼上的指点,不过一时半会儿还看不完那篇文章,太长了.呵呵.
janusle
帖子: 36
注册时间: 2006-08-14 11:40
送出感谢: 0
接收感谢: 0

#5

帖子 janusle » 2006-08-25 23:56

sudo apt-get install kde-desktop
或者
sudo apt0get install gnome-desktop
回复

回到 “老旧版本支持”