当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 5 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 升级出了点问题,flashplugin-nonfree删除不掉了。
帖子发表于 : 2009-09-30 21:18 

注册: 2006-01-18 18:11
帖子: 254
送出感谢: 0 次
接收感谢: 0 次
昨天将8.04LTS升级到9.10A6了,还比较顺利,没有什么大的问题。只有一个小问题,就是flashplugin-nonfree删除/升级都不行了。
每次运行apt-get upgrade -f,都报下面的错误。
将会安装下列额外的软件包:
flashplugin-installer flashplugin-nonfree
建议安装的软件包:
xulrunner-1.9 firefox-3.0 ttf-xfree86-nonfree xfs
下列【新】软件包将被安装:
flashplugin-installer
下列的软件包将被升级:
flashplugin-nonfree
共升级了 1 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。
有 1 个软件包没有被完全安装或卸载。
需要下载 0B/21.2kB 的软件包。
解压缩后会消耗掉 61.4kB 的额外空间。
您希望继续执行吗?[Y/n]
正在预设定软件包 ...
dpkg:处理 flashplugin-nonfree (--remove)时出错:
该软件包现在的状态极为不妥 - 您最好能
在删除它之前再重新安装一次。
在处理时有错误发生:
flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

重新安装这个软件包也不行。
想请问下有什么办法手工删除这个软件包,需要完整删除才行。否则只要运行apt-get upgrade,都会报上面的错误。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 升级出了点问题,flashplugin-nonfree删除不掉了。
帖子发表于 : 2009-11-09 9:37 
头像

注册: 2009-11-09 9:35
帖子: 196
送出感谢: 0 次
接收感谢: 0 次
你也遇到了啊,我也跟你同样的问题,现在还没有解决啊.


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 升级出了点问题,flashplugin-nonfree删除不掉了。
帖子发表于 : 2009-11-09 15:46 
头像

注册: 2009-09-24 19:37
帖子: 52
送出感谢: 1
接收感谢: 0 次
下个重装得了!


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 升级出了点问题,flashplugin-nonfree删除不掉了。
帖子发表于 : 2009-12-10 22:30 

注册: 2009-12-10 22:18
帖子: 4
送出感谢: 0 次
接收感谢: 0 次
尝试一下这个办法
viewtopic.php?f=48&t=247899


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 升级出了点问题,flashplugin-nonfree删除不掉了。
帖子发表于 : 2009-12-10 22:39 
头像

注册: 2007-05-06 2:46
帖子: 15634
送出感谢: 0 次
接收感谢: 2
看wiki

就一个so插件,拷贝链接一下

新里得的flashplugin安装莫名其妙依赖其他包,害人无数

:em04


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 5 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译