当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 12 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-04 22:52 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
我知道以下叙述可能有点长,但是我想把我的详细问题说一下

我的机子上08年配的

CPU AMD 5000+
主板 映泰 780G M2+HP
硬盘 西数 160G SATA
内存 1G + 2G
光驱 先锋 DVR-116 ATA
显卡 集成 ATI 3200
键鼠 PS/2键盘+USB鼠标

问题是这样的,我先下载了9.10的beta CD并刻盘,把硬盘重新分区,用的是CD-R,安装时出现问题,以前版本安装都很快,大约25分钟左右,但是这个版本的安装至少近两个小时,就是卡在 80%时和94%时还有97%的时候,这几步特别是的设置硬件”要完成至少要40分钟,期间已经拔掉网线,在几次安装过程中,有一次在安装接近完成时屏幕出现花屏,有几次用LIVE CD安装完成后重启在弹出CD后都不能正常关机重启,每次手动关机重启后提示文件载入出错,不能进入系统,GRUB中任何一个选项都没有办法进入,我以为是CD的问题,但是换成DVD后问题同样存在,我已经弄了两天了,还没有解决,请各位帮帮忙,这也可以算是个BUG吧

总的来说是这样的,就是安装很难完成,就算完成也要2个小时,并且安装成功之后重启也没有办法进入系统
,都提示文件载入失败,请各位帮帮忙,谢谢,还有什么信息要提供的请各位提出

怎么回不了帖子?

感谢LS回复

关于1,我个人认为主板还是可以的,毕竟780在当年还是比较主流的,但是我突然想到一个问题,我前几天刷了9月2号的新BIOS,会不会和BIOS有关?我重刷BIOS后好像有一些莫名其妙的问题,地址是这个
http://www.biostar.cn/app/en-us/t-serie ... p?S_ID=368

关于2和3,因为我虽然很喜欢UBUNTU,但是都是一些简单的应用,所以分区比较小,如下


20G WINDOWS 7 NTFS
15G MAC OS X LEOPARD HFS+
10G UBUNTU EXT4
拓展
4G SWAP LINUX-SWAP
40G NTFS
60G NTFS

我有严重的分区洁癖,每次重装之前都重新分区,一开始用的是PARTED MAGIC,地址是这个
http://partedmagic.com/
后来我担心有问题,就用9.10自带的GParted了还是同样的问题,有时分区很快,但有时探测分区时很慢,要5分钟,有时只要几秒,不知道是什么问题

我有点等不及了,因为因为国庆假之后我就要回去寄宿了,特别是在用过了LIVE版的9.10之后,更想体验了,还请各位帮帮忙


最后由 zldict 编辑于 2009-10-04 23:40,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-04 23:10 
头像

注册: 2007-10-31 20:10
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
几点猜测性质的回答,请诸位拍砖
1.这一套东东跟我的台式机是一样的,当年安装的时候也是比较慢,应该是主板的问题。
2,虽然慢,但是可以安装成功并进入X,所以我怀疑你分区方式有问题。
3.请用自带的工具分区。还有,如果你机器上有win分区,那么建议你留一个主分区的名额。
4,这个机器的板子是万恶的ATI,但似乎可以正常进X。
5,试着用8.04LTS看看,等9.10出正式版了再说吧~~


页首
 用户资料  
 
3 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-04 23:36 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
感谢LS回复

关于1,我个人认为主板还是可以的,毕竟780在当年还是比较主流的,但是我突然想到一个问题,我前几天刷了9月2号的新BIOS,会不会和BIOS有关?我重刷BIOS后好像有一些莫名其妙的问题,地址是这个
http://www.biostar.cn/app/en-us/t-serie ... p?S_ID=368

关于2和3,因为我虽然很喜欢UBUNTU,但是都是一些简单的应用,所以分区比较小,如下


20G WINDOWS 7 NTFS
15G MAC OS X LEOPARD HFS+
10G UBUNTU EXT4
拓展
4G SWAP LINUX-SWAP
40G NTFS
60G NTFS

我有严重的分区洁癖,每次重装之前都重新分区,一开始用的是PARTED MAGIC,地址是这个
http://partedmagic.com/
后来我担心有问题,就用9.10自带的GParted了还是同样的问题,有时分区很快,但有时探测分区时很慢,要5分钟,有时只要几秒,不知道是什么问题

我有点等不及了,因为因为国庆假之后我就要回去寄宿了,特别是在用过了LIVE版的9.10之后,更想体验了,还请各位帮帮忙


页首
 用户资料  
 
4 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 1:56 
头像

注册: 2007-10-31 20:10
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
好吧,我回来了。三更半夜的,还有蚊子。
有一个重点是:你下载的是哪个版本。
liveCD我没有用过,都是almate的。或许单词又打错了。或许邪恶的眼睛又在笑,但是不管了。妈的,蚊子好多,已经咬来几个包了。
建议你用almate的版本。
然后,安装的时候其实很简单的。
然后装完了如果不能启动,记得给详细的错误提示。
好吧我承认我是菜鸟。但是基本的英文还是可以看的懂。还有就是我不太清楚你的MAC会不会造成问题。进不了X其实很正常。我每次都要FSCK一下。
邪恶眼睛应该出来帮下忙,但这厮似乎叛变了。 :em20


页首
 用户资料  
 
5 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 5:53 
头像

注册: 2009-08-30 14:04
帖子: 544
地址: 上海
送出感谢: 0 次
接收感谢: 10
本人尚无刻盘安装经历,回楼LZ 。本人grub硬盘引导安装曾发生过类似情况,后来查明原因,
关于用grub硬盘引导 进入livcd界面后,安装程序不认硬盘分区:
如要选择安装ubuntu到分区,先不要查看硬盘个分区。
首先必需要打开终端输入 cd /(注意这里cd和 / 之间有一空格)回车,再输入 sudo umount -l isodevice回车
这时,桌面上会自动跳出挂载ISO的分区。此时再点击桌面上的安装程序图标安装即可,方法和光盘安装完全一样。



猜想可能还是ISO的问题!(只是猜想,没帮上忙 :em03 !)


_________________
(ubuntu9.10正式版下载地址 及Windows7或XP与ubuntu9.10(或9.04)的双系统不刻盘安装
浅谈linux多系统(及安装入门 )
(请点击这里)

(初次接触linux, 了解linux, 安装ubuntu,ubuntu基础等, 请点击这里)


最后由 千里不留行 编辑于 2009-10-09 6:55,总共编辑了 4 次

页首
 用户资料  
 
6 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 7:39 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
arogue 写道:
好吧,我回来了。三更半夜的,还有蚊子。
有一个重点是:你下载的是哪个版本。
liveCD我没有用过,都是almate的。或许单词又打错了。或许邪恶的眼睛又在笑,但是不管了。妈的,蚊子好多,已经咬来几个包了。
建议你用almate的版本。
然后,安装的时候其实很简单的。
然后装完了如果不能启动,记得给详细的错误提示。
好吧我承认我是菜鸟。但是基本的英文还是可以看的懂。还有就是我不太清楚你的MAC会不会造成问题。进不了X其实很正常。我每次都要FSCK一下。
邪恶眼睛应该出来帮下忙,但这厮似乎叛变了。 :em20


忘了说了,我下载的是
ubuntu-9.10-beta-desktop-amd64.iso
ubuntu-9.10-beta-dvd-amd64.iso
这两个
其中DVD版本是有文本形式安装的,我用过,安装比用图形方式快了很多,自动弹出光盘重新启动也很正常,但是重启以后还是提示文件载入错误

MAC分区其实应该影响不大,因为虽然MAC是HFS+分区,但是在分区时我是先分NTFS,到安装MACOSX时再用OSX的抹盘工具抹成HFS+的

FSCK以前都没有用过


页首
 用户资料  
 
7 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 7:44 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
千里不留行 写道:
想问boot分区在哪?
本人认为,如果有boot分区。也还是分区的问题,或者分区表问题,或者引导分区坏了,可能是grub和MAC的tboot冲突。
本人遇到过类似问题,和你的很象。这时再用windows安装盘的8.05图形分区工具,已经不能给你的硬盘分区了,只能修正一下错误。
ubuntu9.10live里的分区工具,我不清楚,ubuntu9.04live里的分区工具也已经不能再给这个硬盘分区了,此时只好找新氧9.04或雨林木风的linux1.15的安装光盘,用这张盘进入live模式,给硬盘重新分区。
到底是新氧9.04还是雨林木风的linux1.15的安装光盘,我记不清了。
不过本人当时是第一次装Fedora12,装坏的分区表,我是用windows pe进去把windows里的东西拷到移动硬盘里,再用BT4的live盘把ubuntu的东西也拷到移动硬盘里,然后,彻底地给硬盘重新分区的。

我想的不一定对,这个法子也很笨,参考一下。


所有的LINUX文件都放在EXT4的第三分区,没有单独的BOOT分区,而且每次都是先用GParted分区的,而不是PM和PQ,也还没装MACOSX,所以应该不存在TBOOT的问题

为什么新氧或雨林的工具可以呢?我想不太明白


页首
 用户资料  
 
8 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 10:35 
头像

注册: 2009-03-28 15:12
帖子: 7867
送出感谢: 2
接收感谢: 19
arogue 写道:
好吧,我回来了。三更半夜的,还有蚊子。
有一个重点是:你下载的是哪个版本。
liveCD我没有用过,都是almate的。或许单词又打错了。或许邪恶的眼睛又在笑,但是不管了。妈的,蚊子好多,已经咬来几个包了。
建议你用almate的版本。
然后,安装的时候其实很简单的。
然后装完了如果不能启动,记得给详细的错误提示。
好吧我承认我是菜鸟。但是基本的英文还是可以看的懂。还有就是我不太清楚你的MAC会不会造成问题。进不了X其实很正常。我每次都要FSCK一下。
邪恶眼睛应该出来帮下忙,但这厮似乎叛变了。 :em20


我来了N次了,不过实在不清楚什么问题,才没发言。

LZ如果能确定刷bios前可以正常安装,刷了之后有不少问题的话,可以推断为bios不兼容。

或者可以先用以前的版安装试试,如果正常顺利的话,那就别用beta版,等正式版。如果连以前的版本都出问题了,那就bios刷回原来的看看。
引用:
设置硬件”要完成至少要40分钟

从这个来看,是硬件兼容的问题可能性最大。或者可以不要用amd64,改为i386的试试。


_________________
Grub2 基础教程


页首
 用户资料  
 
9 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 10:51 
头像

注册: 2007-10-31 20:10
帖子: 117
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
arogue 写道:
好吧,我回来了。三更半夜的,还有蚊子。
有一个重点是:你下载的是哪个版本。
liveCD我没有用过,都是almate的。或许单词又打错了。或许邪恶的眼睛又在笑,但是不管了。妈的,蚊子好多,已经咬来几个包了。
建议你用almate的版本。
然后,安装的时候其实很简单的。
然后装完了如果不能启动,记得给详细的错误提示。
好吧我承认我是菜鸟。但是基本的英文还是可以看的懂。还有就是我不太清楚你的MAC会不会造成问题。进不了X其实很正常。我每次都要FSCK一下。
邪恶眼睛应该出来帮下忙,但这厮似乎叛变了。 :em20


我来了N次了,不过实在不清楚什么问题,才没发言。

LZ如果能确定刷bios前可以正常安装,刷了之后有不少问题的话,可以推断为bios不兼容。

或者可以先用以前的版安装试试,如果正常顺利的话,那就别用beta版,等正式版。如果连以前的版本都出问题了,那就bios刷回原来的看看。
引用:
设置硬件”要完成至少要40分钟

从这个来看,是硬件兼容的问题可能性最大。或者可以不要用amd64,改为i386的试试。

我也是费了半天脑水~~~
刚睡醒,继续睡……


页首
 用户资料  
 
10 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 11:33 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
smallapple 写道:
arogue 写道:
好吧,我回来了。三更半夜的,还有蚊子。
有一个重点是:你下载的是哪个版本。
liveCD我没有用过,都是almate的。或许单词又打错了。或许邪恶的眼睛又在笑,但是不管了。妈的,蚊子好多,已经咬来几个包了。
建议你用almate的版本。
然后,安装的时候其实很简单的。
然后装完了如果不能启动,记得给详细的错误提示。
好吧我承认我是菜鸟。但是基本的英文还是可以看的懂。还有就是我不太清楚你的MAC会不会造成问题。进不了X其实很正常。我每次都要FSCK一下。
邪恶眼睛应该出来帮下忙,但这厮似乎叛变了。 :em20


我来了N次了,不过实在不清楚什么问题,才没发言。

LZ如果能确定刷bios前可以正常安装,刷了之后有不少问题的话,可以推断为bios不兼容。

或者可以先用以前的版安装试试,如果正常顺利的话,那就别用beta版,等正式版。如果连以前的版本都出问题了,那就bios刷回原来的看看。
引用:
设置硬件”要完成至少要40分钟

从这个来看,是硬件兼容的问题可能性最大。或者可以不要用amd64,改为i386的试试。
\

我也知道386的兼容性要好一些,但是个人还是偏爱64位版,只是不清楚是否和BIOS有关系


页首
 用户资料  
 
11 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 11:44 

注册: 2007-04-22 13:14
帖子: 328
送出感谢: 0 次
接收感谢: 2
不知道你是否把主分区插在了逻辑分区中间:主 | 逻辑 | 逻辑 | 主 | 逻辑
这样分区不好。
你试试fdisk -l看是否报错说分区重叠。
引导参数中别用uuid,直接指定root=/dev/sdaXX

另外:安装卡在80%的时候,直接ifconfig eth0 down,还有不要让安装程序自动安装grub。


页首
 用户资料  
 
12 楼 
 文章标题 : Re: [9.10 BETA]BETA 9.10无法安装成功(刚才可能发错了,再次发帖求助)
帖子发表于 : 2009-10-05 17:22 

注册: 2009-10-04 22:17
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
WIN OSX UBUNTU 是主分区 ,SWAP 和另外的两个盘是逻辑分区,应该不存在分区重叠的问题

ifconfig eth0 down是直接在终端里面输入吗?

还有为什么不能自动装GRUB?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 12 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译