用APT-GET命令安装软件错误

为当前最终发行版之前的所有版本提供支持
回复
student
帖子: 7
注册时间: 2006-08-27 20:57
送出感谢: 0
接收感谢: 0

用APT-GET命令安装软件错误

#1

帖子 student » 2006-08-28 3:52

我用apt-get命令安装软件的时候总是提示
E: Could not get lock /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)

E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

这是什么原因啊?
注:在ROOT权限下/。
jsleemz
帖子: 144
注册时间: 2006-07-27 15:50
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 jsleemz » 2006-08-28 10:23

你是否同时打开了新立得或软件更新,又在终端运行apt-get
就会出现这个提示。

我有时也出现这个提示,都是在上述情况下出现的。
只要关闭新立得或软件更新,再运行终端就可以了。
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#3

帖子 xiehuoli » 2006-08-28 10:29

........... :em01
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
student
帖子: 7
注册时间: 2006-08-27 20:57
送出感谢: 0
接收感谢: 0

谢谢!

#4

帖子 student » 2006-08-28 14:23

先去试一下,要是不行再来问下 :P
xdongrainbow
帖子: 25
注册时间: 2006-08-26 16:33
送出感谢: 0
接收感谢: 0
联系:

Re: 谢谢!

#5

帖子 xdongrainbow » 2006-08-28 21:20

student 写了:先去试一下,要是不行再来问下 :P
我的也是这个问题,不过没有开新得立软件包管理器。

安装flash支持没成功,后来就成这个样子了
头像
jjkppo
帖子: 157
注册时间: 2007-11-09 1:35
送出感谢: 0
接收感谢: 1 次
联系:

#6

帖子 jjkppo » 2007-11-30 15:44

:em06 :em06 :em06 原来我也是犯的这个错误。。。。。。。。
头像
sonixrp
帖子: 505
注册时间: 2007-03-28 12:39
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 sonixrp » 2007-11-30 15:59

lock 是个文件锁 当一个程序或者命令在为系统安装程序的时候会先获得这个锁,安装执行结束会释放。这一个过程中,其他程序是无法获得这个文件锁的,也是说同时只能有一个程序为系统增加程序。
目前研究自编译内核,有兴趣的朋友一起来吧~
回复

回到 “老旧版本支持”