执行aptitude upgrade时出错,应该如何解决?

为当前最终发行版之前的所有版本提供支持
回复
chylli
帖子: 18
注册时间: 2006-01-13 13:09
送出感谢: 0
接收感谢: 0

执行aptitude upgrade时出错,应该如何解决?

#1

帖子 chylli » 2006-08-28 12:23

ubuntu 6.06
在执行aptitude upgrade 时,在升级emacs-snapshot-gtk时出现如下错误

In toplevel form:
sb-info.el:54:1:Error: Recursive `require' for feature `sb-info'
Wrote /usr/share/emacs-snapshot/site-lisp/speedbar/sb-rmail.elc
Wrote /usr/share/emacs-snapshot/site-lisp/speedbar/sb-texinfo.elc
Wrote /usr/share/emacs-snapshot/site-lisp/speedbar/sb-w3.elc
Wrote /usr/share/emacs-snapshot/site-lisp/speedbar/speedbar.elc
Wrote /usr/share/emacs-snapshot/site-lisp/speedbar/speedbar-load.elc
emacs-install: /usr/lib/emacsen-common/packages/install/speedbar emacs-snapshot failed at /usr/lib/emacsen-common/emacs-install line 28, <TSORT> line 16.
dpkg:处理 emacs-snapshot-gtk (--configure)时出错:
子进程·post-installation script·返回了错误号·1
在处理时有错误发生:
emacs-snapshot-gtk

我应该如何解决?
是不是先down下来再安装?
如何做?
请指教
ahlongxp
帖子: 209
注册时间: 2006-03-06 19:16
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 ahlongxp » 2006-09-02 9:31

试一下 aptitude dist-upgrade
回复

回到 “老旧版本支持”