[问题]进不了系统

为当前最终发行版之前的所有版本提供支持
回复
tiger81
帖子: 80
注册时间: 2006-07-15 12:09
送出感谢: 0
接收感谢: 0

[问题]进不了系统

#1

帖子 tiger81 » 2006-08-29 9:55

请教个问题:
我换了个笔记本,只有一块硬盘,sata的
装完ubuntu后,重启进系统的时候提示:
ALERT! /dev/sda7 does not exist; Dropping to a shell!
BusyBox v1.01(Debian 1:1.01-4ubuntu3) Built-in shell (ash)
Enter 'help' for a list of built-in commands.
bin/sh: can't access tty; job control turned off
用live cd进去看到:
Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Device Boot Start End Blocks Id System
/dev/sda1 * 1 1275 10241406 c W95 FAT32 (LBA)
/dev/sda2 1276 2566 10369957+ af Unknown
/dev/sda3 2567 7296 37993725 f W95 Ext'd (LBA)
/dev/sda5 2567 6009 27655866 7 HPFS/NTFS
/dev/sda6 6010 6140 1052226 82 Linux swap / Solaris
/dev/sda7 6141 7296 9285538+ 83 Linux
手动挂载又提示不存在:
ubuntu@ubuntu:~$ sudo -s -H
root@ubuntu:/home/ubuntu# mkdir -p /mnt/sda7
root@ubuntu:/home/ubuntu# mount -t ext3 /dev/sda7 /mnt/sda7
mount: special device /dev/sda7 does not exist
上次由 tiger81 在 2006-08-29 10:10,总共编辑 1 次。
tiger81
帖子: 80
注册时间: 2006-07-15 12:09
送出感谢: 0
接收感谢: 0

#2

帖子 tiger81 » 2006-08-29 15:45

没人知道吗?是不是因为sata的硬盘又有ntfs分区的原因啊?
networker
帖子: 419
注册时间: 2006-02-06 21:06
来自: Shanghai,China
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 networker » 2006-08-30 9:10

是不是你的grub里的/分区位置写错了。建议检查一下。
Enter 'help' for a list of built-in commands.
还有上面提示叫你用help命令帮助,你试下。
是不是连终端也进不了呢。楼主能不能说的清楚点。
ntfs分区应该和系统启动没有什么关系,是你的windows分区吧。
tiger81
帖子: 80
注册时间: 2006-07-15 12:09
送出感谢: 0
接收感谢: 0

#4

帖子 tiger81 » 2006-08-30 9:53

networker 写了:是不是你的grub里的/分区位置写错了。建议检查一下。
Enter 'help' for a list of built-in commands.
还有上面提示叫你用help命令帮助,你试下。
是不是连终端也进不了呢。楼主能不能说的清楚点。
ntfs分区应该和系统启动没有什么关系,是你的windows分区吧。

应该不是grub的问题,能读取menu.lst文件。
终端也进不去啊,只能用livecd进去,还不能访问硬盘的linux分区。但是用fdisk可以看到。
郁闷啊!装了几遍都是这个问题,换了几张安装盘也不行。
tiger81
帖子: 80
注册时间: 2006-07-15 12:09
送出感谢: 0
接收感谢: 0

#5

帖子 tiger81 » 2006-08-30 22:00

试了alternate和网络安装,都是装到快完时就停在一个白色斑块的画面,装不上啊!
intel945gm的芯片,gma950显卡,应该没问题的啊
上次由 tiger81 在 2006-09-02 10:41,总共编辑 1 次。
tiger81
帖子: 80
注册时间: 2006-07-15 12:09
送出感谢: 0
接收感谢: 0

#6

帖子 tiger81 » 2006-09-02 9:18

试了fedora和suse都没这个问题,难道真的没办法?
难道让我放弃ubuntu吗?
回复

回到 “老旧版本支持”