[问题]请大家帮忙(已解决)

为当前最终发行版之前的所有版本提供支持
回复
james743
帖子: 117
注册时间: 2005-05-03 9:51
送出感谢: 0
接收感谢: 0

[问题]请大家帮忙(已解决)

#1

帖子 james743 » 2006-08-29 19:54

make -C /home/jameszhou/v4l-dvb/v4l
make[1]: Entering directory `/home/jameszhou/v4l-dvb/v4l'
scripts/make_makefile.pl /lib/modules/2.6.15-26-686/build
File not found: /lib/modules/2.6.15-26-686/build/include/linux/autoconf.h at ./scripts/make_kconfig.pl line 29.
make[1]: *** 没有规则可以创建“config-compat.h”需要的目标“.myconfig”。 停止。
make[1]: Leaving directory `/home/jameszhou/v4l-dvb/v4l'
make: *** [all] 错误 2

我想编译一个程序,蛤执行make后出现上面的提示,请问是怎么回事,应该怎么办?build-essential, gcc, make都已安装并已经是最新版本了。

原来只要装上相应内核的header就可以了。
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2006-09-01 14:39

需要首先用autoconf、automake来产生所需要的文件,很复杂,自己google一下吧!
回复

回到 “老旧版本支持”