当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页
作者 内容
1 楼 
 文章标题 : 各位使用breezy的朋友们安装上nvidia的驱动了么?
帖子发表于 : 2005-08-26 2:24 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
root@maniac:~ # apt-get install nvidia-glx
Reading package lists... Done
Building dependency tree... Done
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对问题的解决有所帮助:

下列的软件包有不能满足的依赖关系:
nvidia-glx: Depends: libglu1-mesa 但是它将不会被安装 或
libglu1
E: 受损安装包
root@maniac:~ #


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2005-08-26 7:24 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我不知什么时候安装了nvidia-glx 的,但好像装得不完全,并没认出我的显卡。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
3 楼 
 文章标题 :
帖子发表于 : 2005-08-26 11:43 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
问题解决了, 今天在官方的源里发现了新的libgl1,装上之后就可以apt-get install nvidia-glx了


页首
 用户资料  
 
4 楼 
 文章标题 :
帖子发表于 : 2005-08-26 13:23 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
maniac 写道:
问题解决了, 今天在官方的源里发现了新的libgl1,装上之后就可以apt-get install nvidia-glx了

请问兄弟,你用哪个libgl1?
我装的是libgl1-mesa 和 libgl1-mesa-dri,发现没logo出来的。
我看到还有libgl1-xorg 的。


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2005-08-26 13:28 
头像

注册: 2005-05-19 15:53
帖子: 77
地址: 重庆市
送出感谢: 0 次
接收感谢: 0 次
我今天升级,新立得把nvidia-glx卸载了,当我重新安装nvidia-glx的时候,发现和刚升级的amule等不能共存。


_________________
问君能有几多愁?
恰似一江春水向东流......


页首
 用户资料  
 
6 楼 
 文章标题 :
帖子发表于 : 2005-08-26 14:30 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
yongyi 写道:
请问兄弟,你用哪个libgl1?
我装的是libgl1-mesa 和 libgl1-mesa-dri,发现没logo出来的。
我看到还有libgl1-xorg 的。

和你装的好像一样,然后重新装nvidia-glx,再改配置文件就行了,这两个包似乎在今天凌晨还没有,到早上才放出来的


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2005-08-26 14:57 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
晕。我可一直都在用啊。。。
那你启动时有nvidia的logo吗?
还有,你的xorg.conf中认出显卡的驱动是nvidia吗?(我的只能认出是mesa)


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
8 楼 
 文章标题 :
帖子发表于 : 2005-08-26 15:15 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
我是手动把xorg.conf里的nv改成nvidia的,启动时有Logo,因为我的液晶屏在没驱动的时候都会往右偏十几个像素,所以装上驱动后的效果很明显。quake3运行也很流畅。


页首
 用户资料  
 
9 楼 
 文章标题 :
帖子发表于 : 2005-08-26 15:39 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
我改成改成nvidia也没有logo,偏移倒是见效,但玩游戏不对劲,跟没安装显卡驱动一样。 :twisted:


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
10 楼 
 文章标题 :
帖子发表于 : 2005-08-26 19:22 
头像

注册: 2005-04-08 14:54
帖子: 310
送出感谢: 0 次
接收感谢: 0 次
怎么大家都在用breezy了吗?


页首
 用户资料  
 
11 楼 
 文章标题 :
帖子发表于 : 2005-08-26 19:48 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
郁闷!这系统什么时候把nvidia-glx给我卸载了的 :evil:
原来一直在忙呼都是白忙。

但好像依赖没解决!
在新立得安装nvidia-glx,竟然要卸载一大堆软件!甚至要卸载x-window-system-core!!


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
12 楼 
 文章标题 :
帖子发表于 : 2005-08-26 20:26 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
不会吧,你用官方的源试试


页首
 用户资料  
 
13 楼 
 文章标题 :
帖子发表于 : 2005-08-27 0:04 

注册: 2005-05-07 23:57
帖子: 3025
送出感谢: 0 次
接收感谢: 0 次
好了,更新后,可以安装了。可是还不能出现logo,我
sudo dpkg-reconfigure xserver-xorg
却在启动时弹出错误的提示窗口!
查看一下/var/log/Xorg.0.log,摘录开头部分:
X Window System Version 6.8.2 (Ubuntu 6.8.2-53 20050820201910 root@vernadsky.buildd)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.10 i686 [ELF]
Current Operating System: Linux ubuntu 2.6.12-6-686 #1 Wed Aug 10 22:27:35 BST 2005 i686
Build Date: 20 August 2005
Before reporting problems, check http://wiki.X.Org
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-6-686 (buildd@rothera) (gcc version 3.4.5 20050729 (prerelease) (Debian 3.4.4-6ubuntu2)) #1 Wed Aug 10 22:27:35 BST 2005
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri Aug 26 23:52:56 2005
(==) Using config file: "/home/yongyi/xorg.conf"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "StudioWorks"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) |-->Input Device "Configured Mouse"
(WW) The directory "/usr/share/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/share/X11/fonts/CID" does not exist.
Entry deleted from font path.
(WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID".
Entry deleted from font path.
(Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID").
(**) FontPath set to "unix/:7100,/usr/share/X11/fonts/misc,/usr/share/X11/fonts/100dpi/:unscaled,/usr/share/X11/fonts/75dpi/:unscaled,/usr/share/X11/fonts/Type1,/usr/share/X11/fonts/100dpi,/usr/share/X11/fonts/75dpi,/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
Couldn't open RGB_DB '/usr/X11R6/lib/X11/rgb'
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.2
X.Org Video Driver: 0.7
X.Org XInput driver : 0.4
X.Org Server Extension : 0.2
X.Org Font Renderer : 0.4



这要怎么搞定呀?
RGB_DB '/usr/X11R6/lib/X11/rgb' 没有呢。。。




我的xorg.conf:
代码:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
   FontPath   "unix/:7100"         # local font server
   # if the local font server has problems, we can fall back on these
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/CID"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
   Load   "dri"
   Load   "glx"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
   VideoRam   65536
   Option      "UseFBDev"      "true"
EndSection

Section "Monitor"
   Identifier   "StudioWorks"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV11 [GeForce2 MX/MX 400]"
   Monitor      "StudioWorks"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "832x624" "800x600" "720x450" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection


_________________
独自看一看大海
总想起身边走在路上的朋友
Lenovo E290-420[Celeron-M420/256M/60G/Intel GMA950]


页首
 用户资料  
 
14 楼 
 文章标题 :
帖子发表于 : 2005-08-27 0:13 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
把Load "dri" 注释掉试试
我也没有/usr/X11R6/lib/X11/rgb,应该不是什么重要的文件夹
或者你看看我的和你的配置文件上有什么不同
代码:
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
   FontPath   "unix/:7100"         # local font server
   # if the local font server has problems, we can fall back on these
   FontPath   "/usr/share/X11/fonts/misc"
   FontPath   "/usr/share/X11/fonts/cyrillic"
   FontPath   "/usr/share/X11/fonts/100dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/75dpi/:unscaled"
   FontPath   "/usr/share/X11/fonts/Type1"
   FontPath   "/usr/share/X11/fonts/CID"
   FontPath   "/usr/share/X11/fonts/100dpi"
   FontPath   "/usr/share/X11/fonts/75dpi"
        # paths to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
   Load   "bitmap"
   Load   "dbe"
   Load   "ddc"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "record"
   Load   "type1"
   Load   "v4l"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc104"
   Option      "XkbLayout"   "us"
   Option      "XkbVariant"   "dvorak"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "Emulate3Buttons"   "true"
   Option      "ZAxisMapping"      "4 5"
EndSection

Section "Device"
   Identifier   "NVIDIA Corporation NV17 [GeForce4 MX 440]"
   Driver      "nvidia"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "Philips 150B"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "NVIDIA Corporation NV17 [GeForce4 MX 440]"
   Monitor      "Philips 150B"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
EndSection

Section "DRI"
   Mode   0666
EndSection


页首
 用户资料  
 
15 楼 
 文章标题 :
帖子发表于 : 2005-08-27 0:31 

注册: 2005-06-12 1:42
帖子: 138
送出感谢: 0 次
接收感谢: 0 次
max0000 写道:
怎么大家都在用breezy了吗?

是啊,breezy已经没什么大问题了,都是些小问题,耗了我不少时间


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 25 篇帖子 ]  前往页数 1, 2  下一页

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译