当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 13 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-25 20:38 

注册: 2007-10-24 17:56
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
这是终端错误提示
~$ amsn
Error in startup script: unknown encoding "gb18030"
while executing
"fconfigure $file_id -encoding $current_enc"
(procedure "load_lang" line 30)
invoked from within
"load_lang [::config::getGlobalKey language]"
invoked from within
"if { $initialize_amsn == 1 } {
###############################################################
create_dir $HOME
create_dir $HOME/plugins
create_di..."
(file "config.tcl" line 1881)
invoked from within
"source config.tcl "
("uplevel" body line 29)
invoked from within
"uplevel \#0 {

# amsncore.tcl is already loaded but we'll re-source it here in case we manually do reload_files
source amsncore.tcl
source audio.tc..."
(procedure "reload_files" line 2)
invoked from within
"reload_files"
(file "/usr/bin/amsn" line 290)


最后由 yanglh 编辑于 2009-10-25 22:08,总共编辑了 1 次

页首
 用户资料  
 
2 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了
帖子发表于 : 2009-10-25 20:51 

注册: 2008-12-16 14:16
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
代码:

export current_enc=utf-8

amsn



试试看。从log来看,是编码的问题


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了
帖子发表于 : 2009-10-25 20:54 

注册: 2008-12-16 14:16
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
ubuntu默认安装了python,在命令行下输入

代码:
zhaolei@zhaolei:~$ python
Python 2.6.4rc2 (r264rc2:75497, Oct 20 2009, 02:55:11)
[GCC 4.4.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import locale
>>> locale.getdefaultlocale()
('zh_CN', 'UTF8')
>>>


或者
代码:
zhaolei@zhaolei:~$ locale
LANG=zh_CN.UTF-8
LANGUAGE=zh_CN.UTF-8
LC_CTYPE="zh_CN.UTF-8"
LC_NUMERIC="zh_CN.UTF-8"
LC_TIME="zh_CN.UTF-8"
LC_COLLATE="zh_CN.UTF-8"
LC_MONETARY="zh_CN.UTF-8"
LC_MESSAGES="zh_CN.UTF-8"
LC_PAPER="zh_CN.UTF-8"
LC_NAME="zh_CN.UTF-8"
LC_ADDRESS="zh_CN.UTF-8"
LC_TELEPHONE="zh_CN.UTF-8"
LC_MEASUREMENT="zh_CN.UTF-8"
LC_IDENTIFICATION="zh_CN.UTF-8"
LC_ALL=
zhaolei@zhaolei:~$


utf-8就是你系统编码


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了
帖子发表于 : 2009-10-25 21:06 

注册: 2007-10-24 17:56
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
谢谢,但是还不行, 二楼和三楼的方法都试了,问题依旧


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了
帖子发表于 : 2009-10-25 21:13 

注册: 2008-12-16 14:16
帖子: 68
送出感谢: 0 次
接收感谢: 0 次
恩,那就把amsn卸载,再重新安装看看 或者到
http://www.amsn-project.net/download.php下载最新的版本试试看

现在Ubuntu9.10运行一些软件是有点问题,看看正式版怎么样。


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了
帖子发表于 : 2009-10-25 21:59 

注册: 2007-10-24 17:56
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
OK了 ,谢谢
用ubuntu 的deb包安装还是一样有问题

下了package 包安装的 0.97.2版
这个版本好像有点问题,一点偏好设定就不停的出错


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-26 8:31 

注册: 2007-10-24 17:56
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
今天换源重新安装也OK了
原来用网易的源
看来网易的源不太好用


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-30 15:56 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
我装到9.10正式版,用到台湾源,也不行阿!


页首
 用户资料  
 
9 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-30 16:06 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
You need TCL/TK 8.4\
or better to run aMSN. Please upgrade.


页首
 用户资料  
 
10 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-30 19:38 
头像

注册: 2007-07-11 21:43
帖子: 3382
地址: 东江边
系统: archlinux
送出感谢: 15
接收感谢: 7
我到官方下载最新版本安装之后成功了


_________________
我来了,我看见了,我征服了!
求勾搭,不管饭。


页首
 用户资料  
 
11 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-10-31 11:38 

注册: 2008-10-27 22:28
帖子: 369
送出感谢: 0 次
接收感谢: 0 次
我昨天也去官方下的,还是不行啊!周一去公司再看吧


页首
 用户资料  
 
12 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[真正OK了]
帖子发表于 : 2009-11-20 9:12 

注册: 2007-10-24 17:56
帖子: 111
送出感谢: 0 次
接收感谢: 0 次
今天终于把这个问题搞清楚了,问题出在 langlist上面,新版AMSN里面多了一个gb18030的编码,估计tcl还不认识吧

用0.97的 langlist 覆盖一下就OK了

我的 langlist 在 /usr/share/amsn/ 里面

sudo cp ../amsn-0.97.2/langlist /usr/share/amsn

amsn正常启动

附件传不上来,就直接贴了
<?xml version="1.0"?>

<version>
<lang>
<langcode>al</langcode>
<name>Albanian (shqip)</name>
<version>1.11</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>ast</langcode>
<name>Asturian</name>
<version>1.3</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>eu</langcode>
<name>Basque (euskera)</name>
<version>1.37</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>bn</langcode>
<name>Bengali (বাংলা)</name>
<version>1.3</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>bs</langcode>
<name>Bosnian (Bosanski)</name>
<version>1.2</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>bg</langcode>
<name>Bulgarian</name>
<version>1.1</version>
<encoding>cp1251</encoding>
</lang>
<lang>
<langcode>ca</langcode>
<name>Catalan-Valencian (Català-Valencià)</name>
<version>1.123</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>cs</langcode>
<name>Cesky</name>
<version>1.13</version>
<encoding>iso8859-2</encoding>
</lang>
<lang>
<langcode>zh-CN</langcode>
<name>Chinese - Simplified (中文)</name>
<version>1.2</version>
<encoding>gb2312</encoding>
</lang>
<lang>
<langcode>zh-TW</langcode>
<name>Chinese - Taiwanese (台語)</name>
<version>1.12</version>
<encoding>big5</encoding>
</lang>
<lang>
<langcode>da</langcode>
<name>Danish (dansk)</name>
<version>1.46</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>nl</langcode>
<name>Dutch (Nederlands)</name>
<version>1.137</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>ei</langcode>
<name>Eivissenc</name>
<version>1.1</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>en</langcode>
<name>English</name>
<version>1.372</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>eo</langcode>
<name>Esperanto</name>
<version>1.7</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>ee</langcode>
<name>Estonian (eesti keel)</name>
<version>1.41</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>fi</langcode>
<name>Finnish (suomi)</name>
<version>1.10</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>fr</langcode>
<name>French - France (français)</name>
<version>1.172</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>fr_CA</langcode>
<name>French - Canadian</name>
<version>1.8</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>fri</langcode>
<name>Frisian (Frysk)</name>
<version>1.17</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>fur</langcode>
<name>Friulan (Furlan)</name>
<version>1.4</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>glg</langcode>
<name>Galician (Galego)</name>
<version>1.6</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>de</langcode>
<name>German (Deutsch)</name>
<version>1.52</version>
<encoding>iso8859-15</encoding>
</lang>
<lang>
<langcode>el</langcode>
<name>Greek (ελληνικά)</name>
<version>1.16</version>
<encoding>iso8859-7</encoding>
</lang>
<lang>
<langcode>gr2</langcode>
<name>Greeklish</name>
<version>1.8</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>hu</langcode>
<name>Hungarian (magyar)</name>
<version>1.23</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>id</langcode>
<name>Indonesian (Bahasa Indonesia)</name>
<version>1.50</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>is</langcode>
<name>Icelandic (Íslenska)</name>
<version>1.10</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>it</langcode>
<name>Italian (italiano)</name>
<version>1.69</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>ja</langcode>
<name>Japanese (日本語)</name>
<version>1.16</version>
<encoding>euc-jp</encoding>
</lang>
<lang>
<langcode>ko</langcode>
<name>Korean (한국어)</name>
<version>1.0</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>lt</langcode>
<name>Lithuanian (lietuviškai)</name>
<version> 1.0</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>mk</langcode>
<name>Macedonian (Македонски)</name>
<version>1.14</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>mn</langcode>
<name>Mongolian (Монгол)</name>
<version>1.9</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>no</langcode>
<name>Norwegian (Norsk)</name>
<version>1.52</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>oc</langcode>
<name>Occitan</name>
<version>1.0</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>pl</langcode>
<name>Polish (polski)</name>
<version>1.7</version>
<encoding>iso8859-2</encoding>
</lang>
<lang>
<langcode>pt</langcode>
<name>Portuguese - Portugal (português)</name>
<version>1.63</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>pt_BR</langcode>
<name>Portuguese - Brazil</name>
<version>1.36</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>ro</langcode>
<name>Romanian (Limba Română)</name>
<version>1.38</version>
<encoding>iso8859-2</encoding>
</lang>
<lang>
<langcode>ru</langcode>
<name>Russian (Русский язык)</name>
<version>1.20</version>
<encoding>koi8-r</encoding>
</lang>
<lang>
<langcode>sk</langcode>
<name>Slovak (slovenčina)</name>
<version>1.11</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>sl</langcode>
<name>Slovenian (slovenščina)</name>
<version>1.43</version>
<encoding>iso8859-2</encoding>
</lang>
<lang>
<langcode>af</langcode>
<name>South African</name>
<version>1.6</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>es</langcode>
<name>Spanish (Español)</name>
<version>1.252</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>sr</langcode>
<name>Serbian (Српски)</name>
<version>1.12</version>
<encoding>iso8859-5</encoding>
</lang>
<lang>
<langcode>sv</langcode>
<name>Swedish (svenska)</name>
<version>1.18</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>swa</langcode>
<name>Swahili (Kiswahili)</name>
<version>1.19</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>ta</langcode>
<name>Tamil (தமிழ்)</name>
<version>1.5</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>tr</langcode>
<name>Turkish (Türkçe)</name>
<version>1.62</version>
<encoding>iso8859-9</encoding>
</lang>
<lang>
<langcode>ca_VC</langcode>
<name>Valencian-Catalan (Valencià - Català)</name>
<version>1.2</version>
<encoding>iso8859-1</encoding>
</lang>
<lang>
<langcode>cy</langcode>
<name>Welsh (Cymraeg)</name>
<version>1.11</version>
<encoding>utf-8</encoding>
</lang>
<lang>
<langcode>mt</langcode>
<name>Maltese</name>
<version>0.1</version>
<encoding>utf-8</encoding>
</lang>
</version>


页首
 用户资料  
 
13 楼 
 文章标题 : Re: 求助,升级后amsn无法启动了地[O了]
帖子发表于 : 2009-11-20 15:18 

注册: 2009-03-10 21:46
帖子: 27
送出感谢: 0 次
接收感谢: 0 次
这是由于字符编码的问题引起的,将/usr/share/amsn/langlist

<langcode>zh-CN</langcode>
<name>Chinese - Simplified (中文)</name>
<version>1.2</version>
<encoding>gb18030</encoding>
</lang>
改为
<langcode>zh-CN</langcode>
<name>Chinese - Simplified (中文)</name>
<version>1.2</version>
<encoding>gb2312</encoding>
</lang>


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 13 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译