如何安装nvidia的驱动??

为当前最终发行版之前的所有版本提供支持
回复
hanny
帖子: 197
注册时间: 2006-08-29 0:24
送出感谢: 0
接收感谢: 0

如何安装nvidia的驱动??

#1

帖子 hanny » 2006-09-02 22:47

hanny@hanny-yeung:~$ sudo apt-get install nvidia-glx
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
现在没有可用的软件包 nvidia-glx,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 nvidia-glx 还没有可供安装的候选者
hanny@hanny-yeung:~$

我安装的时候,出这个信息!!

谢谢!
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-09-02 23:22

你update了?设置好源了?
● 鸣学
hanny
帖子: 197
注册时间: 2006-08-29 0:24
送出感谢: 0
接收感谢: 0

#3

帖子 hanny » 2006-09-02 23:53

你是说系统更新么?我更新过了,已经是最新的了,源也设置了
deb http://ubuntu.cn99.com/ubuntu/ dapper main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-updates main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-security main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu/ dapper-backports main restricted universe multiverse
deb http://ubuntu.cn99.com/ubuntu-cn/ dapper main restricted universe multiverse

就是这个源
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

我一样的源都有啊。只是没下,因为没需要。

#4

帖子 eexpress » 2006-09-03 0:12

$ as nvidia-glx
nvidia-glx - NVIDIA binary XFree86 4.x/X.Org driver
nvidia-glx-dev - NVIDIA binary XFree86 4.x/X.Org driver development files
nvidia-glx-legacy - NVIDIA binary XFree86 4.x/X.Org 'legacy' driver
nvidia-glx-legacy-dev - NVIDIA binary XFree86 4.x/X.Org 'legacy' driver development files
nvidia-kernel-source - NVIDIA binary kernel module source
nvidia-legacy-kernel-source - NVIDIA binary 'legacy' kernel module source
● 鸣学
hanny
帖子: 197
注册时间: 2006-08-29 0:24
送出感谢: 0
接收感谢: 0

#5

帖子 hanny » 2006-09-03 0:21

我的命令用对么?
hanny
帖子: 197
注册时间: 2006-08-29 0:24
送出感谢: 0
接收感谢: 0

#6

帖子 hanny » 2006-09-03 0:27

晕死,我刚才试了一下,又可以了,之前一直不成功,不知道什么原因
不过还是谢谢eexpress!
hanny
帖子: 197
注册时间: 2006-08-29 0:24
送出感谢: 0
接收感谢: 0

#7

帖子 hanny » 2006-09-03 0:40

但是还有个问题
Error: your X configuration has been altered.
This script cannot proceed automatically. If you believe that this
not correct, you can update the md5sum entry executing the following
command:
md5sum /etc/X11/xorg.conf | sudo tee /var/lib/x11/xorg.conf.md5sum
otherwise edit manually /etc/X11/xorg.conf to change the Driver section

我想手动编辑xorg.conf文件的时候,却没有发现Driver 这部分,为什么??
头像
oneleaf
论坛管理员
帖子: 10231
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#8

帖子 oneleaf » 2006-09-03 9:13

先运行一下:

md5sum /etc/X11/xorg.conf | sudo tee /var/lib/x11/xorg.conf.md5sum
iamfriday
帖子: 36
注册时间: 2006-09-03 10:26
送出感谢: 0
接收感谢: 0

#9

帖子 iamfriday » 2006-09-03 10:34

安装驱动,应该先init 3吧?
回复

回到 “老旧版本支持”