当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-01 21:30 

注册: 2006-10-10 11:01
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
怎么ubuntu9.10安装不了vim?ubuntu9.10为desktop版本,默认安装..如果没有vim,在命令行界面中vi不正常..似乎连I命令都无法用...如果是putty连接,则vi会把好多按键当成特殊字符...vim则正常...老版本的ubuntu都可以安vim的...

user@machine:~$ sudo apt-get install vim
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
现在没有可用的软件包 vim,但是它被其它的软件包引用了。
这可能意味着这个缺失的软件包可能已被废弃,
或者只能在其他发布源中找到
E: 软件包 vim 还没有可供安装的候选者
user@machine:~$ vim
The program 'vim' can be found in the following packages:
* vim
* vim-gnome
* vim-tiny
* vim-gtk
* vim-nox
Try: sudo apt-get install <selected package>
vim: command not found
user@machine:~$ sudo apt-get install vim-tiny
正在读取软件包列表... 完成
正在分析软件包的依赖关系树
正在读取状态信息... 完成
vim-tiny 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-01 21:48 
头像

注册: 2007-01-15 9:59
帖子: 64
地址: beijing china
送出感谢: 0 次
接收感谢: 0 次
dpkg -L vim-tiny看看


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-01 22:00 

注册: 2006-10-10 11:01
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
user@machine:~$ dpkg -L vim-tiny
/.
/usr
/usr/share
/usr/share/vim
/usr/share/vim/vim72
/usr/share/vim/vim72/doc
/usr/share/vim/vim72/doc/README.Debian
/usr/share/vim/vim72/doc/tags
/usr/share/vim/vim72/doc/help.txt
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/vim-tiny
/usr/share/bug
/usr/share/bug/vim-tiny
/usr/share/bug/vim-tiny/presubj
/usr/share/doc
/usr/bin
/usr/bin/vim.tiny
/etc
/etc/vim
/etc/vim/vimrc.tiny
/usr/share/vim/vimrc.tiny
/usr/share/doc/vim-tiny


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-01 22:04 
头像

注册: 2008-03-30 11:42
帖子: 621
送出感谢: 0 次
接收感谢: 1
我的也是啊,从Beta版开始就是这样了,换源试一下,我用的是台湾的源,不知道别的源里面是不是会有,安装vim-full的时候是安装不上去的。


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-01 22:05 

注册: 2006-10-10 11:01
帖子: 147
送出感谢: 0 次
接收感谢: 0 次
搞定了,要先
sudo apt-get update
然后再
sudo apt-get install vim


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2009-11-03 20:14 
头像

注册: 2007-01-15 9:59
帖子: 64
地址: beijing china
送出感谢: 0 次
接收感谢: 0 次
gydoesit 写道:
user@machine:~$ dpkg -L vim-tiny
/.
/usr
/usr/share
/usr/share/vim
/usr/share/vim/vim72
/usr/share/vim/vim72/doc
/usr/share/vim/vim72/doc/README.Debian
/usr/share/vim/vim72/doc/tags
/usr/share/vim/vim72/doc/help.txt
/usr/share/lintian
/usr/share/lintian/overrides
/usr/share/lintian/overrides/vim-tiny
/usr/share/bug
/usr/share/bug/vim-tiny
/usr/share/bug/vim-tiny/presubj
/usr/share/doc
/usr/bin
/usr/bin/vim.tiny
/etc
/etc/vim
/etc/vim/vimrc.tiny
/usr/share/vim/vimrc.tiny
/usr/share/doc/vim-tiny


/usr/bin/vim.tiny不就是吗?不过怎么是vim.tiny呢,应该是 vim-tiny呀


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 怎么ubuntu9.10安装不了vim?
帖子发表于 : 2011-01-23 0:06 

注册: 2010-12-06 10:18
帖子: 3
送出感谢: 0 次
接收感谢: 1
5楼说的对
先sudo apt-get update
然后sudo apt-get install vim就可以了 :em11


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译