当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 1 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 9.10 code::blocks安装出现问题及解决(无法启动)
帖子发表于 : 2009-11-02 16:13 

注册: 2009-11-02 16:07
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我是想用openFrameworks,开始直接利用openframeworks的install_codeblocks.sh安装后,从终端启动codeblocks出现一下错误:

引用:
codeblocks: relocation error: /usr/lib/libcodeblocks.so.0: symbol _Z18wxSafeConvertWX2MBPKw, version WXU_2.8.2 not defined in file libwx_baseu-2.8.so.0 with link time reference


从google上搜了一下,找到这个帖:
http://forums.codeblocks.org/index.php/ ... 11.75.html
首先按照这家伙说的,修改了install_codeblocks.sh,"deb http://apt.wxwidgets.org/ hardy-wx main "改为 "deb http://apt.wxwidgets.org/ jaunty-wx main "
但是重新装了以后还是那个问题....

郁闷了许久...

从http://sourceforge.net/projects/codeblocks/直接下载了Code::Blocks的deb包,然后安装“sudo dpkg -i *deb”。
一开始还是失败了,提示依赖不对什么的...
找到开头安装失败的地方,安装了libwxgtk2.8-0 ...
然后再次“sudo dpkg -i *deb”

启动,居然可以了...

后来把codeblocks升级了一下,又不能运行了,同样的错误....
系统把codeblocks-contrib (8.02-0ubuntu1) to 8.02svn5857-0ubuntu1~hardy....都升级到hardy版本的(看来这个版本在Karmic中真的是“It seems that for Ubuntu Karmic 9.10, the wxWidgets libraries are provided but no more compatible with C::B compiled with the library from wxWidgets (Hardy Heron for me).”).
只好把codeblocks删除了.
引用:
已删除下列软件包:
codeblocks
codeblocks-common
codeblocks-contrib
codeblocks-contrib-common
codeblocks-dbg
codeblocks-dev
codeblocks-headers
libwxsmithlib0
libwxsmithlib0-dev
wxsmith-dev
wxsmith-headers


安装下载的Code::Blocks:
引用:
选中了曾被取消选择的软件包 codeblocks。
(正在读取数据库 ... 系统当前总共安装有 122135 个文件和目录。)
正在解压缩 codeblocks (从 codeblocks_8.02-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 codeblocks-contrib。
正在解压缩 codeblocks-contrib (从 codeblocks-contrib_8.02-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 codeblocks-dbg。
正在解压缩 codeblocks-dbg (从 codeblocks-dbg_8.02-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 codeblocks-dev。
正在解压缩 codeblocks-dev (从 codeblocks-dev_8.02-0ubuntu1_i386.deb) ...
dpkg:警告:即将把 libcodeblocks0 从 8.02svn5857-0ubuntu1~hardy 降级到 8.02-0ubuntu1。
正预备替换 libcodeblocks0 8.02svn5857-0ubuntu1~hardy (使用 libcodeblocks0_8.02-0ubuntu1_i386.deb) ...
正在解压缩将用于更替的包文件 libcodeblocks0 ...
选中了曾被取消选择的软件包 libwxsmithlib0。
正在解压缩 libwxsmithlib0 (从 libwxsmithlib0_8.02-0ubuntu1_i386.deb) ...
选中了曾被取消选择的软件包 libwxsmithlib0-dev。
正在解压缩 libwxsmithlib0-dev (从 libwxsmithlib0-dev_8.02-0ubuntu1_i386.deb) ...
正在设置 libcodeblocks0 (8.02-0ubuntu1) ...

正在设置 libwxsmithlib0 (8.02-0ubuntu1) ...

正在设置 libwxsmithlib0-dev (8.02-0ubuntu1) ...
正在设置 codeblocks (8.02-0ubuntu1) ...

正在设置 codeblocks-dev (8.02-0ubuntu1) ...
正在处理用于 desktop-file-utils 的触发器...
正在处理用于 gnome-icon-theme 的触发器...
正在处理用于 man-db 的触发器...
正在处理用于 shared-mime-info 的触发器...
正在设置 codeblocks-contrib (8.02-0ubuntu1) ...
正在设置 codeblocks-dbg (8.02-0ubuntu1) ...
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 1 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译