[问题]网络设置的问题,请教各位达人

为当前最终发行版之前的所有版本提供支持
回复
seecool
帖子: 3
注册时间: 2006-09-04 5:41
送出感谢: 0
接收感谢: 0

[问题]网络设置的问题,请教各位达人

#1

帖子 seecool » 2006-09-06 3:03

昨天开始装上了ubuntu就一直跟我的网卡们战斗着。我的机器里有两个网卡一个DLink 530G+ Wireless一个主板自带的板是Gigabyte K8NMF9,安装完ubuntu两个网卡都被识别出来了。我想通过一个和我的路由器连接上网。

eth0 Link encap:Ethernet HWaddr 00:14:85:29:83:89
inet addr:192.168.2.105 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::214:85ff:fe29:8389/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7296 errors:0 dropped:0 overruns:0 frame:0
TX packets:4317 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10575361 (10.0 MiB) TX bytes:348535 (340.3 KiB)
Interrupt:217 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:7 errors:0 dropped:0 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:372 (372.0 b) TX bytes:372 (372.0 b)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:13:46:B1:D6:BB
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:66 Base address:0x4000

进入系统的时候,internet的连接时有时无。如果没有连接的时候,我要是用 sudo ifdown eth0,然后sudo ifup eth0.一下就有连接就了。真的很奇怪,怎么能让我的ubuntu启动之后100%通过路由器和互联网连接呢?
顺变问下,怎么可以通过wireless卡连结呢?

非常感谢。
seecool
帖子: 3
注册时间: 2006-09-04 5:41
送出感谢: 0
接收感谢: 0

Re: [问题]网络设置的问题,请教各位达人

#2

帖子 seecool » 2006-09-06 17:50

ding xia zi ji
albatross
帖子: 10
注册时间: 2006-09-06 13:49
送出感谢: 0
接收感谢: 0

#3

帖子 albatross » 2006-09-06 19:27

看起来你还有一块网卡没有被识别,你是不是通过 eth0 连接路由器上网的的?
seecool
帖子: 3
注册时间: 2006-09-04 5:41
送出感谢: 0
接收感谢: 0

#4

帖子 seecool » 2006-09-06 23:38

对,原本我还希望能用无线网卡上网,所以请了个达人帮我调了下,好象他用了什么软件引用了我winxp下的无线网卡驱动.然后一切ok了。然后我又以及重新装了一遍,就一直有这个毛病.必须手动终止,然后在连接.后来我想大概是我的无线网卡也许和系统有冲突?我就干脆把它给拔了。但是毛病依旧.苦恼啊.我现在就是想知道,如何正确的设置我的普通有线网卡就可以了。 :( 但是最好也能帮帮我,如何设置无线网卡,比如如何在linux中加在硬件在winxp中的驱动 :? xiexie
头像
ubuntu_amateur
帖子: 79
注册时间: 2006-06-10 14:58
来自: China
送出感谢: 0
接收感谢: 0

#5

帖子 ubuntu_amateur » 2006-11-21 11:27

Step 1a)通过浏览器,敲192.168.1.1(假设你的路由器在LAN的IP地址是这个嗬),将DSN Server的IP记下。
1b)或者在System->Administration->Networking中看也可以。

Step 2)sudo gedit /etc/dhcp3/dhclient.conf
将#prepend domain-name-servers 127.0.0.1;一行的#去掉,将127.0.0.1改为如上提及的确切的DSN Server IP地址。

Step 3)sudo /etc/init.d/networking restart
路由器的复位时间改长一点,每次复位就得运行一次。没办法,有些路由器是这样子的,D-Link没有此现象。

以后不用每次启动都运行一遍sudo ifdown eth0及sudo ifup eth0啦!
回复

回到 “老旧版本支持”