当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 7 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 新手!系统更新出现错误,我该怎么办?急!
帖子发表于 : 2006-09-08 0:32 

注册: 2006-09-07 22:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
刚刚从上海交大源下载了更新,我点击安装之后提示如下:
“软件索引已被破坏

无法安装或删除任何软件。请使用包管理软件"synaptic"或在终端运行"sudo apt-get install -f"来修正这个问题。”

我在终端运行之后
“E: 无法获得锁 /var/lib/dpkg/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?”


页首
 用户资料  
 
2 楼 
 文章标题 :
帖子发表于 : 2006-09-08 3:08 
头像

注册: 2006-08-22 16:42
帖子: 62
地址: 广东省广州市
送出感谢: 0 次
接收感谢: 0 次
出错是由于你同时运行多个系统管理程序,可能是你还没有退出新立德管理软件,你把新立德软件先退出后再运行命令应该没有问题.啦


_________________
放飞心情,用最真的语言舞动最真的心......
>>梦之海豚,请勇往直前-->我的Blog


页首
 用户资料  
 
3 楼 
 文章标题 : 我的也是这种情况。
帖子发表于 : 2006-09-08 16:07 

注册: 2006-09-07 16:29
帖子: 14
地址: 东北大学
送出感谢: 0 次
接收感谢: 0 次
onlysai 写道:
出错是由于你同时运行多个系统管理程序,可能是你还没有退出新立德管理软件,你把新立德软件先退出后再运行命令应该没有问题.啦

我也是加入上海交大的源自之后,升级了一下系统,也变成这样了。说是索引出错,也安装不了软件。望各位高手解答。
具体情况如下:
。具体的情况是这样的:
limingdao@limingdao-desktop:~$ sudo apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
openoffice.org-base: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-calc: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-evolution: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-gnome: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-gtk: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-kde: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-math: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
openoffice.org-writer: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
python-uno: 依赖: openoffice.org-core (= 2.0.3-6dapper1) 但是 2.0.2-2ubuntu12 已经安装了
E: 不能满足依赖关系。不妨试一下 -f 选项。
另外我上次升级的软件如下:Commit Log for Wed Sep 6 19:15:25 2006


已升级下列软件包:
binutils-static (2.16.1cvs20060117-1ubuntu2) to 2.16.1cvs20060117-1ubuntu2.1
gimp (2.2.11-1ubuntu3) to 2.2.11-1ubuntu3.1
gimp-data (2.2.11-1ubuntu3) to 2.2.11-1ubuntu3.1
gimp-python (2.2.11-1ubuntu3) to 2.2.11-1ubuntu3.1
gnupg (1.4.2.2-1ubuntu2) to 1.4.2.2-1ubuntu2.2
imagemagick (6:6.2.4.5-0.6) to 6:6.2.4.5-0.6ubuntu0.1
kate (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kcontrol (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdebase-bin (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdebase-data (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdebase-kio-plugins (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdelibs-bin (4:3.5.2-0ubuntu18) to 4:3.5.2-0ubuntu18.1
kdelibs-data (4:3.5.2-0ubuntu18) to 4:3.5.2-0ubuntu18.1
kdelibs4c2a (4:3.5.2-0ubuntu18) to 4:3.5.2-0ubuntu18.1
kdepasswd (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdeprint (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdesktop (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kdm (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kfind (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
khelpcenter (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kicker (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
klipper (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kmenuedit (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
konqueror (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
konqueror-nsplugins (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
konsole (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kopete (4:3.5.2-0ubuntu6.2) to 4:3.5.3kopete0.12.0-1
ksmserver (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
ksplash (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
ksysguard (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
ksysguardd (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
kwin (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
libfreetype6 (2.1.10-1ubuntu2) to 2.1.10-1ubuntu2.2
libgd2-noxpm (2.0.33-2ubuntu5) to 2.0.33-2ubuntu5.1
libgimp2.0 (2.2.11-1ubuntu3) to 2.2.11-1ubuntu3.1
libkonq4 (4:3.5.2-0ubuntu26) to 4:3.5.2-0ubuntu27
libkrb53 (1.4.3-5) to 1.4.3-5ubuntu0.1
libmagick9 (6:6.2.4.5-0.6) to 6:6.2.4.5-0.6ubuntu0.1
libmysqlclient15off (5.0.21-3ubuntu1) to 5.0.22-0ubuntu6.06
libpq4 (8.1.3-4) to 8.1.4-0ubuntu1
libruby1.8 (1.8.4-1ubuntu1) to 1.8.4-1ubuntu1.1
libskim0 (1.4.4-0ubuntu7) to 1.4.5-0ubuntu1
libsmbclient (3.0.22-1ubuntu3) to 3.0.22-1ubuntu3.1
libtiff4 (3.7.4-1ubuntu3) to 3.7.4-1ubuntu3.2
libwmf0.2-7 (0.2.8.3-3.1) to 0.2.8.3-3.1ubuntu0.1
libwpd8c2a (0.8.4-2) to 0.8.6-0ubuntu1
libxine-main1 (1.1.1+ubuntu2-7) to 1.1.1+ubuntu2-7.2
linux-386 (2.6.15.22) to 2.6.15.24
linux-image-386 (2.6.15.22) to 2.6.15.24
linux-restricted-modules-386 (2.6.15.22) to 2.6.15.24
linux-restricted-modules-common (2.6.15.11-1) to 2.6.15.11-3
login (1:4.0.13-7ubuntu3) to 1:4.0.13-7ubuntu3.2
mysql-common (5.0.21-3ubuntu1) to 5.0.22-0ubuntu6.06
openoffice.org (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-base (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-calc (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-common (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-core (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-draw (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-evolution (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-gnome (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-gtk (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-help-en-us (2.0.2-2ubuntu5) to 2.0.3-3dapper4
openoffice.org-impress (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-java-common (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-kde (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-l10n-common (2.0.2-2ubuntu5) to 2.0.3-3dapper4
openoffice.org-l10n-en-gb (2.0.2-2ubuntu5) to 2.0.3-3dapper4
openoffice.org-l10n-en-us (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-l10n-en-za (2.0.2-2ubuntu5) to 2.0.3-3dapper4
openoffice.org-l10n-zh-cn (2.0.2-2ubuntu5) to 2.0.3-3dapper4
openoffice.org-math (2.0.2-2ubuntu12) to 2.0.3-6dapper1
openoffice.org-writer (2.0.2-2ubuntu12) to 2.0.3-6dapper1
passwd (1:4.0.13-7ubuntu3) to 1:4.0.13-7ubuntu3.2
ppp (2.4.4b1-1ubuntu3) to 2.4.4b1-1ubuntu3.1
python-uno (2.0.2-2ubuntu12) to 2.0.3-6dapper1
ruby1.8 (1.8.4-1ubuntu1) to 1.8.4-1ubuntu1.1
samba-common (3.0.22-1ubuntu3) to 3.0.22-1ubuntu3.1
scim-qtimm (0.9.4-0ubuntu4) to 0.9.4-0ubuntu5
skim (1.4.4-0ubuntu7) to 1.4.5-0ubuntu1
smbclient (3.0.22-1ubuntu3) to 3.0.22-1ubuntu3.1
ttf-opensymbol (2.0.2-2ubuntu12) to 2.0.3-6dapper1
vim (1:6.4-006+2ubuntu6) to 1:7.0-010+1ubuntu1
vim-common (1:6.4-006+2ubuntu6) to 1:7.0-010+1ubuntu1
vim-runtime (1:6.4-006+2ubuntu6) to 1:7.0-010+1ubuntu1

已安装下列软件包:
linux-image-2.6.15-26-386 (2.6.15-26.46)
linux-restricted-modules-2.6.15-26-386 (2.6.15.11-3)


页首
 用户资料  
 
4 楼 
 文章标题 : 附加
帖子发表于 : 2006-09-08 16:16 

注册: 2006-09-07 16:29
帖子: 14
地址: 东北大学
送出感谢: 0 次
接收感谢: 0 次
且那个软件管理器没法关掉。


页首
 用户资料  
 
5 楼 
 文章标题 :
帖子发表于 : 2006-09-08 18:46 
头像

注册: 2006-03-02 23:51
帖子: 231
送出感谢: 0 次
接收感谢: 1
apt-get -f install


页首
 用户资料  
 
6 楼 
 文章标题 : [问题]我的问题是这样的:
帖子发表于 : 2006-09-08 21:20 

注册: 2006-09-07 22:40
帖子: 7
送出感谢: 0 次
接收感谢: 0 次
"下列软件包存在未满足的依赖关系:
openoffice.org-gnome: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-writer: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-draw: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-gtk: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-evolution: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-math: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
python-uno: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-base: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
openoffice.org-calc: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是 2.0.2-2ubuntu12.1 已被安装并且被保持不升级。
Resolving dependencies...
下列动作将解决这些依赖关系:

升级 下列软件包:
openoffice.org-common [2.0.2-2ubuntu12.1 (dapper-security, dapper-security, now)-> 2.0.3-6dapper2 (dapper-proposed, dapper-proposed)]
openoffice.org-core [2.0.2-2ubuntu12.1 (dapper-security, dapper-security, now)
-> 2.0.3-6dapper2 (dapper-proposed, dapper-proposed)]
openoffice.org-impress [2.0.2-2ubuntu12.1 (dapper-security, dapper-security,
now) -> 2.0.3-6dapper2 (dapper-proposed, dapper-proposed)]
openoffice.org-l10n-en-gb [2.0.2-2ubuntu5 (dapper, dapper, dapper, now) ->
2.0.3-3dapper4 (dapper-proposed, dapper-proposed)]
openoffice.org-l10n-en-us [2.0.2-2ubuntu12.1 (dapper-security, dapper-security,
now) -> 2.0.3-6dapper2 (dapper-proposed, dapper-proposed)]
openoffice.org-l10n-en-za [2.0.2-2ubuntu5 (dapper, dapper, dapper, now) ->
2.0.3-3dapper4 (dapper-proposed, dapper-proposed)]

分数是 -250

是否接受该解决方案?[Y/n/q/?] y
下列软件包已经被阻止升级:
bind9-host dnsutils libbind9-0 libdns21 libisc11 libisccc0 libisccfg1
libkrb53 liblwres9 libmagick9 libmysqlclient15off libssl0.9.8 libtag1c2a
libtheora0 libwmf0.2-7 libwpd8c2a libxfont1 mysql-common openoffice.org
openoffice.org-help-en-us openoffice.org-java-common openssl
ttf-opensymbol vim vim-common vim-runtime xserver-xorg-core
下列“新”软件包将被安装。
xorg-driver-fglrx
下列软件包将被升级:
openoffice.org-common openoffice.org-core openoffice.org-impress
openoffice.org-l10n-en-gb openoffice.org-l10n-en-us
openoffice.org-l10n-en-za
6 个软件包被升级,新安装 1 个, 0 个将被删除, 同时 27 个将不升级。
需要获取 10.6MB/69.3MB 的存档。 解包后将要使用 28.0MB。
您要继续吗?[Y/n/?] y
正在编辑扩展状态信息... 完成
读取:1 http://mirror.net9.org dapper-security/restricted xorg-driver-fglrx 7.0.0-8.25.18+2.6.15.11-3 [10.6MB]
已下载 10.6MB,耗时 5m53s (29.8kB/s)
(正在读取数据库 ... 系统当前总共安装有 71174 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-impress_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
软件包安装失败。正在试图恢复:
dpkg:依赖关系问题使得 openoffice.org-evolution 的配置工作不能继续:
openoffice.org-evolution 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-evolution (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-gnome 的配置工作不能继续:
openoffice.org-gnome 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-base 的配置工作不能继续:
openoffice.org-base 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-base (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-math 的配置工作不能继续:
openoffice.org-math 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-math (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-draw 的配置工作不能继续:
openoffice.org-draw 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-draw (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-gtk 的配置工作不能继续:
openoffice.org-gtk 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-gtk (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-calc 的配置工作不能继续:
openoffice.org-calc 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-calc (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 openoffice.org-writer 的配置工作不能继续:
openoffice.org-writer 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 openoffice.org-writer (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 python-uno 的配置工作不能继续:
python-uno 依赖于 openoffice.org-core (= 2.0.3-6dapper2);然而:
系统里的 openoffice.org-core 的版本是 2.0.2-2ubuntu12.1.
dpkg:处理 python-uno (--configure)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
openoffice.org-evolution
openoffice.org-gnome
openoffice.org-base
openoffice.org-math
openoffice.org-draw
openoffice.org-gtk
openoffice.org-calc
openoffice.org-writer
python-uno"




望各位高手帮帮忙吧^-^


页首
 用户资料  
 
7 楼 
 文章标题 :
帖子发表于 : 2007-03-18 9:33 

注册: 2007-03-10 7:55
帖子: 42
送出感谢: 0 次
接收感谢: 0 次
ubuntu不适合网络差的用户用
只是个玩具


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 7 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译