vmplayer无法运行的处理方法。

为当前最终发行版之前的所有版本提供支持
回复
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

vmplayer无法运行的处理方法。

#1

帖子 oneleaf » 2006-09-09 16:10

直接运行:

vmplayer:

代码: 全选

LD_PRELOAD=/usr/lib/libdbus-1.so.3 vmplayer
vmware:

代码: 全选

LD_PRELOAD=/usr/lib/libdbus-1.so.3 vmware
或者使用补丁:

代码: 全选

--- wrapper-gtk24.sh.old        2006-09-08 10:03:49.769448000 -0500
+++ wrapper-gtk24.sh    2006-09-08 10:04:31.036027000 -0500
@@ -115,6 +115,9 @@
 vm_run() {
    local exitCode;
 
+   # Fix for vmplayer pulling in libdbus-1.so.2 instead of .3
+   export LD_PRELOAD=/usr/lib/libdbus-1.so.3:$LD_PRELOAD
+
    # Append any libraries that are still missing.
    if [ "$VMWARE_USE_SHIPPED_GTK" = 'force' ]; then
       export LD_PRELOAD="$LD_PRELOAD":"`LANGUAGE=C LANG=C ldd "$binary" | vm_append_missing`"
上次由 oneleaf 在 2006-09-15 16:23,总共编辑 2 次。
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#2

帖子 oneleaf » 2006-09-15 16:21

忘记说错误现象了,提供错误现象以便搜索:

/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
nuremberg
帖子: 11
注册时间: 2006-02-19 18:49
送出感谢: 0
接收感谢: 0

大侠咋办,那个补丁怎么打啊

#3

帖子 nuremberg » 2006-09-15 16:51

ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/usr/lib/libdbus-1.so.3' from LD_PRELOAD cannot be preloaded: ignored.
/usr/lib/vmware/bin/vmware: /usr/lib/vmware/lib/libpng12.so.0/libpng12.so.0: no version information available (required by /usr/lib/libcairo.so.2)
*** glibc detected *** free(): invalid pointer: 0x092865b8 ***
头像
oneleaf
论坛管理员
帖子: 10238
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 107 次

#4

帖子 oneleaf » 2006-09-15 17:25

sudo apt-get install libdbus-1-3
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#5

帖子 renex » 2006-09-16 1:06

安装中,到openoffice-core时出错

sudo apt-get -f install

继续

sudo apt-get dist-upgrade
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#6

帖子 renex » 2006-09-16 1:17

安装到cupsys-common又出错

还是
sudo apt-get -f install

又出错,继续
sudo apt-get -f install

终于好了
接着
sudo apt-get dist-upgrade
头像
renex
帖子: 269
注册时间: 2006-04-29 21:45
来自: Shanghai
送出感谢: 0
接收感谢: 0

#7

帖子 renex » 2006-09-16 1:18

目前还剩余500多个包没有安装
gisworld
帖子: 113
注册时间: 2005-04-11 22:56
送出感谢: 0
接收感谢: 0

#8

帖子 gisworld » 2006-09-16 15:28

现在vmplayer可以安装了?
我上次安装时在自动配置的时候一直有错误。
头像
syhan
帖子: 272
注册时间: 2006-09-06 12:24
来自: Southeast University
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 syhan » 2006-11-10 15:24

补丁请问怎么使用啊?难道我每次都得在命令行模式下运行吗 ?
gisworld
帖子: 113
注册时间: 2005-04-11 22:56
送出感谢: 0
接收感谢: 0

#10

帖子 gisworld » 2006-11-10 21:55

现在vmplayer可以直接安装,不需要补丁了。
回复

回到 “老旧版本支持”