edgy笔记本上netboot安装成功

为当前最终发行版之前的所有版本提供支持
回复
robinjmmj
帖子: 45
注册时间: 2006-02-19 21:47
送出感谢: 0
接收感谢: 0

edgy笔记本上netboot安装成功

#1

帖子 robinjmmj » 2006-09-09 22:48

自己庆祝一下。
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 karron » 2006-09-10 8:26

能否寫一個教程出來呢? 比如adsl環境該如何做,其他環境該如何做,這樣能夠造福更多人.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
robinjmmj
帖子: 45
注册时间: 2006-02-19 21:47
送出感谢: 0
接收感谢: 0

#3

帖子 robinjmmj » 2006-09-10 10:57

karron 写了:能否寫一個教程出來呢? 比如adsl環境該如何做,其他環境該如何做,這樣能夠造福更多人.
我是ADSL+router,好像直接adsl不行阿。。。
robinjmmj
帖子: 45
注册时间: 2006-02-19 21:47
送出感谢: 0
接收感谢: 0

#4

帖子 robinjmmj » 2006-09-10 11:32

写一下自己在笔记本上netboot安装edgy的经验,最后的情况是保留了原先的dapper(必须),edgy正常运行。网络安装的过程其实是一样的,我在安装过程中主要是碰到了initramfs-tools出错的问题,主要写一下如何解决的。

前两天台式机上网络安装了edgy,觉得不错,昨天尝试在笔记本上网络安装。首先通过jigdo文件找到正确的安装文件,具体可以找论坛里的帖子,其实就是现在最新的。
http://debian.cn99.com/ubuntu/dists/edg ... i386/linux
http://debian.cn99.com/ubuntu/dists/edg ... /initrd.gz
启动,选语言,地区,键盘,mirror,分区什么的。然后安装base system,第一次安装initramfs-tools就会出错,退回菜单,重新安装一遍base system,这次这个错就没了,安装程序会让你选择一个合适的内核进行安装。这里我尝试了几个都不行,一选择马上就是initramfs-tools的错,所以这里选none,这样可以让你继续安装,但是无法从新的安装启动。先继续下去安装完软件会出一个蓝牙什么包的错,别管他,将来删了这个包就行了,然后跳过grub,完成安装。
现在edgy基本上已经在硬盘里了,但是因为没装内核不能启动。用dapper启动,到cn99的edgy源里下载edgy内核相关的包。下载完后将dapper里/boot下的文件复制到edgy的/boot下。然后在grub里打几个命令来启动edgy,因为是只有vmliuz和iinitrd.img等几个文件,启动的时候很多模块无法加载的,不用理会,启动了之后dpkg -i安装在dapper里下载的kernel,因为这时网络也没有,所以必须在dapper下载。安装之后edgy就安装完成了,可能还需要修该一下menu.lst。

写的不太详细,因为方法不是很好,而且感觉installer的问题应该会马上解决的,这里主要给想在笔记本上netboot安装的朋友一点思路。
头像
glade
帖子: 1383
注册时间: 2005-10-21 16:57
送出感谢: 0
接收感谢: 0

#5

帖子 glade » 2006-09-11 2:10

既然保留了dapper那么/boot没必要复制到edgy里面
menu.lst改dapper里面的就行了
robinjmmj
帖子: 45
注册时间: 2006-02-19 21:47
送出感谢: 0
接收感谢: 0

#6

帖子 robinjmmj » 2006-09-11 14:50

glade 写了:既然保留了dapper那么/boot没必要复制到edgy里面
menu.lst改dapper里面的就行了
用dapper的image启动是不是只要加上root=/dev/hdaX就行了?当时我想复制过去保险。
回复

回到 “老旧版本支持”