[原创]用wine实现本地安装IE6简体中文版--详细功略(已修正)

为当前最终发行版之前的所有版本提供支持
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

[原创]用wine实现本地安装IE6简体中文版--详细功略(已修正)

#1

帖子 yee » 2005-08-28 17:19

本文提及的软件已经停止提供下载,新版本的wine-config-helper可在http://iyee.cn/blog上下载,欢迎试用。


最近被必胜客小龙人催稿好辛苦啊~~
不过辛苦还是值得的,今天终于可以把安装IE的方法拿出来见人了.
就是使用本人刚刚修改好的 wine 配置帮手0.1来进行安装
我在ubuntu下测试过了,没问题.
不知道其他人怎么样,所以托着测试版的名义找不怕死的人来替我测试(应该没问题才对)
下载地址 http://wz.iyee.cn/down/wine-config-helper-0.1.tar.gz

以下是安装说明


版权声明
=============================================
本程序修改于wine-config-sidenet V1.8.4 installer
版权归http://sidenet.ddo.jp所有.本人对其进行修改汉化
本人还参考了deman的easywine,欧侃的OKYH
感谢以上两位的支持(虽然我只是修改这个程序^-^)


=============================================
安装方法
=============================================

注:ubuntu的终端如无法显示中文,请单击终端窗口上方的“终端(T)”-“设定字符编码(C)-简体中文”,在三个简体中文中随便选一个就可以显示了。
同时,本程序不能以root身份安装。

1. 虽然本程序可以自动下载并安装IE6,但本人推荐进行本地安装。
先到 http://www.onlinedown.net/soft/17441.htm 下载一个中文版的IE6安装程序
然后解压到 wine-config-helper 文件夹内,注意保持路径形式为 wine-config-helper-0.1 下有一个IE6 文件夹,而IE6文件夹内就是IE6的全部安装程序(很多个的)即满足 /home/yourname/wine-config-helper-0.1/IE6/ie的全部安装文件 (IE6要大写!)

2. 终端中运行 tar zxvf wine-config-helper-0.1.tar.gz 进行解压
cd wine-config-helper-0.1 进入该目录
./setup 启动安装程序
接下来都是中文的了
一路配置下来,出现4个安装选项。想省事装IE的就选第一项吧,这样电脑就自动配置了。
等到IE6的图形安装界面出现后,就靠自己的常识进行安装吧(左下方第二个按钮就是“下一步”,555我还不知道怎么才能让他显示中文呢)。
安装到45%左右的时候,电脑会像假死一样一动不动,不过不要停止阿,程序还在运行中。苦等了几分钟后,进度条又开始前进了。IE安装结束后,系统还会自动配置,这段时间虽然风平浪静,但千万不要关闭终端。又等了几分钟,可能有个错误窗口弹出,不过不要紧,按确定(没出现当然最好)。接着再过几十妙,终端又开始刷刷的运行了。最后,IE 会自动弹出,并显示本人的Blog.

3.运行wine
无所谓大小写,也不管是在哪个目录下。只要在终端中输入 wine iexplore 就可以了,厉害吧。(启动要等几十妙,这也是没办法的事)


============================
修改部分
============================

汉化(这部分参照了deman的,不过我翻译的应该更准确一些^-^)

本人对其进行的修改,也仅仅是实现本地安装IE而已。
(本来这程序根本不能装中文版的IE6,在我的电脑上连自动下载个IE都不行)

其他修改部分:没了

以后可能会支持自动安装的软件: QQ2005 (除非我能弄得十分稳定,否则不会提供这项功能)
DreamWeaver(这个我拼了命也要搞出来!)
Flash MX/8 (还没试过)
FireWorks
CS (这个难度最大)
上次由 yee 在 2005-10-14 20:33,总共编辑 2 次。
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 yee » 2005-08-28 17:45

有问题记得跟贴,我需要大家的反馈信息好修改.
操作系统应该可以更优雅一些
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

目錄名好像有誤

#3

帖子 millenniumdark » 2005-08-29 22:55

yee 写了:然后解压到 wine-config-helper 文件夹内,注意保持路径形式为 wine-config-helper 下有一个IE6 文件夹,而IE6文件夹内就是IE6的全部安装程序(很多个的)即满足 /home/yourname/wine-config-helper/IE6/ie的全部安装文件
cd wine-config-helper 进入该目录


上面的wine-config-helper好像都應該替還為wine-config-helper-0.1

看樣子樓主是照壓縮包里的安裝說明寫的

安裝說明里也有這個錯誤。
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

安裝成功

#4

帖子 millenniumdark » 2005-08-29 23:11

終於在linux下用上IE了

thank lz
头像
millenniumdark
论坛版主
帖子: 4160
注册时间: 2005-07-02 14:41
系统: Ubuntu 14.04 (Kylin)
送出感谢: 43 次
接收感谢: 9 次
联系:

中文顯示問題

#5

帖子 millenniumdark » 2005-08-29 23:25

安裝的時候除了按鍵上的英文以外,什么也看不到。我全是選了第一項的。

至於安裝好後的IE,界面上凡是中文一概無法顯示。

我下的是簡體中文版,選擇語言時選了cn

但是我的gnome 界面是英文的
附件
ie.png
考驗我對很久以前使用的IE的記憶的時候到了
头像
lyreopera
帖子: 771
注册时间: 2005-05-23 13:38
来自: gdsz
送出感谢: 0
接收感谢: 0

#6

帖子 lyreopera » 2005-08-30 0:15

我觉得最好用英文版。
……
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

Re: 中文顯示問題

#7

帖子 yee » 2005-08-30 0:21

millennuimdark 写了:安裝的時候除了按鍵上的英文以外,什么也看不到。我全是選了第一項的。

至於安裝好後的IE,界面上凡是中文一概無法顯示。

我下的是簡體中文版,選擇語言時選了cn

但是我的gnome 界面是英文的


我在自己的电脑上装IE,显示全是中文的.不存在你说的问题.
可能是什么地方出错了.我回去好好找找看.
其他人如果有相同问题的请跟贴.
谢谢
操作系统应该可以更优雅一些
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 yee » 2005-08-30 0:31

看样子,可能是因为你装的ubuntu是英文版的.
我装的是比较新的(十多天前下载的那个版本),系统默认就是简体中文的,然后我也没多少改动就直接装了.....

问问管理员看看.
操作系统应该可以更优雅一些
mahj
帖子: 106
注册时间: 2005-09-12 7:28
来自: 大连
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 mahj » 2005-10-07 22:09

太感谢搂主了
我装了,很顺利。
这下可以用网上银行了。
yee
帖子: 125
注册时间: 2005-08-14 18:16
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 yee » 2005-10-14 20:26

楼上的,冒昧的问一句,真的能用网上银行了吗?
操作系统应该可以更优雅一些
头像
id_sonic
帖子: 339
注册时间: 2005-04-08 18:08
来自: Chongqing
送出感谢: 0
接收感谢: 0
联系:

#11

帖子 id_sonic » 2005-10-19 12:41

我安装好了 不能访问 https
目前是 tinkpad r400 上的 debian 用户
my blog Trust Dating
头像
DarkEyes
帖子: 548
注册时间: 2005-07-01 13:09
来自: 广西南宁
送出感谢: 0
接收感谢: 1 次

#12

帖子 DarkEyes » 2005-10-27 17:16

我也装好了。。不过也好卡~~~觉得用用WINE运行IE简直是件折磨人的事情
最新座驾:华晨中华酷宝 1.8T手动
rods
帖子: 181
注册时间: 2005-11-19 18:43
送出感谢: 0
接收感谢: 0

好像曼德拉草支持CS1.5哦!!!

#13

帖子 rods » 2005-11-19 18:47

好像曼德拉草支持CS1.5哦!!!
charlis
帖子: 19
注册时间: 2005-09-29 17:55
送出感谢: 0
接收感谢: 0
联系:

#14

帖子 charlis » 2005-11-20 17:46

哈哈!太好了!那个EasyWine2.2RC1我装好了可运行没反应!这下可以试试这个了!正好我虚拟机里的Ubuntu5.10里装的是apt-get 的wine0725版的!完全可以用这个!吃晚饭就试试!谢谢楼主老大!
Neoion
帖子: 111
注册时间: 2005-12-02 7:23
送出感谢: 0
接收感谢: 0

#15

帖子 Neoion » 2005-12-09 20:34

这个好似已经不能用了 :cry:
回复

回到 “老旧版本支持”