[问题]磁盘是挂载好了,可是没有权限写入。

为当前最终发行版之前的所有版本提供支持
回复
引火虫
帖子: 750
注册时间: 2006-08-28 9:08
来自: 安徽/安庆
送出感谢: 0
接收感谢: 0
联系:

[问题]磁盘是挂载好了,可是没有权限写入。

#1

帖子 引火虫 » 2006-09-13 14:26

在论坛里面搜了很多关于挂载磁盘的帖子,
现在磁盘是挂载好了,
可是每次启动后都要手动修改权限,
否则不能写入,
能不能在挂载的时候就把权限设好?
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 SuperWar3Fan » 2006-09-13 15:33

把uid=000写入fstab
引火虫
帖子: 750
注册时间: 2006-08-28 9:08
来自: 安徽/安庆
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 引火虫 » 2006-09-14 8:32

SuperWar3Fan 写了:把uid=000写入fstab
请 问是这样写吗?
/dev/sdb5 /home/主目录/挂载目录 ext3 defaults,uid=000 0 3
可是这样在挂载以后,
设备属性里面看到这个盘总是不可访问状态,
点击启用,
好像没有效果,
在挂载目录里面好像也少了个lost+found文件夹,
可是我向挂载目录里面新建文件,拷贝文件,保存文件都没有问题,
而且也能显示出那个盘的剩余空间,
这是不是说明已经挂载好了?
可是点击设备属性里面的启用没有反应呢?
在挂载目录里面怎么少了lost+found文件夹呢?
头像
xiehuoli
帖子: 5941
注册时间: 2006-06-10 8:43
来自: 中国 CS
送出感谢: 0
接收感谢: 2 次

#4

帖子 xiehuoli » 2006-09-14 9:10

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hdb1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda1 /media/hda1 ext3 defaults 0 2
/dev/hda3 /media/hda3 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda5 /media/hda5 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hda6 /media/hda6 vfat defaults,utf8,umask=007,gid=46 0 1
/dev/hdb5 none swap sw 0 0
/dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0


这个是我的挂载,你看看能否帮下你

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 / ext3 defaults,errors=remount-ro 0 1
/dev/hda3 /media/hda3 ext3 defaults 0 2
/dev/hda5 /media/hda5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
/dev/hda7 /opt ext3 defaults 0 2
/dev/hda6 /var ext3 defaults 0 2
/dev/hda8 none swap sw 0 0
年轻没有失败! ! ! ! ! !
噢!有怪兽,有怪兽!
引火虫
帖子: 750
注册时间: 2006-08-28 9:08
来自: 安徽/安庆
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 引火虫 » 2006-09-14 10:29

谢了,
没有用的。
回复

回到 “老旧版本支持”