apt error?

为当前最终发行版之前的所有版本提供支持
回复
grothendieck
帖子: 24
注册时间: 2006-09-13 8:13
送出感谢: 0
接收感谢: 0

apt error?

#1

帖子 grothendieck » 2006-09-15 9:13

Password:
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-common openoffice.org-core openoffice.org-impress
openoffice.org-l10n-en-gb openoffice.org-l10n-en-us
openoffice.org-l10n-en-za
建议安装的软件包:
hunspell-dictionary-en-gb myspell-dictionary-en-gb
openoffice.org-hyphenation-en-gb openoffice.org-help-en-gb
hunspell-dictionary-en-us myspell-dictionary-en-us
openoffice.org-hyphenation-en-us hunspell-dictionary-en-za
myspell-dictionary-en-za openoffice.org-hyphenation-en-za
openoffice.org-thesaurus-en-za openoffice.org-help-en-za
下列的软件包将被升级:
openoffice.org-common openoffice.org-core openoffice.org-impress
openoffice.org-l10n-en-gb openoffice.org-l10n-en-us
openoffice.org-l10n-en-za
共升级了 6 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 9 个软件未被升级。
有 29 个软件包没有被完全安装或卸载。
需要下载 0B/58.8MB 的软件包。
解压缩后将会空出 2208kB 的空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 70540 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-impress_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
grothendieck
帖子: 24
注册时间: 2006-09-13 8:13
送出感谢: 0
接收感谢: 0

#2

帖子 grothendieck » 2006-09-15 9:17

获取:1 http://mirror.net9.org dapper-proposed/main openoffice.org-impress 2.0.3-6dapper2 [591kB]
获取:2 http://mirror.net9.org dapper-proposed/main openoffice.org-l10n-en-za 2.0.3-6dapper1 [594kB]
获取:3 http://mirror.net9.org dapper-proposed/main openoffice.org-l10n-en-gb 2.0.3-6dapper1 [1801kB]
获取:4 http://mirror.net9.org dapper-proposed/main openoffice.org-core 2.0.3-6dapper2 [30.0MB]
获取:5 http://mirror.net9.org dapper-proposed/main openoffice.org-l10n-en-us 2.0.3-6dapper2 [576kB]
获取:6 http://mirror.net9.org dapper-proposed/main openoffice.org-common 2.0.3-6dapper2 [25.3MB]
下载 58.8MB,耗时 20s (2883kB/s)
(正在读取数据库 ... 系统当前总共安装有 70540 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-impress_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
karrigen
帖子: 43
注册时间: 2006-09-09 20:34
送出感谢: 0
接收感谢: 0

#3

帖子 karrigen » 2006-09-15 10:34

我也碰到过
可能是新的软件包与已有的软件包冲突

可以用新立得搜索关键字
然后将所有相关的包先卸载(查看包的详细信息)
升级源以后(可以用初学者指南里面的那些源)
再重新安装

如果打开添加删除或者新立得提示错误
那需要先把源改成系统默认的(应该有个备份吧)
然后进行系统升级
一般都能解决问题
再重复第二段的步骤

希望没有误人子弟
aBiNg
帖子: 1331
注册时间: 2006-07-09 12:22
来自: 南京
送出感谢: 0
接收感谢: 2 次

#4

帖子 aBiNg » 2006-09-15 11:03

代码: 全选

sudo apt-get remove openoffice.org-common --purge
sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade
have a try... :lol:
回复

回到 “老旧版本支持”