sudo apt-get install build-essential出现的问题

为当前最终发行版之前的所有版本提供支持
回复
Guo R.H
帖子: 87
注册时间: 2006-09-15 19:14
送出感谢: 0
接收感谢: 0

sudo apt-get install build-essential出现的问题

#1

帖子 Guo R.H » 2006-09-15 19:20

我安装 sudo apt-get install build-essential提示 :
在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
有一些软件包无法被安装。如果您用的是不稳定(unstable)发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们还在新到(incoming)目录中。

您仅要求对单一软件包进行操作,这极有可能是因为该软件包安装不上,同时,
您最好提交一个针对这个软件包的故障报告。
下列的信息可能会对解决问题有所帮助:

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装


但是我已经安装了gcc g++呀,怎么还会出现这个呢?
谢谢!!!!!
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 BigSnake.NET » 2006-09-15 19:30

sudo apt-get update
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
Guo R.H
帖子: 87
注册时间: 2006-09-15 19:14
送出感谢: 0
接收感谢: 0

#3

帖子 Guo R.H » 2006-09-15 19:33

我做了怎么还是一样的问题呢?这个是什么原因阿?谢谢
回复

回到 “老旧版本支持”