系统更新之后说软件索引已被破坏???!!!

为当前最终发行版之前的所有版本提供支持
回复
糊涂
帖子: 15
注册时间: 2006-08-26 9:35
送出感谢: 0
接收感谢: 0

系统更新之后说软件索引已被破坏???!!!

#1

帖子 糊涂 » 2006-09-16 0:46

系统更新之后说软件索引已被破坏???!!!
说终端运行“sudo apt-get install -f”进行修复?
linux@linux-desktop:~$ sudo apt-get install -f
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-common openoffice.org-core openoffice.org-impress
下列【新】软件包将被安装:
openoffice.org-core
下列的软件包将被升级:
openoffice.org-common openoffice.org-impress
共升级了 2 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 15 个软件未被升 级。
有 9 个软件包没有被完全安装或卸载。
需要下载 0B/55.8MB 的软件包。
解压缩后会消耗掉 81.2MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 79068 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12 (使用 .../openoffice.org-impre ss_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.de b (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetect ion/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-6dapper2 _all.deb:
openoffice.org-common 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper2_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-6dapper2_i38 6.deb:
openoffice.org-core 冲突于 openoffice.org-impress (<< 2.0.3-6dapper2)
openoffice.org-impress (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper2_i386.deb ( --unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper2_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
linux@linux-desktop:~$
说有冲突 ,初学不知道是怎么回事?还请大虾帮忙
lirh
帖子: 10
注册时间: 2006-03-14 21:39
送出感谢: 0
接收感谢: 0

#2

帖子 lirh » 2006-09-16 12:51

我也遇到这种情况,按照提示我用新立得的broken过滤器过滤,直接把ooo给删掉了,反正用不了ooo,大不了安装wps或star
头像
SuperWar3Fan
帖子: 1263
注册时间: 2006-05-20 6:25
来自: 山东淄博
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 SuperWar3Fan » 2006-09-16 13:31

这是更新源的问题,譬如你用清华的源,可能出现这个问题。建议你用cn99的源。更新的时候,破坏了索引。更改一下sources.list,再
sudo apt-get update
就可以了。
回复

回到 “老旧版本支持”