JAVA装不上去!!

为当前最终发行版之前的所有版本提供支持
回复
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

JAVA装不上去!!

#1

帖子 huanhuan516 » 2006-09-16 16:24

huan@chinagirl:~$ sudo apt-get install sun-java5-jre
Password:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
huan@chinagirl:~$

输入了装SUN 1.5 JAVA 的代码,显示如上.我要怎么做吖...... :cry: :cry: :cry:
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#2

帖子 huanhuan516 » 2006-09-16 18:08

帮忙帮忙…………
头像
oneleaf
论坛管理员
帖子: 10231
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 103 次

#3

帖子 oneleaf » 2006-09-16 18:30

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
上次安装没有配置完毕,先

sudo dpkg --configure -a

再安装。
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#4

帖子 huanhuan516 » 2006-09-16 22:34

oneleaf 写了:
E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.
上次安装没有配置完毕,先



再安装。

请问怎么sudo dpkg --configure -a ???
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#5

帖子 huanhuan516 » 2006-09-16 23:04

huan@chinagirl:~$ sudo dpkg --configure -a
Richte sun-java5-doc ein (1.5.0-06-1) ...
This package is an installer package, it does not actually contain the
J2SDK documentation. You will need to go download one of the
archives:

jdk-1_5_0-doc.zip jdk-1_5_0-doc-ja.zip

(choose the non-update version if this is the first installation).
Please visit

http://java.sun.com/j2se/1.5.0/download.html

now and download. The file should be owned by root.root and be copied
to /tmp.

[Press RETURN to try again, 'no' + RETURN to abort]
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#6

帖子 huanhuan516 » 2006-09-16 23:06

。。。现在要怎么办啊。。
vp25
帖子: 32
注册时间: 2006-09-14 23:18
送出感谢: 0
接收感谢: 0

#7

帖子 vp25 » 2006-09-17 2:05

直接打开新里的软件安装就可以完成了,不用你手动APT-GET的
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#8

帖子 huanhuan516 » 2006-09-17 4:10

在终端输入代码 sudo dpkg --configure -a
显示如下:
huan@chinagirl:~$ sudo dpkg --configure -a
Password:
Richte sun-java5-doc ein (1.5.0-06-1) ...
This package is an installer package, it does not actually contain the
J2SDK documentation. You will need to go download one of the
archives:

jdk-1_5_0-doc.zip jdk-1_5_0-doc-ja.zip

(choose the non-update version if this is the first installation).
Please visit

http://java.sun.com/j2se/1.5.0/download.html

now and download. The file should be owned by root.root and be copied
to /tmp.

[Press RETURN to try again, 'no' + RETURN to abort]
MorningStar
帖子: 11
注册时间: 2006-09-15 21:21
送出感谢: 0
接收感谢: 0

#9

帖子 MorningStar » 2006-09-17 10:58

系统本身有JRE呀,不过是1.4.2的,你可以从java.sun.com上下载一个jdk1.5.0直接安装,再配一下环境就没有问题了。
huanhuan516
帖子: 29
注册时间: 2006-01-01 22:58
送出感谢: 0
接收感谢: 0

#10

帖子 huanhuan516 » 2006-09-17 16:09

请问怎么设置环境……新人来的…… :?: :?:
回复

回到 “老旧版本支持”