升级的时候出现这个问题,高手看看是什么原因?

为当前最终发行版之前的所有版本提供支持
回复
Guo R.H
帖子: 87
注册时间: 2006-09-15 19:14
送出感谢: 0
接收感谢: 0

升级的时候出现这个问题,高手看看是什么原因?

#1

帖子 Guo R.H » 2006-09-17 10:18

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
openoffice.org: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装
openoffice.org-base: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没 有被安装
openoffice.org-calc: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没 有被安装
openoffice.org-common: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安装 或
openoffice.org-core-experimental (> 2.0.2) 但 却无法安装它
openoffice.org-draw: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没 有被安装
openoffice.org-evolution: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没有被安装
openoffice.org-gnome: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没有被安装
openoffice.org-gtk: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没有被安装
openoffice.org-help-zh-cn: 依赖: openoffice.org-core (>= 2.0.3) 但是它还没有 被安装 或
language-support-zh 但是它还没有被安装
openoffice.org-impress: 依赖: openoffice.org-core (> 2.0.2) 但是它还没有被安 装
openoffice.org-l10n-zh-cn: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12 已经安装了 或
language-support-zh 但是它还没有被安装
openoffice.org-l10n-zh-tw: 依赖: openoffice.org-common (>= 2.0.3) 但是 2.0.2-2ubuntu12 已经安装了 或
language-support-zh 但是它还没有被安装
openoffice.org-math: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没 有被安装
openoffice.org-writer: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还 没有被安装
python-uno: 依赖: openoffice.org-core (= 2.0.3-6dapper2) 但是它还没有被安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
guorh@guorh-desktop:/etc$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列额外的软件包:
openoffice.org-common openoffice.org-core openoffice.org-impress
下列【新】软件包将被安装:
openoffice.org-core
下列的软件包将被升级:
openoffice.org-common openoffice.org-impress
共升级了 2 个软件包,新安装了 1 个软件包,要卸载 0 个软件包,有 22 个软件未被升级。
有 9 个软件包没有被完全安装或卸载。
需要下载 0B/55.8MB 的软件包。
解压缩后会消耗掉 81.2MB 的额外空间。
您希望继续执行吗?[Y/n]y
(正在读取数据库 ... 系统当前总共安装有 84118 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12 (使用 .../openoffice.org-impress_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common
dpkg:关于含有 openoffice.org-common 的 .../openoffice.org-common_2.0.3-6dapper2_all.deb:
openoffice.org-common 冲突于 openoffice.org-impress (<< 2.0.3)
openoffice.org-impress (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper2_all.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-common
dpkg:关于含有 openoffice.org-core 的 .../openoffice.org-core_2.0.3-6dapper2_i386.deb:
openoffice.org-core 冲突于 openoffice.org-impress (<< 2.0.3-6dapper2)
openoffice.org-impress (版本为 2.0.2-2ubuntu12)现在 已安装完毕。
dpkg:处理 /var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper2_i386.deb (--unpack)时出错:
软件包相互冲突 - 将不安装 openoffice.org-core
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
/var/cache/apt/archives/openoffice.org-common_2.0.3-6dapper2_all.deb
/var/cache/apt/archives/openoffice.org-core_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#2

帖子 proming » 2006-09-17 11:17

更新OpenOffice就是有这个问题
可以上新立得里把OpenOffice删掉
Hardware:
Lenovo ThinkPad T400
Processor: Intel Core2 Duo P8700
Memory: 2G
Disk: 320G

Ubuntu
Release 10.10
Kernel Linux 2.6.35-24-generic
GNOME 2.32.0

欢迎访问我的blog
Hijhon
帖子: 57
注册时间: 2006-09-10 12:56
送出感谢: 0
接收感谢: 1 次
联系:

#3

帖子 Hijhon » 2006-09-17 12:17

我在新立得里怎么删除不了openoffice阿。提示说有什么依赖关系。
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-09-17 12:19

源的问题拉,好像清华、上交的源都是这样。官方的没有问题。我到现在还是2.0.2的。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
winson
帖子: 48
注册时间: 2006-07-11 14:43
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 winson » 2006-09-17 14:10

zhuqin_83 写了:源的问题拉,好像清华、上交的源都是这样。官方的没有问题。我到现在还是2.0.2的。
恩那,上交的源出这种问题,提示有更新,但是老是无法下载
头像
proming
帖子: 52
注册时间: 2006-04-03 10:38
来自: Beijing
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 proming » 2006-09-17 17:22

Hijhon 写了:我在新立得里怎么删除不了openoffice阿。提示说有什么依赖关系。
直接删openoffice.org-core和openoffice.org-common
Hardware:
Lenovo ThinkPad T400
Processor: Intel Core2 Duo P8700
Memory: 2G
Disk: 320G

Ubuntu
Release 10.10
Kernel Linux 2.6.35-24-generic
GNOME 2.32.0

欢迎访问我的blog
回复

回到 “老旧版本支持”