软件更新发生错误,OPENOFFICE,不知道大家有碰到过没?

为当前最终发行版之前的所有版本提供支持
回复
dreamshen
帖子: 14
注册时间: 2006-08-30 19:07
送出感谢: 0
接收感谢: 0

软件更新发生错误,OPENOFFICE,不知道大家有碰到过没?

#1

帖子 dreamshen » 2006-09-17 16:37

开始是系统更新,看了一下大部分是openoffice的更新包,下好后,开始替换,但是有一个包是open office common的替换不了,并说叫我用apt-get install -f来修正这个问题,在终端运行好,也下载好了OPEN OFFICE的各个包后出现下面提示:

(正在读取数据库 ... 系统当前总共安装有 80201 个文件和目录。)
正预备替换 openoffice.org-impress 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-impress_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-impress ...
dpkg:处理 /var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/openoffice/share/registry/modules/org/openoffice/TypeDetection/Filter/fcfg_impressgraphics_filters.xcu”,它属于软件包 openoffice.org-common正预备替换 openoffice.org-math 2.0.2-2ubuntu12.1 (使用 .../openoffice.org-math_2.0.3-6dapper2_i386.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-math ...
正预备替换 openoffice.org-l10n-common 2.0.2-2ubuntu5 (使用 .../openoffice.org-l10n-common_2.0.3-6dapper1_all.deb) ...
正在解压缩将用于更替的包文件 openoffice.org-l10n-common ...
在处理时有错误发生:
/var/cache/apt/archives/openoffice.org-impress_2.0.3-6dapper2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

现在点击那个更新的图标,就出现软件索引已破坏,不能安装或删除任何软件的对话杠了
头像
buffalo319
帖子: 29
注册时间: 2006-05-12 20:32
送出感谢: 0
接收感谢: 0

#2

帖子 buffalo319 » 2006-09-17 18:25

me tooooo!
ahlongxp
帖子: 209
注册时间: 2006-03-06 19:16
送出感谢: 0
接收感谢: 0
联系:

#3

帖子 ahlongxp » 2006-09-17 18:43

openoffice太麻烦,我直接把它删了
删掉的还有ubuntu-desktop,同样地麻烦

就用永中office了
头像
sniper54
帖子: 96
注册时间: 2006-07-31 19:16
来自: 重庆
送出感谢: 1 次
接收感谢: 0
联系:

#4

帖子 sniper54 » 2006-09-17 19:11

在新立得中去除OPENOFFICE所有的项目
然后再apt-get install update
apt-get dist-upgrade
dreamshen
帖子: 14
注册时间: 2006-08-30 19:07
送出感谢: 0
接收感谢: 0

#5

帖子 dreamshen » 2006-09-17 21:06

楼上兄弟,好像不行啊....
daniellau
帖子: 5
注册时间: 2006-09-14 9:44
送出感谢: 0
接收感谢: 0

#6

帖子 daniellau » 2006-09-19 10:03

在系统--系统管理--新立德软件包管理器, 搜索openoffice.org-core,和 openoffice.org-common, 标记删除, 然后再把openoffice的其他程序,比如数据库,字处理,等程序全部标记删除, 为什么要先标记删除 前两个呢? 因为你标记删除openoffice应用程序的时候,前两个程序因为依赖关系是要升级的,但是oenoffice.org-core 又不能升级到 dapper 那个版本,所以应当先把前两个程序标记删除掉,然后再删除openoffice的其他程序。 openoffice的组件全删除完了之后,重新安装openoffice就没有问题了。
回复

回到 “老旧版本支持”