[讨论]麻烦大家看看下面这个安装时候的错误,不知道是怎么回事

为当前最终发行版之前的所有版本提供支持
回复
xyqyahoo
帖子: 17
注册时间: 2006-09-17 22:38
送出感谢: 0
接收感谢: 0

[讨论]麻烦大家看看下面这个安装时候的错误,不知道是怎么回事

#1

帖子 xyqyahoo » 2006-09-18 10:29

dpkg:依赖关系问题使得 zlib1g-dev 的配置工作不能继续:
zlib1g-dev 依赖于 zlib1g (= 1:1.2.3-6ubuntu4);然而:
系统里的 zlib1g 的版本是 1:1.2.3-9.
dpkg:处理 zlib1g-dev (--install)时出错:
依赖关系问题 - 仍未被配置

这样版本不对的时候应该怎么做呢?

还有就是想问下apt-get和新立得是什么意思?看到好多人在说这个,但又在网上找不到比较具体一点的信息,还请大家教教我这个刚入门的菜鸟把!谢谢了
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-09-18 10:35

man apt-get 可以看到他的说明。或者在系统帮助里面搜索apt-get、新立得。
apt-get 是一种高级包安装工具,比如你的问题,用apt-get 很容易解决。直接 sudo apt-get install zlib1g-dev,他会自动帮你解决依赖问题。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
xyqyahoo
帖子: 17
注册时间: 2006-09-17 22:38
送出感谢: 0
接收感谢: 0

#3

帖子 xyqyahoo » 2006-09-18 10:38

请问一下deb文件都可以像上面这么装吗?
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#4

帖子 zhuqin_83 » 2006-09-18 10:42

如果源里面有的话,自然可以。如果是你自己下载的软件包而源里没有,则只能sudo dpkg -i xxx,或者直接双击你的deb包。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
xyqyahoo
帖子: 17
注册时间: 2006-09-17 22:38
送出感谢: 0
接收感谢: 0

#5

帖子 xyqyahoo » 2006-09-18 11:32

我使用了apt-get install zlib1g-dev安装时依然出错
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
zlib1g-dev 已经是最新的版本了。
您可能需要运行“apt-get -f install”来纠正下列错误:
下列的软件包有不能满足的依赖关系:
zlib1g-dev: 依赖: zlib1g (= 1:1.2.3-6ubuntu4)
E: 有未能满足的依赖关系。请尝试不指明软件包的名字来运行“apt-get -f install”(也可以指定一个解决办法)。

我按照它的提示做了一遍也还是不能安装成功
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#6

帖子 zhuqin_83 » 2006-09-18 12:01

zlib1g装了没有?这两个包记得系统默认都已经安装了阿。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
xyqyahoo
帖子: 17
注册时间: 2006-09-17 22:38
送出感谢: 0
接收感谢: 0

#7

帖子 xyqyahoo » 2006-09-18 13:04

应该装了,因为我用dpkg装这个包时有提示
系统里的 zlib1g 的版本是 1:1.2.3-9
??
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#8

帖子 zhuqin_83 » 2006-09-18 13:07

那就是说,这两个软件都安装了。如果你觉得用终端不方便,不妨用一下新立得。
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
回复

回到 “老旧版本支持”