[问题]how to install GCC C++ and G++??(已解决)

为当前最终发行版之前的所有版本提供支持
回复
toto233
帖子: 15
注册时间: 2006-09-06 15:35
送出感谢: 0
接收感谢: 0

[问题]how to install GCC C++ and G++??(已解决)

#1

帖子 toto233 » 2006-09-18 20:55

i can't use gcc

and can't install it



jack@jack-sse:~$ sudo apt-get install gcc

下列的软件包有不能满足的依赖关系:
gcc: 依赖: cpp (>= 4:4.0.1-3) 但是它将不会被安装
依赖: gcc-4.0 (>= 4.0.1-2) 但是它将不会被安装
E: 无法安装的软件包
jack@jack-sse:~$ sudo apt-get install cpp

下列的软件包有不能满足的依赖关系:
cpp: 依赖: cpp-4.0 (>= 4.0.1-2) 但是它将不会被安装
E: 无法安装的软件包
jack@jack-sse:~$ sudo apt-get install cpp-4.0

下列的软件包有不能满足的依赖关系:
cpp-4.0: 依赖: gcc-4.0-base (= 4.0.1-4ubuntu9) 但是 4.0.3-1ubuntu5 正要被安装
E: 无法安装的软件包

jack@jack-sse:~$ sudo apt-get install gcc-4.0-base

gcc-4.0-base 已经是最新的版本了。
共升级了 0 个软件包,新安装了 0 个软件包,要卸载 0 个软件包,有 0 个软件未被升级。

.........
same question with g++
附件
puzzle.png
比如这个图片显示的,右边说依赖libc6
但是我左边已经表示安装了libc6(虽然版本不同)
我也不知道怎么去搞他要的版本呀
上次由 toto233 在 2006-09-18 21:58,总共编辑 2 次。
toto233
帖子: 15
注册时间: 2006-09-06 15:35
送出感谢: 0
接收感谢: 0

#2

帖子 toto233 » 2006-09-18 21:14

那些包几乎是圈克,这个装不上因为依赖那个,那个又依赖另外的包,跑一圈最后需要的包我反而装上了。


也不敢卸那些包,牵一发而动全身。怕弄坏了又要重装,今天已经重装4次了。。。
firebird.002
帖子: 2
注册时间: 2006-09-08 21:23
送出感谢: 0
接收感谢: 0

#3

帖子 firebird.002 » 2006-09-18 21:18

try "sudo apt-get install build-essential"
toto233
帖子: 15
注册时间: 2006-09-06 15:35
送出感谢: 0
接收感谢: 0

#4

帖子 toto233 » 2006-09-18 21:27

这个命令我用过了,

下列的软件包有不能满足的依赖关系:
build-essential: 依赖: libc6-dev 但是它将不会被安装 或
libc-dev
依赖: gcc (>= 4:4.0) 但是它将不会被安装
依赖: g++ (>= 4:4.0) 但是它将不会被安装
E: 无法安装的软件包


我现在就想装上这几个
toto233
帖子: 15
注册时间: 2006-09-06 15:35
送出感谢: 0
接收感谢: 0

#5

帖子 toto233 » 2006-09-18 21:29

谢谢3楼的同志踊跃回答
toto233
帖子: 15
注册时间: 2006-09-06 15:35
送出感谢: 0
接收感谢: 0

搞定了

#6

帖子 toto233 » 2006-09-18 21:57

搞定了,原来是源设置的有问题,我用的是学校内的源,那个源并没怎么更新,所以软件有问题,用上外网的源后,再更新就好了,谢谢大家。

不过我们学校按流量收费,一更新银子花花的就没了。。。。还是用内网源省钱
iptton
帖子: 26
注册时间: 2007-05-06 10:58
送出感谢: 0
接收感谢: 0

#7

帖子 iptton » 2007-12-10 11:01

我也遇到这个问题了。。。
从7。04升级到7。10都不可以。。。

试下换源...
iptton
帖子: 26
注册时间: 2007-05-06 10:58
送出感谢: 0
接收感谢: 0

#8

帖子 iptton » 2007-12-10 11:02

原来是一年多前的由此子,汗 = =||
回复

回到 “老旧版本支持”