升级安装出错,求助!!!!

为当前最终发行版之前的所有版本提供支持
回复
funnychen
帖子: 9
注册时间: 2005-04-10 14:40
送出感谢: 0
接收感谢: 0

升级安装出错,求助!!!!

#1

帖子 funnychen » 2005-08-31 7:29

root@Fatty:/home/funnychen # apt-get upgrade
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
您也许需要运行“apt-get -f install”来纠正上面的错误。
下列的软件包有不能满足的依赖关系:
gnome-themes: 依赖: gtk2-engines-pixbuf (>= 2.0.2) 但是它还没有被安装
依赖: gtk2-engines-redmond95 (>= 2.2.0) 但是它还没有被 安装
gtk2-engines-spherecrystal: 依赖: gtk2-engines-pixbuf 但是它还没有被 安装
E: 不能满足依赖关系。不妨试一下 -f 选项。
root@Fatty:/home/funnychen # apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 完成
将会安装下列的额外的软件包:
gtk2-engines-pixbuf gtk2-engines-redmond95
建议安装的软件包:
gtk-engines-pixmap gtk-engines-redmond95
下列【新】软件包将被安装:
gtk2-engines-pixbuf gtk2-engines-redmond95
共升级了 0 个软件包,新安装了 2 个软件包,要卸载 0 个软件包,有 0 个软 件未被升级。
有 137 个软件包没有被完全安装或卸载。
需要下载 0B/77.4kB 的软件包。
解压缩后会消耗掉 266kB 的额外空间。
您希望继续执行吗?[Y/n]y

Preconfiguring packages ...
(正在读取数据库 ... 系统当前总共安装有 98952 个文件和目录。)
正在解压缩 gtk2-engines-pixbuf (从 .../gtk2-engines-pixbuf_2.6.4-0ubuntu3_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gtk2-engines-pixbuf_2.6.4-0ubuntu3_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gtk-2.0/2.4.0/engines/libpixmap.la”,它属于软件包 gtk2-devel
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
正在解压缩 gtk2-engines-redmond95 (从 .../gtk2-engines-redmond95_1%3a2.6.2-0ubuntu2_i386.deb) ...
dpkg:处理 /var/cache/apt/archives/gtk2-engines-redmond95_1%3a2.6.2-0ubuntu2_i386.deb (--unpack)时出错:
正试图覆盖“/usr/lib/gtk-2.0/2.4.0/engines/libredmond95.so”,它属于软件包 gtk2-engines
dpkg-deb: 子进程 paste 被信号(断开的管道)终止了
在处理时有错误发生:
/var/cache/apt/archives/gtk2-engines-pixbuf_2.6.4-0ubuntu3_i386.deb
/var/cache/apt/archives/gtk2-engines-redmond95_1%3a2.6.2-0ubuntu2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@Fatty:/home/funnychen #
zh00yi
帖子: 27
注册时间: 2005-07-29 21:06
送出感谢: 0
接收感谢: 0

#2

帖子 zh00yi » 2005-08-31 13:50

关注!
我平常apt-get update
funnychen
帖子: 9
注册时间: 2005-04-10 14:40
送出感谢: 0
接收感谢: 0

#3

帖子 funnychen » 2005-08-31 14:01

先apt-get update
再apt-get upgrade
上边出错是因为
apt-get install gnome
所遗留下的问题!!
求助!!!
头像
yonsan
帖子: 887
注册时间: 2005-07-01 18:56
来自: 广州市
送出感谢: 0
接收感谢: 3 次

#4

帖子 yonsan » 2005-08-31 15:13

funnychen 写了:先apt-get update
再apt-get upgrade
上边出错是因为
apt-get install gnome
所遗留下的问题!!
求助!!!


用现在使用的是breezy吗?
zh00yi
帖子: 27
注册时间: 2005-07-29 21:06
送出感谢: 0
接收感谢: 0

#5

帖子 zh00yi » 2005-08-31 15:37

会不会是apt源的问题???
头像
firehare
论坛版主
帖子: 2625
注册时间: 2005-04-10 16:54
来自: 温州大学
送出感谢: 0
接收感谢: 2 次
联系:

#6

帖子 firehare » 2005-08-31 16:25

其实最好是
sudo apt-get update
sudo apt-get dist-upgrade
这样的话会比较好点!
我心无畏,源自于我心无知。
图片
funnychen
帖子: 9
注册时间: 2005-04-10 14:40
送出感谢: 0
接收感谢: 0

#7

帖子 funnychen » 2005-08-31 17:29

因该不会是apt源的问题,因为都是ubuntu的源!!!
我在安装Bootsplash的时候也出现过这种情况,也一直没有解决!!
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#8

帖子 gnix_oag » 2005-08-31 20:01

有冲突了

:(
funnychen
帖子: 9
注册时间: 2005-04-10 14:40
送出感谢: 0
接收感谢: 0

#9

帖子 funnychen » 2005-08-31 22:35

那该怎么解决呢??请指教!!!
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#10

帖子 oneleaf » 2005-08-31 22:49

删除所有的X。直到使用 apt-get dist-upgrade 没有任何问题。
再安装 apt-get install ubuntu-desktop
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
头像
gnix_oag
帖子: 1994
注册时间: 2005-05-19 18:38
来自: 湖南永州
送出感谢: 0
接收感谢: 1 次
联系:

#11

帖子 gnix_oag » 2005-09-01 11:47

又要发点时间下载了,

想深入了解,还有以下方法

http://forum.ubuntu.org.cn/viewtopic.php?t=2504
funnychen
帖子: 9
注册时间: 2005-04-10 14:40
送出感谢: 0
接收感谢: 0

#12

帖子 funnychen » 2005-09-01 12:17

多谢各位高手指教,但还一个问题指教:如何删除所有X???
头像
oneleaf
论坛管理员
帖子: 10208
注册时间: 2005-03-27 0:06
系统: Ubuntu 12.04
送出感谢: 7 次
接收感谢: 99 次

#13

帖子 oneleaf » 2005-09-01 12:56

学会 aptitude
当净其意如虚空,远离妄想及诸取,令心所向皆无碍
回复

回到 “老旧版本支持”