当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 8 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : 如何强制卸载VIM?
帖子发表于 : 2010-01-17 15:12 
头像

注册: 2008-08-22 20:36
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
我的 ubuntu 9.04上面自带的vim 有错误 每次安装新安装包的时候,都因为这个错误没法安装


用apt-get install vim 安装 说最新版 不需要升级,我想卸载后重装,卸载的时候终端显示:

(正在读取数据库 ... 系统当前总共安装有 136011 个文件和目录。)
正在删除 vim ...
update-alternatives: 无法创建 /usr/share/man/it.UTF-8/man1/vi.1.gz.dpkg-tmp 为 /etc/alternatives/vi.it.UTF-8.1.gz 的符号链接(symlink):没有该文件或目录
dpkg:处理 vim (--remove)时出错:
子进程 pre-removal script 返回了错误号 2
update-alternatives: 无法创建 /usr/share/man/it.UTF-8/man1/vi.1.gz.dpkg-tmp 为 /etc/alternatives/vi.it.UTF-8.1.gz 的符号链接(symlink):没有该文件或目录
dpkg: 作下列清理工作时发生错误:
子进程 post-installation script 返回了错误号 2
在处理时有错误发生:
vim
:em20 :em20 :em20 应该怎么办?

求助 一


页首
 用户资料  
 
2 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 15:33 

注册: 2009-04-29 21:22
帖子: 1081
送出感谢: 3
接收感谢: 1
可以试着重装一下,重装命令:
sudo apt-get --reinstall install vim

不知你用的是什么卸载命令,推荐:
sudo apt-get purge vim


页首
 用户资料  
 
3 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 15:40 

注册: 2007-10-08 16:45
帖子: 82
送出感谢: 0 次
接收感谢: 0 次
zodboyer 写道:
我的 ubuntu 9.04上面自带的vim 有错误 每次安装新安装包的时候,都因为这个错误没法安装


用apt-get install vim 安装 说最新版 不需要升级,我想卸载后重装,卸载的时候终端显示:

(正在读取数据库 ... 系统当前总共安装有 136011 个文件和目录。)
正在删除 vim ...
update-alternatives: 无法创建 /usr/share/man/it.UTF-8/man1/vi.1.gz.dpkg-tmp 为 /etc/alternatives/vi.it.UTF-8.1.gz 的符号链接(symlink):没有该文件或目录
dpkg:处理 vim (--remove)时出错:
子进程 pre-removal script 返回了错误号 2
update-alternatives: 无法创建 /usr/share/man/it.UTF-8/man1/vi.1.gz.dpkg-tmp 为 /etc/alternatives/vi.it.UTF-8.1.gz 的符号链接(symlink):没有该文件或目录
dpkg: 作下列清理工作时发生错误:
子进程 post-installation script 返回了错误号 2
在处理时有错误发生:
vim
:em20 :em20 :em20 应该怎么办?

求助 一


不知道所谓到强制卸载是个啥子意思,难道就卸载还卸载不了嘛?如果是正在运行到东西,先去进程管理器里找到把它杀死,然后在应用程序最下面一个,UBUNTU软件中心搜索下VIM,然后点右边到箭头,不就有移除?
你的问题好奇怪的说。。。


页首
 用户资料  
 
4 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 15:41 
头像

注册: 2008-08-22 20:36
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
x谢谢 LS的
可还是不行阿
我用的 apt-get remove vim


页首
 用户资料  
 
5 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 15:49 
头像

注册: 2008-08-22 20:36
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
E: vim-gnome: 子进程 pre-removal script 返回了错误号 2

出现这个提示。。。。。怎么办


页首
 用户资料  
 
6 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 19:35 
头像

注册: 2010-01-13 9:54
帖子: 41
送出感谢: 0 次
接收感谢: 0 次
到新立德里搜搜看看


_________________
"More people willing to give their souls for what they desire..."


页首
 用户资料  
 
7 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-17 20:04 
头像

注册: 2009-02-07 18:01
帖子: 200
送出感谢: 0 次
接收感谢: 0 次
我记得可以重整apt的一个文件的............
具体忘了
viewtopic.php?f=77&t=243553&view=next
这个看看有没有帮助


页首
 用户资料  
 
8 楼 
 文章标题 : Re: 如何强制卸载VIM?
帖子发表于 : 2010-01-18 11:35 
头像

注册: 2008-08-22 20:36
帖子: 36
送出感谢: 0 次
接收感谢: 0 次
又重新装了一遍VIM 不知道BUG修复了没有。。。
以后再说吧

现凑合用


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 8 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 5 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译