当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 2 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : apt安装软件的旧版本问题
帖子发表于 : 2010-01-25 10:52 
头像

注册: 2008-01-10 18:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
今天一直忙着搞Ubuntu下的mplayer 为了看rmvb的视频。
安装软件 安装解码器 安装皮肤 一大堆操作之后终于看上视频了
但是每次启动都会报错 could not open required directshow codec drvc.dll。
上网一搜说用下面方法解决
ldd /usr/lib/codecs/drvc.so
显示出有一个包找不到
libstdc++.so.5 => not found
在上网搜 又说要安装这个包。结果找到一大堆关于yum命令安装的帖子。
在这里小小抱怨一下,搜同样一个问题就拿安装软件来说吧。
给出yum的就一定比apt的多得多。yum是redhat下的吧?我也不太懂。大概是这么个意思
最重点是执行命令时候 sudo apt-get install libstdc++.so.5 他跟我说没有这个包。意思大概是过期了,现在有更新的了。
更SB得是我装了个libstdc6的包居然还不行 他脑子一根筋 就知道要5的。给我搞崩溃了。
apt那个libstdc++.so.5的包还说找不到,气人。但是我看他们用yum命令就能安装哪些过期的旧的版本的软件包了,是吗?
怎么才能解决我这种情况呢,现在我正在网上直接找那个包的下载呢,不用apt了。希望能好使。

在csdn上下了一个那个包,放到/usr/lib下面了 这次ldd发现不缺包了 但是打开mplayer还是报那个错误。坐等高手解答。


页首
 用户资料  
 
2 楼 
 文章标题 : Re: apt安装软件的旧版本问题
帖子发表于 : 2010-01-25 16:03 
头像

注册: 2008-01-10 18:37
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
太没人性了 没人帮我? 我问题表达不清楚还是没人会?


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 2 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:没有注册用户 和 3 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译