【求助】CDMA 1X USB无线网卡驱动

为当前最终发行版之前的所有版本提供支持
回复
头像
sandana
帖子: 8
注册时间: 2010-01-30 11:56
送出感谢: 0
接收感谢: 0

【求助】CDMA 1X USB无线网卡驱动

#1

帖子 sandana » 2010-01-30 12:09

小弟新装了Ubuntu9.10 有一张CDMA 1X USB无线网卡 不知道如何安装驱动并使用,望各位大大给个建议,谢谢

(网卡是朋友给的,自动拨号,我也不知道密码....)
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

Re: 【求助】CDMA 1X USB无线网卡驱动

#2

帖子 sanz » 2010-01-30 13:28

1 、确认安装setserial, wvdial

2、sudo vim /etc/wvdial.conf
------------分割符号-----------
[Dialer Defaults]
Phone = #777
Username = CARD
Password = CARD
New PPPD = yes
---------------分割符号----------
(注:你不会要把分割符号---- 一行也放在文件里吧?!)

3、chmod 666 /etc/ppp/chapsecret
chmod 666 /etc/ppp/papsecrests

4、dmesg | grep tty
看结果,比如如果是 ttyS1则下面命令,否则相应改动:
sudo ln -sf /dev/ttyS1 /dev/modem
sudo setserial /dev/ttyS1 baud_base 230400
sudo route add default ppp0
wvdial
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

Re: 【求助】CDMA 1X USB无线网卡驱动

#3

帖子 sanz » 2010-01-30 13:30

我是一个杂牌的PCICA卡,和你的USB有可能不一样,不过原理应该是一样的。如果有错误就放狗搜。
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
sanz
帖子: 1009
注册时间: 2006-09-29 5:11
送出感谢: 11 次
接收感谢: 5 次

Re: 【求助】CDMA 1X USB无线网卡驱动

#4

帖子 sanz » 2010-01-30 13:39

再补充一句,UBUNTU下没有也不需要你所要的“驱动”,以上步骤就是手动完成“驱动”并拨号的过程。前提是你要有SIM卡放在里面哦!
上面第4步是每次上网都需要的拨号过程,可以放进一个文件作为每次上网的自动执行程序比如shangwang.sh。(不要告诉我你不会)。前面的是一次性的设置。最后一个命令执行后,很快就会出来提示告诉你DNS网关之类的地址信息,然后就可以上网了。(有时候可能默认网关没有刷新,提示上不了网,可以再次手动运行倒数第2行命令。一般情况下这样就可以上网了。极少数情况下,还是有问题,就拔下网卡或者插拔SIM卡后重来就OK)
Dell D620 -> Asus U44SG
Dapper->Edgy->Feisty->Gutsy->Hardy->Karmic->Lucid -> Oneric -> Precise->Trusty
Python+JS
头像
sandana
帖子: 8
注册时间: 2010-01-30 11:56
送出感谢: 0
接收感谢: 0

Re: 【求助】CDMA 1X USB无线网卡驱动

#5

帖子 sandana » 2010-01-30 13:46

呵呵,我是新手,不太懂.....谢谢这位大哥了,我自己先折腾去了
Laptop: ThinkPad SL (Intel Centrino 2)---T5 2.0G/2G/ICH9M-GM45
Desktop OS: WinXP Pro / Ubuntu 9.10
Orientation: IEEE==DUTCl/MOATOOE/MOP
http://forum.ubuntu.org.cn
E-mail: csandana0@gmail.com
回复

回到 “老旧版本支持”