当前时区为 UTC + 8 小时



发表新帖 回复这个主题  [ 3 篇帖子 ] 
作者 内容
1 楼 
 文章标题 : ubuntu 9.10更新出现错误 无法使用 groupadd
帖子发表于 : 2010-02-01 22:53 

注册: 2010-02-01 22:46
帖子: 1
送出感谢: 0 次
接收感谢: 0 次
我的ubuntu是安装在虚拟机上的,直接用的ubuntu 9.10的ISO镜像。第一次联网更新就出现了问题。下面是安装其他软件时出现的错误信息:

正在设置 postfix (2.6.5-3) ...
正在添加组"postfix" (GID 121)...
groupadd: cannot lock /etc/gshadow; try again later.
addgroup:"/usr/sbin/groupadd -g 121 postfix"返回错误代码 10,退出。

dpkg:处理 postfix (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 1
dpkg:依赖关系问题使得 bsd-mailx 的配置工作不能继续:
bsd-mailx 依赖于 postfix | mail-transport-agent;然而:
软件包 postfix 还没有被配置。
未曾安装软件包“mail-transport-agent”。
软件包 postfix 提供了 mail-transport-agent,但是它还没有配置好。
dpkg:处理 bsd-mailx (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 policykit (0.9-4ubuntu1) ...
没有写入 apport 报告,因为错误信息指示它是从上一个失败导致的。
groupadd: cannot lock /etc/gshadow; try again later.
adduser:"/usr/sbin/groupadd -g 121 polkituser"返回错误代码 10,退出。
dpkg:处理 policykit (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 1
dpkg:依赖关系问题使得 kdebase-workspace-bin 的配置工作不能继续:
kdebase-workspace-bin 依赖于 policykit;然而:
软件包 policykit 还没有被配置。
dpkg:处理 kdebase-workspace-bin (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 k3b 的配置工作不能继续:
k3b 依赖于 kdebase-workspace-bin;然而:
软件包 kdebase-workspace-bin 还没有被配置。
dpkg:处理 k3b (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kubuntu-desktop 的配置工作不能继续:
kubuntu-desktop 依赖于 kdebase-workspace-bin;然而:
软件包 kdebase-workspace-bin 还没有被配置。
dpkg:处理 kubuntu-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 mailx 的配置工作不能没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
继续:
mailx 依赖于 bsd-mailx;然而:
软件包 bsd-mailx 还没有被配置。
dpkg:处理 mailx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 plasma-widget-networkmanagement 的配置工作不能继续:
plasma-widget-networkmanagement 依赖于 kdebase-workspace-bin;然而:
软件包 kdebase-workspace-bin 还没有被配置。
dpkg:处理 plasma-widget-networkmanagement (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 policykit-gnome 的配置工作不能继续:
policykit-gnome 依赖于 policykit;然而:
软件包 policykit 还没有被配置。
dpkg:处理 policykit-gnome (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 kpackagekit 的配置工作不能继续:
kpackagekit 依赖于 kdebase-workspace-bin;然而:
软件包 kdebase-workspace-bin 还没有被配置。
dpkg:处理 kpackagekit (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 update-notifier-kde 的配置工作不能继续:
update-notifier-kde 依赖于 kpackagekit;然而:
软件包 kpackagekit 还没有被配置。
dpkg:处理 update-notifier-kde (--configure)时出错:
依赖关系问题 - 仍未被配置
正在设置 winbind (2:3.4.0-3ubuntu5.4) ...
groupadd: cannot lock /etc/gshadow; try again later.
addgroup:"/usr/sbin/groupadd -g 121 winbindd_priv"返回错误代码 10,退出。
dpkg:处理 winbind (--configure)时出错:
子进程 已安装的 post-installation 脚本 返回了错误号 1
dpkg:依赖关系问题使得 lsb-core 的配置工作不能继续:
lsb-core 依赖于 postfix | mail-transport-agent;然而:
软件包 postfix 还没有被配置。
未曾安装软件包“mail-transport-agent”。
软件包 postfix 提供了 mail-transport-agent,但是它还没有配置好。
lsb-core 依赖于 mailx | mailutils;然而:
软件包 mailx 还没有被配置。
软件包 bsd-mailx 提供了 mailx,但是它还没有配置好。
未曾安装软件包“mailutils”。
dpkg:处理 lsb-core (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-graphics 的配置工作不能继续:
lsb-graphics 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-graphics (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使�没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
没有写入 apport 报告,因为已经达到最大报告数
�� lsb-cxx 的配置工作不能继续:
lsb-cxx 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
dpkg:处理 lsb-cxx (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb-desktop 的配置工作不能继续:
lsb-desktop 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
dpkg:处理 lsb-desktop (--configure)时出错:
依赖关系问题 - 仍未被配置
dpkg:依赖关系问题使得 lsb 的配置工作不能继续:
lsb 依赖于 lsb-core;然而:
软件包 lsb-core 还没有被配置。
lsb 依赖于 lsb-graphics;然而:
软件包 lsb-graphics 还没有被配置。
lsb 依赖于 lsb-cxx;然而:
软件包 lsb-cxx 还没有被配置。
lsb 依赖于 lsb-desktop;然而:
软件包 lsb-desktop 还没有被配置。
dpkg:处理 lsb (--configure)时出错:
依赖关系问题 - 仍未被配置
正在处理用于 libc-bin 的触发器...
ldconfig deferred processing now taking place
在处理时有错误发生:
postfix
bsd-mailx
policykit
kdebase-workspace-bin
k3b
kubuntu-desktop
mailx
plasma-widget-networkmanagement
policykit-gnome
kpackagekit
update-notifier-kde
winbind
lsb-core
lsb-graphics
lsb-cxx
lsb-desktop
lsb
E: Sub-process /usr/bin/dpkg returned an error code (1)

我想问题就应该是groupadd这里出了问题 ,但即便用root账户也无法添加postfix组。

恳请各位给予提示 谢谢


页首
 用户资料  
 
2 楼 
 文章标题 : Re: ubuntu 9.10更新出现错误 无法使用 groupadd
帖子发表于 : 2010-04-03 0:55 
头像

注册: 2008-04-18 10:11
帖子: 19
送出感谢: 0 次
接收感谢: 0 次
同问。
我的不是虚拟机


_________________
从来就没有什麽救世主
也不靠神仙皇帝
要创造人类的幸福全靠我们自己!


页首
 用户资料  
 
3 楼 
 文章标题 : Re: ubuntu 9.10更新出现错误 无法使用 groupadd
帖子发表于 : 2010-08-16 20:24 

注册: 2010-08-11 21:03
帖子: 2
送出感谢: 0 次
接收感谢: 0 次
同问 我的是虚拟机 vm7


页首
 用户资料  
 
显示帖子 :  排序  
发表新帖 回复这个主题  [ 3 篇帖子 ] 

当前时区为 UTC + 8 小时


在线用户

正在浏览此版面的用户:Google [Bot] 和 4 位游客


不能 在这个版面发表主题
不能 在这个版面回复主题
不能 在这个版面编辑帖子
不能 在这个版面删除帖子
不能 在这个版面提交附件

前往 :  
本站点为公益性站点,用于推广开源自由软件,由 DiaHosting VPSBudgetVM VPS 提供服务。
我们认为:软件应可免费取得,软件工具在各种语言环境下皆可使用,且不会有任何功能上的差异;
人们应有定制和修改软件的自由,且方式不受限制,只要他们自认为合适。

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
简体中文语系由 王笑宇 翻译