[分享]debian包安装碰到依赖问题时,最好用源程序编译安装

为当前最终发行版之前的所有版本提供支持
回复
onandon
帖子: 29
注册时间: 2006-02-12 18:48
送出感谢: 0
接收感谢: 0

[分享]debian包安装碰到依赖问题时,最好用源程序编译安装

#1

帖子 onandon » 2006-09-24 1:57

今天用debbian包装texmaker,要求libc6>= 2.3.6-6,但是源里面的仅仅是2.3.6;所以下debian包升级,结果升级后紧跟着要升其他的包,搞了一晚上现在才搞定,最后还剩几个包,懒得搞了,直接删掉了,跟带着自动删了大约10个包,以后有问题再说了

中间去ubuntuforums.org搜过相关的问题,大家也没什么好的解决方法,如使用force version;有的人用force version能搞定问题,不过对libc6使用force version,基本整个系统就被卸掉了。

总结一点教训:
library相关的包还是用synapatic package manager升好,否则出问题真的是麻烦大
碰到依赖问题的时候,最好用源程序编译安装
回复

回到 “老旧版本支持”