在fix the broken the packages时,给出了如下出错信息,清大虾给个解决的思路

为当前最终发行版之前的所有版本提供支持
回复
alexxue_1978
帖子: 18
注册时间: 2006-09-13 13:13
送出感谢: 0
接收感谢: 0
联系:

在fix the broken the packages时,给出了如下出错信息,清大虾给个解决的思路

#1

帖子 alexxue_1978 » 2006-09-26 19:53

E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。

E: Unable to correct dependencies
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: Unable to correct dependencies



问题: 我怎么找到这些不能逆转依赖性问题的包,然后如何删除?
我把昨天安装过的软件包不论成不成功的都用删了一遍,但是依然不能解决问题。

在终端中:
$ sudo apt-get -f install
正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
正在更正依赖关系... 失败。
下列的软件包有不能满足的依赖关系:
libc6: 依赖: tzdata 但却无法安装它
libc6-dev: 依赖: libc6 (= 2.3.6-0ubuntu20) 但是 2.3.6.ds1-4 已经安装了
libc6-i686: 预依赖: libc6 (= 2.3.6-0ubuntu20) 但是 2.3.6.ds1-4 已经安装了
E: 错误,pkgProblemResolver::Resolve 发生故障,这可能是有软件包被要求保持现状的缘故。
E: 无法更正依赖关系
头像
eexpress
帖子: 58428
注册时间: 2005-08-14 21:55
来自: 长沙
送出感谢: 4 次
接收感谢: 256 次

#2

帖子 eexpress » 2006-09-26 22:41

是libc6的几个版本太高了。新利得里面找破损的包,一次全部选择删除。高版本的少安装,新利得里面强制降低版本。
● 鸣学
sunrie
帖子: 5
注册时间: 2006-04-26 11:13
送出感谢: 0
接收感谢: 0

#3

帖子 sunrie » 2006-09-28 21:17

我也遇到同样的问题了,我是手工安装了从debian下载的包,因为我要安装的软件需要新版本的libc6,就去debian下了回来,结果就出问题,搞得头都大了。
楼主试试我的方法吧:

sudo apt-get install -f libc6=2.3.6-0ubuntu20 libatk1.0-0=1.11.4-0ubuntu1

ubuntu的更新也太慢了吧,考虑换debian算了! :(
回复

回到 “老旧版本支持”