firefox3.6如何安装java插件?

为当前最终发行版之前的所有版本提供支持
回复
罗非鱼
帖子: 980
注册时间: 2008-04-12 12:44
送出感谢: 1 次
接收感谢: 2 次

firefox3.6如何安装java插件?

#1

帖子 罗非鱼 » 2010-02-25 22:50

我的系统ubuntu9.1,firefox3.6,由于一个网站需要使用最新版本jre1.0.6_18,(java的最新版),我卸载了ubuntu的java jre,安装好了jre1.0.6_18,随后
1、我设置好了环境变量
2、安装浏览器插件
sudo ln -vs $(find . -name libnpjp2.so) /usr/lib/firefox/plugins
安装完成后,发现问题,根本无法使用,打我打开那个需要java插件的网站时,没有任何反应。
于是,我用xp系统,发现也必须更新到jre1.0.6_18,到sun的网站,找到window版本的jre,下载后,点击安装,打开那个网站,很好,ok,工作完成。

pt@pt-laptop:~$ sudo ln -vs /home/pt/jre1.6.0_18/plugins/i386/ns7/libjavaplugin_oji.so /usr/lib/firefox/plugins
`/usr/lib/firefox/plugins/libjavaplugin_oji.so' -> `/home/pt/jre1.6.0_18/plugins/i386/ns7/libjavaplugin_oji.so'
pt@pt-laptop:~$ sudo ln -vs /home/pt/jre1.6.0_18/plugins/i386/ns7-gcc29/libjavaplugin_oji.so /usr/lib/firefox/plugins
ln: creating symbolic link `/usr/lib/firefox/plugins/libjavaplugin_oji.so': File exists
使用这些命令也不行。

现在请教,ubuntu+firefox3.6,如何正确安装java plugins?
我在浏览器中输入,about :plugins,显示的结果:
Shockwave Flash

File: libflashplayer.so
Version:
Shockwave Flash 10.0 r45



VLC Multimedia Plugin (compatible Totem 2.28.2)

File: libtotem-cone-plugin.so
Version:
The Totem 2.28.2 plugin handles video and audio streams.


Windows Media Player Plug-in 10 (compatible; Totem)

File: libtotem-gmp-plugin.so
Version:
The Totem 2.28.2 plugin handles video and audio streams.


DivX® Web Player

File: libtotem-mully-plugin.so
Version:
DivX Web Player version 1.4.0.233

MIME Type Description Suffixes Enabled
video/divx AVI video divx Yes
QuickTime Plug-in 7.2.0

File: libtotem-narrowspace-plugin.so
Version:
The Totem 2.28.2 plugin handles video and audio streams.
没有看见java plugins的字样。
请问,应该如何安装?
bodhi
帖子: 789
注册时间: 2006-10-14 22:07
送出感谢: 0
接收感谢: 0

Re: firefox3.6如何安装java插件?

#2

帖子 bodhi » 2010-02-26 16:59

1.6.0_18?

libnpjp2.so应该链接到这里吧:

代码: 全选

/usr/lib/mozilla/plugins/
或者,

代码: 全选

~/.mozilla/plugins/
opbsder
帖子: 48
注册时间: 2009-09-21 17:27
送出感谢: 0
接收感谢: 0
联系:

Re: firefox3.6如何安装java插件?

#3

帖子 opbsder » 2010-02-27 15:08

建议将你要打开的网站说明下 大家好进行测试
喀纳斯自由软件专卖店
出售Ubuntu 自启动优盘,各种linux DVD光盘,开源文化衫
提供各种linux解决方案。
每出售一件商品,将捐献一元给相关社区。
近期捐款将用于支持GNOME ASIA Summit 2010.
QQ:1217577689
MSN:kanas123@yahoo.cn
回复

回到 “老旧版本支持”