sudo apt-get build-dep gcc出现的问题,大家帮帮我

为当前最终发行版之前的所有版本提供支持
回复
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

sudo apt-get build-dep gcc出现的问题,大家帮帮我

#1

帖子 daqqk » 2006-09-27 12:34

出现如下错误:

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 您必须在您的 sources.list 写入一些“软件包源”的 URI

正在读取软件包列表... 完成
正在分析软件包的依赖关系树... 完成
E: 无法打开文件 /var/lib/apt/lists/cn.archive.ubuntu.com_ubuntu_dists_dapper_main_source_Sources - open (2 No such file or directory)

换了好几个源,在论坛,wiki,google上找了两 天也没找到答案,大家帮帮我吧
头像
zhuqin_83
帖子: 10606
注册时间: 2006-05-13 4:02
送出感谢: 0
接收感谢: 7 次
联系:

#2

帖子 zhuqin_83 » 2006-09-27 12:56

源没有设置好。如果要装gcc用sudo apt-get install build-essential
http://wiki.ubuntu.org.cn/%E5%BF%AB%E9% ... apperDrake
HP Pavilion DV6-2064CA: AMD Turion II Ultra Dual-Core Mobile M640, HD4650, 2GBx2 DDR2-800, Seagate 500GB 7200RPM SATA, BD-ROM
DELL UltraSharp 2209WA
Arch64, Testing repo
头像
BigSnake.NET
帖子: 12522
注册时间: 2006-07-02 11:16
来自: 廣州
送出感谢: 0
接收感谢: 7 次
联系:

#3

帖子 BigSnake.NET » 2006-09-27 12:57

sudo apt-get update
^_^ ~~~
要理解递归,首先要理解递归。

地球人都知道,理论上,理论跟实际是没有差别的,但实际上,理论跟实际的差别是相当大滴。
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

#4

帖子 daqqk » 2006-09-27 13:00

zhuqin_83
这里的源全试过了,都不行
BigSnake.NET
sudo apt-get update已经更新过了
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

#5

帖子 daqqk » 2006-09-27 13:04

就没人遇到过这种问题吗
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#6

帖子 karron » 2006-09-27 15:47

有关第一个问题,E: 您必须在您的 sources.list 写入一些“软件包源”的 URI

检查你sources.list,你可以看到在网址前面有个 deb ,这个表示是二进制包,如果要用到编译等使用的源代码等,需要用deb-src 来表示.所以操作方式是,把原来的deb的那些行复制一下,粘贴,把deb改成deb-src,注意,不要把包含有ubuntu-cn的那些源也修改,因为这里面没有源代码,包含进去会报错.


有关第二个问题,可能是当前源正在更新,或者更新不完整,你可以选择等待,可能要几个小时,也许是第二天,或者更久,看这个服务器的管理员了.如果你不愿意等待,你可以换一个源.


最后,楼主不要把同一个问题,到每个板块都粘贴一下.请自己把其他板块的帖子删除,这次就算了.以后还这样,可能会招致警告处分.
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

#7

帖子 daqqk » 2006-09-27 15:52

karron
好的,马上删

新手指南里的源也有src的,不过没用,试了N个源了,都不行
头像
karron
帖子: 6226
注册时间: 2005-06-11 14:03
来自: 不明真相的群众
送出感谢: 0
接收感谢: 0
联系:

#8

帖子 karron » 2006-09-27 17:29

把你的源贴出来看看.另外,修改了源之后必须 sudo apt-get update 更新包索引
我的blog,关于技术,软件,linux,vim <---- 所有博客均被河蟹.
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

#9

帖子 daqqk » 2006-09-27 21:28

karron
明白了,超级感谢
问题是在更新完源之后没有用sudo apt-get update 更新索引包
daqqk
帖子: 17
注册时间: 2006-09-24 2:42
送出感谢: 0
接收感谢: 0
联系:

#10

帖子 daqqk » 2006-09-27 21:28

BigSnake.NET
很遗憾没有领悟你的意思
回复

回到 “老旧版本支持”